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13.1.

Bit Lamp
Overview

Bit Lamp object displays the state of a designated bit address. If the bit state is OFF, the State 0
shape will be displayed. If the bit state is ON, the State 1 shape will be displayed.

Configuration

Click [Object] » [Bit Lamp] icon on the toolbar to open a Bit Lamp object property dialog box.
Set up the properties, press OK button, and a new Bit Lamp object will be created.
General Tab
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Setting

Description

Comment

User can describe the information of the object.
Bit Lamp / Toggle Switch
Switch between Bit Lamp and Toggle Switch features.

Read address

Click [Setting] to select the [PLC name], [Address], [Device type],
[System tag], [Index register] of the bit device that controls the [Bit
Lamp] object. Users can also set address in [General] tab while
adding a new object.
Invert signal
Reverses the display of ON / OFF states. For example, if [Invert
signal] check box is selected, when the designated bit is OFF, the
object displays ON state.

Blinking

The appearance of the object may alternate between states when
the bit is ON or OFF.
Mode:
None
No blinking.
Alternating image on state 0
The appearance of the object alternates between State 0 and 1
when the bit is OFF.
Alternating image on state 1
The appearance of the object alternates between State 0 and 1
when the bit is ON.
Blinking on state 0
The State 0 appearance of the object will blink when the bit is OFF.
Blinking on state 1
The State 1 appearance of the object will blink when the bit is ON.
Hide picture/shape if no corresponding picture for current state
If selected, when there are not enough pictures to represent all the
states, hides the picture. Otherwise, displays the last state.

Note


In [Label] tab, if select [ON=OFF (use state 0)] check box, both state 0 and 1 follow the
settings of state 0.
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13.2.

Word Lamp
Overview

Word Lamp object displays the state according to the value of a designated word register. Up to
256 states are available. When the value of the register is 0, State 0 appearance of the object is
displayed, and with the register value being 1 the object displays State 1, and so on.

Configuration

Click [Object] » [Word Lamp] icon on the toolbar to open a Word Lamp object property dialog
box. Set up the properties, press OK button, and a new Word Lamp object will be created.
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General Tab

Setting

Description

Comment

User can describe the information of the object.
Word Lamp / Multi-State Switch
Switch between Word Lamp and Multi-State Switch features.

Mode / Offset

Word Lamp object offers the following three modes:
Value
The state is displayed according to the value in the designated word
address and plus the [Offset].
As shown below, if the value within LW-200 is 3, since the offset is
set to 3, the shape of state 0 is displayed. (value 3 - offset 3)
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LSB
Convert the value from decimal to binary. The least significant
active bit in a binary data word selects the state displayed.
Decimal
Binary
Displayed state
0
0000000000000000 State = 0 when all bits are 0.
lowest non-zero bit is
1
0000000000000001 The
bit 0, state = 1.
lowest non-zero bit is
2
0000000000000010 The
bit 1, state = 2.
lowest non-zero bit is
3
0000000000000011 The
bit 0, state = 1.
4
0000000000000100 The lowest non-zero bit is
bit 2, state = 3.
lowest non-zero bit is
7
0000000000000111 The
bit 0, state = 1.
lowest non-zero bit is
8
0000000000001000 The
bit 3, state = 4.
lowest non-zero bit is
16
0000000000010000 The
bit 4, state = 5.
lowest non-zero bit is
32
0000000000100000 The
bit 5, state = 6.
lowest non-zero bit is
64
0000000001000000 The
bit 6, state = 7.
lowest non-zero bit is
128
0000000010000000 The
bit 7, state = 8.
lowest non-zero bit is
256
0000000100000000 The
bit 8, state = 9.
lowest non-zero bit is
512
0000001000000000 The
bit 9, state = 10.
lowest non-zero bit is
1024
0000010000000000 The
bit 10, state = 11.
lowest non-zero bit is
2048
0000100000000000 The
bit 11, state = 12.
lowest non-zero bit is
4096
0001000000000000 The
bit 12, state = 13.
lowest non-zero bit is
8192
0010000000000000 The
bit 13, state = 14.
lowest non-zero bit is
16384 0100000000000000 The
bit 14, state = 15.
lowest non-zero bit is
32768 1000000000000000 The
bit 15, state = 16.
Bit combination
Lamp state depends on the states of bit combinations, where PLC 1
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represents the least significant bit (LSB), PLC 2 represents the next
LSB, and so on. Maximum number of bit is 4, for a total of 16
states. Changing [No. of states] in Attribute group box changes the
number of read addresses.

Read address

Attribute

Change state by time
The state displayed changes on a time basis. The frequency can be
set.
Click [Setting] to select the [PLC name], [Address], [Device type],
[System tag], [Index register] of the word device that controls the
[Word Lamp] object. Users can also set address in [General] tab
while adding a new object.
No. of states
The number of states is utilized by the object. The state is
numbered from 0, so the number of states minus 1 will be the state
number. If the value within the word register is ≥ [No. of states]
defined in Attribute, the highest state will be displayed.
If the number of states is set to 8, the valid states will be 0, 1, 2, …,
7. In this case if the word value is 8 or higher, the system will
display the state 7 shape.
Hide picture/shape if no corresponding picture for current state
If selected, when there are not enough pictures to represent all the
states, hides the picture. Otherwise, displays the last state.

Note


In [Label] tab, Language 1 determines the relevant settings of the font. For Language 2~8,
only the font size can be changed and other settings follow Language 1.
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13.3.

Set Bit
Overview

The Set Bit object provides two operation modes: manual or automatic. Manual mode can
trigger a designated bit address to change the state between ON and OFF when the object is
touched. In automatic mode, the bit is automatically activated when a pre-defined condition
occurs; touching the button will not be effective.
Configuration

Click [Object] » [Set Bit] icon on the toolbar to open a Set Bit object property dialog box. Set up
the properties, press OK button, and a new Set Bit object will be created.
General Tab

Setting

Description

Write address

Click [Setting] to select the [PLC name], [Address], [Device type],
[System tag], [Index register] of the bit device that controls the Set
Bit object. Users can also set address in [General] tab while adding
a new object.
Write after button is released
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Mode / Offset

Macro

Trigger mode

If this function is selected, the action is delayed till button is
released; otherwise, the action is executed once the button is
pressed. This function does not work with momentary buttons.
Set style
Description
Set ON
Set ON the designated bit of the device.
Set OFF
Set OFF the designated bit of the device.
Toggle
Alternates the bit state each time pressed.
Momentary
Holds the bit ON only while button is
pressed.
Periodical toggle Set a designated bit ON and OFF at a set time
interval. Time interval can be selected; the
range is from 0.1 to 25.5 seconds.
Set ON when
Set ON the bit within the window when the
window opens
window opens.
Set OFF when
Set OFF the bit within the window when the
window opens
window opens.
Set ON when
Set ON the bit within the window when the
window closes
window closes.
Set OFF when
Set OFF the bit within the window when the
window closes
window closes.
Set ON when
Set the bit ON when the backlight is turned
backlight on
ON.
(N/A for
cMT-SVR)
Set OFF when
Set the bit OFF when the backlight is turned
backlight on
ON.
(N/A for
cMT-SVR)
Set ON when
Set the bit ON when the backlight is turned
backlight off
OFF.
(N/A for
cMT-SVR)
Set OFF when
Set the bit OFF when the backlight is turned
backlight off
OFF.
(N/A for
cMT-SVR)
Set Bit object can trigger the start of a Macro routine when the
Macro has been created in advance.
For more information, see “18 Macro References”.
If [Set style] is set to [Toggle], there is a further selection to make of
whether the macro operates after Off to ON, ON to OFF transition,
or at both of the changes of state.

Note


In [Label] tab, if select [ON=OFF (use state 0)] check box, both state 0 and 1 follow the
settings of state 0.
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Using address types other than PLB or PLW_Bit for Set Bit objects with [Periodic Toggle]
attribute is not supported by cMT-SVR.
The Set Style setting in the General tab determines which settings are available in the
Security tab. When the Set Style is [Set ON / OFF when window opens], there will be no
settings available in the Security tab.
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13.4.

Set Word
Overview

The Set Word object provides two operation modes: manual or automatic. Manual mode can
change the value in a designated word address when the object is touched. In automatic mode,
the word register is automatically activated when a pre-defined condition occurs; touching the
button will not be effective.
Configuration

Click [Object] » [Set Word] icon on the toolbar to open a Set Word object property dialog box.
Set up the properties, press OK button, and a new Set Word object will be created.
General Tab
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Setting

Description

Write address

Click [Setting] to select the [PLC name], [Address], [Device type],
[System tag], [Index register] of the word device that controls the
Set Word object. Users can also set address in [General] tab while
adding a new object.
Write after button is released
If this function is selected, the action is delayed till button is
released; otherwise, the action is executed once the button is
pressed.

Notification

If this check box is selected, it will notify a designated bit address
(setting ON or OFF).
Before writing / After writing
Set the state of the designated bit address before or after the
manual operation.

Attribute

Set Style
Select the button action from the drop down list, see Example 2.
Dynamic limits
Set the [Bottom limit] and [Upper limit] by a designated register,
see Example 1.

Example 1
Set the [Bottom limit] and [Upper limit] by a designated register. When Dynamic Address is
LW-n, where n is an arbitrary number, the rule of setting Upper / Bottom limit is:
Content

16-bit

32-bit

64-bit (cMT / cMT X only)

Dynamic address

LW-n

LW-n

LW-n

Bottom limit

LW-n

LW-n

LW-n

Upper limit

LW-n+1

LW-n+2

LW-n+4

When Dynamic Address is LW-100, the rule of setting Upper / Bottom limit is:
Content

16-bit

32-bit

64-bit (cMT / cMT X only)

Dynamic address

LW-100

LW-100

LW-100

Bottom limit

LW-100

LW-100

LW-100

Upper limit

LW-101

LW-102

LW-104

Example 2
The available button actions are:
 Write constant value
Write a preset value. Each time the button is pressed, the value in [Set value] is written to the
designated register. Data format is as set by the [Write address] above; it can be 16-bit BCD,
32-bit BCD, …64-bit Double. In the following figure, when the button is pressed, the number
12 is written to the designated register.
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 Write constant string (cMT / cMT X only)
Write a preset string. Each time the button is pressed, the string in [Set string] is written to the
designated register. The string format can be: UTF-8, Unicode, Latin-1…etc. In the following
figure, when the button is pressed, the string “abcd” is written to the designated register.

 Increment value (JOG+)
Increase value in register by a set amount in [Inc. value], each time when the button is pressed,
up to the [Upper limit]. As shown below, each button press increases the value in the register
by 1 until the value is 10.

 Decrement Value (JOG-)
Decrease value in register by a set amount in [Dec. value], each time when the button is
pressed, down to the [Bottom limit]. As shown below, each button press decreases the value in
the register by 1 until the value is 0.



Bounce (up->down->up) (cMT / cMT X only)
Each time when the button is pressed, the value in the register is increased by the [Inc.
value] until the [High limit] is reached, and then the value is decreased by the [Inc. value],
each time when the button is pressed, down to the [Low limit]. As shown below, the
system will increase the value in the register by 1 each time when the button is pressed,
until the value is 10, and then decrease the value by 1 each time when the button is
pressed, until the value is 0, and then increase the value again.
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 Press and hold increment (JOG++)
When the button is held longer than a set time in [JOG delay], it will increase the value in a
register by a set amount :[Inc. value] at a set rate :[JOG speed], to the [Upper limit].
As shown below, when the button is pressed, it increases the value in the designated register
by 1. When the button is held longer than 1 second, it increases the value in register by 1 every
0.5 second, till the value is 10.

 Press and hold increment (JOG--)
When the button is held longer than a set time in [JOG delay], it will decrease the value in a
register by a set amount: [Dec. value] at a set rate: [JOG speed], to the [Bottom limit].
As shown below, when the button is pressed, it decreases the value in the designated register
by 1. When the button is held longer than 1 second, it decreases the value in register by 1
every 0.5 second, till the value is 0.

 Periodic JOG++
This automatic function increases the value in the register by a set amount: [Inc. value], at a set
rate: [Time interval], to the [Upper limit]. As shown below, the system will automatically
increase the value in the register by 1 every 0.5 second, till the value is 10. Then the value
returns to 0 and add 1 every 0.5 second again.
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Automatic JOG++

This automatic function increases the value in the register by a set amount: [Inc. value], at a set
rate: [Time interval], to the [Upper limit].then holds this value. As shown below, the system will
automatically increase the value in the register by 1 every 0.5 second, till the value is 10, and
then stop.

 Automatic JOG-This automatic function decreases the value in the register by a set amount: [Dec. value], at a
set rate: [Time interval], to the [Bottom limit].then holds this value. As shown below, the
system will automatically increase the value in the register by 1 every 0.5 second, till the value
is 10, and then stop.

 Periodic bounce
Increases the word address value to the [Upper limit] by a [Inc. value] at a set rate in [Time
interval], then decreases to the [Bottom limit] by the same value at the same rate. As shown
below, the system will increase the value in the designated register by 1 every 0.5 second, till
the value is 10, and then decrease the value by 1 every 0.5 second till the value is 0 whenever
the screen is active.
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 Periodic step up
Step up to the [High limit] by [Inc. value] at a set rate in [Time interval], then reset immediately
to the [Low limit]. The action repeats whenever the screen is active. As shown below, the
system will increase the value in the designated register by 1 every 0.5 second, till the value is
10, and then reset to 0 and increase again, and the action repeats.

 Periodic step down
Step down to the [Low limit] by [Dec. value] at a set rate in [Time interval], then reset
immediately to the [High limit]. The action repeats whenever the screen is active. As shown
below, the system will decrease the value in the designated register by 1 every 0.5 second, till
the value is 0, and then reset to 10 and decrease again, and the action repeats.

 Set when window opens / Set when window closes
Automatic function occurs whenever the screen is active. The value entered in [Set value] is set
into the word address when the action occurs. If [Set value] is set to 5, when the window
opens / closes, the system enters 5 into the designated register.
 Set when backlight on / Set when backlight off (Not supported on cMT-SVR)
Automatic function occurs whenever the backlight is active. The value entered in [Set value] is
set into the word address when the action occurs. If [Set value] is set to 5, when the backlight
turns ON / OFF, the system sets 5 into the designated register.
 Cyclic JOG+
Each time when the button is pressed, increases the word address value to the [Upper limit] by
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[Inc. value] then reset to the [Bottom limit]. As shown below, each time when pressing the
button, the system will increase the value in the designated register by 1, till the value is 10,
and then reset to 0 and increase again by pressing the button.

 Cyclic JOGEach time when the button is pressed, decrease the word address value to the [Bottom limit]
by [Dec. value] then reset to the [Upper limit]. As shown below, each time when pressing the
button, the system will decrease the value in the designated register by 1, till the value is 0,
and then reset to 10 and decrease again by pressing the button.

 Cyclic JOG++
When the button is held longer than a set time in [JOG delay], it increases the value in a
register by a set amount in [Inc. value] at a set rate in [JOG speed], to the [Upper limit], then
reset to the [Bottom limit]. As shown below, when the button is held longer than 0.5 second,
increase the value in the designated register by 1 every 0.1 second, till the value is 10, and then
reset to 0 and increase again by holding the button.

 Cyclic JOG- When the button is held longer than a set time in [JOG delay], decrease the value in a register
by a set amount in [Dec. value] at a set rate in [JOG speed], to the [Bottom limit], then reset to
the [Upper limit]. As shown below, when the button is held longer than 0.5 second, decrease
the value in the designated register by 1 every 0.1 second, till the value is 0, and then reset to
10 and decrease again by holding the button.
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 Object Control Command (cMT / cMT X only)
Listed for selection are commands (with their corresponding command values) available for
the control address of various functions. For a given function, with write address set to its
control address, Set Word writes the command value and achieves function control.

 System Tag Command (cMT / cMT X only)
When a system tag is set as write address, for example, LW-9134: Language Mode, the
commands relating to the system tag can be selected.
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Setting
Interlock

Description
Use interlock function
When this option is enabled and [Word] is selected, whether
the object is operable depends on the condition of a word
address specified in [Trigger if value is:]. In the settings above,
the object is operable only when the value in LW-1 is greater
than 1.
Hide when disabled
The object is hidden when the specified condition does not
occur in the specified word address.
Grayed label when disabled
The label of the object turns gray when the specified condition
does not occur in the specified word address.

Trigger if value is:
This setting is for specifying a trigger condition. The available
options are: >, <, ==, <>, >=, and <=. A tolerance value can be
set for conditions == and <>.
For example:

When the value is the specified word address is greater than
or equal to 11, or smaller than or equal to 9, the object will be
hidden and is not operable.

Note


Using address types other than PLW for Set Word objects with automatic attributes such
as [Periodic set up], [Periodic set down], [Automatic JOG++], [Automatic JOG--], and
[Periodic JOG++]…etc, is not supported by cMT-SVR.
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13.5.

Function Key
Overview

The Function Key object can be used for several tasks, such as switching between windows,
keypad design, Macro execution, screen hardcopy, and setting USB security key.
Function Keys with [Screen hardcopy] or [Import user data/Use [USB Security Key]] selected do
not work remotely on cMT Viewer.
Configuration

Click [Object] » [Function Key] icon on the toolbar to open a Function Key object property
dialog box. Set up the properties, press OK button, and a new Function Key object will be
created.
General Tab
cMT / cMT X Series

eMT, iE, XE, mTV Series
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Setting

Description

Activate
after button
is released

If this function is selected, the action is delayed till button is
released; otherwise, the action is executed once the button is
pressed.

Change
window

Change full-screen window: Change to another base window.
Change common window: Change common window.
Display popup window: A pop-up window displays in the base
window. If [Close this popup window when parent window is closed]
check box is selected, the pop up window will be closed when
change the base window to another window. Otherwise, a function
key in the pop up window is needed to close it.

(cMT / cMT X Series) Animation Setting: cMT / cMT X Series allows
using transition effects for opening popup windows using Function
Keys. The settings can be opened by clicking [Animation Setting].

The effects are shown below. Different effects may be used for Start
(window appears) and End (window disappears).
Effect Name

Transition

Fade
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Fly

Float

Wipe

Split

Circle

Clock

Zoom

Turn

Push

[Duration] specifies how many milliseconds (ms) a transition effect
takes to complete.
[Direction] The direction of the transition.
Return to previous window: If this is selected, the Function Key will
change from the current screen to the previous one displayed. For
example, when window no. 10 is changed to window no. 20, press
the function key to return to window no. 10. This function is only
available for base window.
Close window: Close any active pop-up windows, message windows
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included.
Display calculator window(cMT / cMT X Series): If this option is
selected, clicking this Function Key can open a calculator with an
unchangeable appearance. This calculator allows operators to do
simple calculation and enter the result to a destination object by
pressing the Enter key.

Selecting this option opens [Keep calculation open after paste]
checkbox, which keeps the calculator displayed after the value is
entered to the object.

Keyboard
Input

Click the icon to watch the demonstration film. Please confirm
your internet connection before playing the film.
Configures the button as a keypad key, and the character it enters,
via [Numeric] or [ASCII] objects.
Enter: Same as the keyboard’s “Enter” function.
Backspace: Same as the keyboard’s “Backspace” function.
Clear: Clear the value in the word register.
Esc: Same as the [Close window] function; it is used to close the
keyboard window.
Delete: Same as the keyboard’s “Delete” function, deletes the
number or character on the right side of the text cursor.
Left: Same as the keyboard’s “←” key moves the text cursor to the
left side of the previous number or character.
Right: Same as the keyboard’s “→” key moves the text cursor to the
left side of the next number or character.
Line feed: Move the cursor down to the next line.
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Inc: Increment by 1.
Dec: Decrement by 1.
ASCII/UNICODE: Specify the character to be entered by this key.
Execute
Macro

Select this check box to execute one of the Macros from the drop
down list that has already been configured by users.
For more information, see “18 Macro References”.

Window title
bar

Function Key defined can be used to move a pop-up window which
has no [window title bar] to a preferred position on screen. Select
the pop-up window and then click on a preferred position, the
window will be moved.

Click the icon to download the demo project. Please confirm
your internet connection before downloading the demo project.
Hard copy
screen to
USB disk, SD
card or
printer

Print the current window. Before using this function, choose a printer
model in [System Parameter Settings] » [Model] » [Printer].
If a monochrome printer is used, selecting [grayscale] can provide a
better print result, but the text may not be clearly printed. To
improve text printing, avoid using [grayscale].

Crop window
This option can be selected for taking a cropped screenshot.
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Acknowledge
all events
(alarms)
(cMT / cMT X
Series)
Import user
data / Use
[USB
Security Key]

Acknowledge all events once by pressing the Function Key.

A Function Key can be used to import the e-mail contacts or user
accounts set, also, to log in using USB Security Key.

Data Position
Select the external device to store data from [SD card] or [USB disk].
Account import mode
If [Overwrite] is selected, the existing accounts will be overwritten
with new accounts in the external device after importing. If [Append]
is selected, HMI will append more accounts while the old accounts
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still exist.
Delete file after importing user accounts
If select this check box, the system will delete the account data saved
in the external device after importing, this can prevent the account
data from leaking out.
Notification

If this selection is enabled, it will notify a designated bit address to
set ON or OFF, each time the button is pressed.

Note


[Overwrite] is the only option when importing the e-mail contacts. This means that all
existing contacts will be removed first, and then the new contacts are added.
For more information, see “6 Window Operations”, “12 Keypad Design and Usage”, “36

Administrator Tools”.

EasyBuilder Pro V6.08.01

13-30

Objects

13.6.

Toggle Switch
Overview

Toggle Switch object is a combination of Bit Lamp object and Set Bit object. The appearance of
the object is controlled by the ON / OFF state of the read bit address. As well, pressing the
button sets the value in the bit address according to the settings.
Configuration

Click [Object] » [Toggle Switch] icon on the toolbar to open a Toggle Switch object property
dialog. Set up the properties, press OK button, and a new Toggle Switch object will be created.
General Tab
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Setting

Description

Comment

User can describe the information of the object.
Bit Lamp / Toggle Switch
Switch between Bit Lamp and Toggle Switch features.

Read/Write
use different
addresses
Read address

Different addresses can be used to read data and write data.
Click [Setting] to select the [PLC name], [Address], [Device type],
[System tag], [Index register] of the bit device that controls the
[Toggle Switch] object. Users can also set address in [General] tab
while adding a new object.
Invert signal
Reverses the display of ON / OFF states. For example, if [Invert
signal] check box is selected, when the designated bit is OFF, the
object displays ON state.
When [Read/Write use different addresses] option is not selected,
the title of this group box will be “Read/Write address”.

Write address

Attribute

Macro

Click [Setting] to select the [PLC name], [Address], [Device type],
[System tag], [Index register] of the bit device that controls the
[Toggle Switch] object. Users can also set address in [General] tab
while adding a new object. The address can be the same or
different from [Read address].
Write after button is released
If this function is selected, the action is delayed till button is
released, otherwise, the action is executed once the button is
pressed. This function does not work with momentary buttons.
Set style
Description
Set ON
Set ON the designated bit of the device.
Set OFF
Set OFF the designated bit of the device.
Toggle

Alternates the bit state each time pressed.

Momentary

Holds the bit ON only while button is
pressed.

Toggle Switch object can trigger the start of a Macro routine when
the Macro has been created in advance.
For more information, see “18 Macro References”.
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13.7.

Multi-State Switch
Overview

Multi-state Switch object is a combination of Word Lamp object and Set Word object. The
appearance of the object is controlled by the value of the read word address. As well, pressing
the button sets the value in the word address according to the settings.
Configuration

Click [Object] » [Multi-State Switch] icon on the toolbar to open a Multi-State Switch object
property dialog box. Set up the properties, press OK button, and a new Multi-State Switch
object will be created.
General Tab
cMT / cMT X Series

eMT, iE, XE, mTV Series
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Setting

Description

Comment

User can describe the information of the object.
Word Lamp / Multi-State Switch
Switch between Word Lamp and Multi-State Switch features.

Model /
Offset

Different modes can be selected: [Value], [LSB].

Read/Write
use different

For more information, see “13.2 Word Lamp”.
Different addresses can be used to read data and write data.

addresses
Read address

Click [Setting] to select the [PLC name], [Address], [Device type],
[System tag], [Index register] of the word device that controls the
Multi-state Switch object. Users can also set address in [General]
tab while adding a new object.
When [Read/Write use different addresses] option is not selected,
the title of this group box will be “Read/Write address”.

Write address

Click [Setting] to select the [PLC name], [Address], [Device type],
[System tag], [Index register] of the word device that controls the
Multi-state Switch object. Users can also set address in [General]
tab while adding a new object.
Write after button is released
If this function is selected, the action is delayed till button is
released; otherwise, the action is executed once the button is
pressed.

Attribute

Switch style
Select the object’s operation mode, see Example 1.
User-defined mapping
The value placed in the write register of each selection, the action
taken when an illegal value is entered, and error notification to a
designated bit address can be set.
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Remain current state
If an illegal value is entered, Multi-state Switch will remain at the
current state.
Jump to error state
If an illegal value is entered, Multi-state Switch will jump to the
error state.
Error notification
If an illegal value is entered, automatically set the value placed in
the designated register.
Send
notification
after writing
successfully

After the system successfully writes data to PLC, the designated bit
address will be set On/Off.

Error handling
(cMT / cMT X
Series)

The action taken when an illegal value is entered or notify a
designated bit address. This is similar to [User-defined mapping];
the difference is the value corresponding to each state need not to
be preset.

Example 1
 JOG+
Increase the value of a designated register by 1 each time when pressing the button, till the
value equals to [No. of states]. A cyclic action can be enabled. As shown below, each time
when pressing the button, the state number will add 1 start from state 0, till state 4 ([no. of
state]-1), and returns to 0 and step up again.
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 JOGDecrease the value of the designated register by 1 each time when pressing the button, till the
value equals to 0. A cyclic action can be enabled. As shown below, each time when pressing the
button, the state number will minus 1 start from state 4 ([no. of state]-1), till state 0, and
returns to state 4 and step down again.
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13.8.

Slider
Overview

Slider object is used to change the value in a designated word register address by moving the
slide on the screen.
Configuration

Click [Object] » [Slider] icon on the toolbar to open a Slider object property dialog box. Set up
the properties, press OK button, and a new Slider object will be created.
General Tab
cMT / cMT X
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eMT, iE, XE, mTV

Setting

Description

Attribute

Direction
Select the direction of the slider. (Right, Up, Left, Down)

Resolution
Sets the value change in the word register for each step of the
Slider. For example, if set to 10, the register value changes by 10
points for each increment or decrement on the Slider.
Constant
Sets the range of the Slider. For example, If set [Low limit] to 5, and
[High limit] to 100, the Slider will enter values between 5 and 100.
Address
Set the [Low/High limit] by a designated register, see Example 1.
Coarse increment
Apart from moving the roller to change the value as in [Resolution],
EasyBuilder Pro V6.08.01

13-38

Objects

if this option is selected, the word value will increase / decrease by
the [Increment] value each time the object is touched.
Write address

Click [Setting] to select the [Device], [Address], [Device type],
[System tag], [Index register] of the word device that controls the
Slider object. Users can also set address in [General] tab while
adding a new object.

Notification

If enabled, the state of a designated bit address will be set to ON or
OFF before or after writing.
Click [Setting] to select the [Device], [Address], [Device type],
[System tag], [Index register] of the bit device that controls the
notification settings. Users can also set address in [General] tab
while adding a new object.
[Before writing] / [After writing]
Change the state of a designated bit register before, or after the
slider is slid.

Watch address

When moving the roller, the new value written to the word register
address can be displayed in real time.

Example 1
Set the low or high limit by a designated register. When write address is LW-n, where n is an
arbitrary number, the rule of setting limits is:
Content

16-bit

32-bit

64-bit (cMT / cMT X only)

Address

LW-n

LW-n

LW-n

Low limit

LW-n

LW-n

LW-n

High limit

LW-n+1

LW-n+2

LW-n+4

When address is LW-100, the rule of setting limits is:
Content

16-bit

32-bit

64-bit (cMT / cMT X only)

Address

LW-100

LW-100

LW-100

Low limit

LW-100

LW-100

LW-100

High limit

LW-101

LW-102

LW-104

Outline Tab
cMT / cMT X Seires
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eMT, iE, XE, mTV Seires

Setting

Description

Slider button
type (cMT /
cMT X)

Select slider button type, by default, a picture selected from the
Picture Library can be the slider button.

Slider button
type (eMT, iE,

Four default styles are offered, and the width and color of the
Frame, Background, Slot can be set.

XE, mTV)

Combo Setting
cMT / cMT X Series HMI support combo setting for Slider, which allows setting of multiple
related objects at a time. Slider can be set with Background and Dynamic Scale.
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Background

Setting

Description

Margin

Specify the space between the background edge and
the objects.

Color/Style

Customize

Select a suitable background pattern and color.
Picture

Use the default picture or choose a picture from
Picture Library.
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Dynamic Scale

Setting

Description

Style

The scale style will follow the Slider.

Alignment

The position of the scale bar along the Slider.

Tick Mark

Configure the number of tick marks for main and
sub scales, and the color of tick marks.

Scale Label

Configure the font, font color, font size and other
attributes of scale label.
In Slider settings if [Address] is selected for
Low/High limit, then Scale Label’s [Dynamic limits]
will be set automatically.
In Slider settings if [Left] is selected for Direction,
then Scale Label’s [Reverse (Left/Right)] will be set
automatically.
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13.9.

Numeric
Overview

Numeric object can be used to input or display the value of a designated word register.
Configuration

Click [Object] » [Numeric] icon on the toolbar to open a Numeric object property dialog box.
Set up the properties, press OK button, and a new Numeric object will be created.
General Tab
cMT, cMT X Series

Setting
Allow input
Read / Write

eMT, iE, XE, mTV Series

Description
If selected, the input features and relevant settings are enabled.
Different addresses can be used to read data and write data.
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use different
address
Read address

Click [Setting] to select the [Device], [Address], [Device type],
[System tag], [Index register] of the word device that displays the
value. Users can also select a tag defined in Address Tag Library.
When [Read/Write use different addresses] option is not selected,
the title of this group box will be “Read/Write address”.

Write address

Select the [Device], [Device type], [Address] of the word device
that system writes to.

Notification

With notification enabled, the state of the designated bit address
can be set on / off, before / after writing.
Notification works differently comparing cMT / cMT X Series with
eMT/iE/XE/mTV Series.
cMT/cMT X Series: Trigger the object to open a keyboard window »
Notification before writing » Enter a value and press ENTER » Start
writing operation » Notification after writing.
eMT/iE/XE/mTV Series:
Trigger the object to open a keyboard window » Enter a value and
press ENTER » Notification before writing » Start writing operation
» Notification after writing.

Notification
on invalid
input

If an illegal value is entered, automatically set the state of a
designated register.
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Data Entry Tab
cMT, cMT X

eMT, iE, XE, mTV Series

Setting

Description

Mode

Touch
Used when data entry is initiated by touching the screen object.
Bit control
Used when data entry is enabled by turning ON a designated bit,
and entry ends when the bit goes OFF.

Input control

Specify a bit address that enables or ends data entry. The order of
data entry is specified in [Input order] and an external USB
keyboard is needed for data entry. For cMT-SVR, use cMT Viewer’s
keyboard.

Input order

Perform continuous input by setting [Input order] and [Group].
The criterion of searching the next input object:
 The range of [Input order]: 1 ~ 511, range of [Group]: 1 ~ 15.
 If [Group] is not selected, its input order is 0.
 The system only searches for the objects within the same
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Group.
 The lower number of order is entered before the higher
number of order.
 For multiple objects within the same group and with the same
input order, the object placed in the lower layer is entered first.
Click the icon to download the demo project. Please confirm
your internet connection before downloading the demo project.
Keyboard

Use a popup keypad
If selected: A pre-designed pop-up keypad can be chosen by
selecting a check box and selecting the relative position on the HMI
screen. When data entry is enabled, the pop-up keypad displays in
the selected position, and closed when data entry ends.
If not selected: When data entry is enabled, the pop-up keypad is
not displayed. Users may:
 Create a custom design on the same screen window.
 Use a USB keyboard.
System keypad
cMT / cMT X Series model has its own system keypad, select this
checkbox to use the system keypad, or select [Custom keypad] to
set up a customized keypad.
Animation Setting
When using a cMT / cMT X Series model with [Custom keypad]
selected, the transition effect of the keypad window can be
selected.
See Chapter 13.5 Function Key in this manual for the list of
effects.
Hide title bar
Use a keypad without the title bar.
Popup position
When using a cMT / cMT X Series model with [Custom keypad]
selected, the position where the keypad pops up can be selected.
The position can either be relative to HMI screen or relative to
object.
Relative to HMI screen

Relative to object
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Restart the keypad if input value is out of range
When entering data, if the value entered is not within the valid
range, the system will automatically restart the keypad.
Other options
(For cMT /
cMT X Series)

Display lower and upper limits
If selected, when entering a value, the range
is displayed near the object.
Display previous value
If selected, when entering a value, the value
before update is displayed near the object.

To create a keyboard in current window, see “12 Keypad Design and Usage”.
Click the icon to watch the demonstration film. Please confirm your internet connection
before playing the film.

Example 1
This example demonstrates how to use [Input Order] and [Group] to perform continuous input
in several Numeric objects. After entering data in one object, entry will be passed to the next
input order object which is in the same group.
1. Create three Numeric objects, and set [Input order] to 1, 2, and 3 respectively. Include
the three objects in [Group 1] as shown in the following figure.
LW-0

LW-1
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LW-2

Group1

Order1

2.

Order2

Order3

When finish entering data in the last object, to end data entry of all objects, please select
[Stop sequential input function after input] check box.
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Format Tab

Setting

Description

Device Data
Format

Set the data format of a designated word register. Options include:
BCD, Binary, Unsigned, Signed, HEX, and Float. 16-bit uses 1 word
where 32-bit uses two words.
Mask
If selected, any values entered will be hidden by displaying them as
asterisks “*”.

Display
format

Numeric
General Numeric formats.
Customized
Each “*” sign represents each integer digit, and each “#” sign
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represents each fraction digit that will be displayed in the Numeric
object. Float and Double formats are only supported on cMT / cMT
X models.
Apart from “*” signs, extra texts can be entered in the [Format]
field, for example: kg. The available alignment options are: [Left],
[Center], [Right], [Leading zero].
The numeric value represented by “*” sign will be displayed from
the highest digit to the lowest in the Numeric object.
Truncated digits
Specify the number of digits to be truncated, from the lowest digit
to the highest.
The number of “*” signs = [Left of decimal Pt.] - [Truncated digits] [Right of decimal Pt.].
The number of “#” signs = [Right of decimal Pt.] - [Truncated digits].
Please see the following examples:
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When leading zero is not used, the text enclosed in two “*” signs
will not show, for example:
[Left of decimal Pt.] = 5, [Truncated digits] = 0, and Display Format
is “Total=**kg***g”
If the data read is 255, the result would be: "Total=255g"
If the data read is 1000, the result would be: "Total=1kg000g"
Scientific Notation
Express numerical data using scientific notation; for example,
number 100 is displayed as 1e+2. Scientific notation is not available
for device data formats: BCD, HEX, or Binary.
Number of
digits

Left of decimal Pt.
The number of digits before the decimal point.
Right of decimal Pt.
The number of digits after the decimal point.

Scaling

Interpolation
If this check box is selected, [Engineering low] and [Engineering
high] boxes appear. Values entered in these boxes correspond to
the display range required. The setting also requires [Input low]
and [Input high] in the limits section. See Example 2.
Test: Preview the result of Interpolation. See Example 2.
Dynamic scales: Set the [Engineering low] and [Engineering high]
by a designated register. See Example 4.
Macro subroutine
The value read from or written to the register can be computed by
macro subroutines selected in [Read conversion] and [Write
conversion]. The macro subroutines should be defined in Macro
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Function Library. To use this feature, see “13.9.2.1 The rule of using
Macro subroutine”.
Limits

This section allows users to apply display limits to the values held in
the input register. The color when the register value is outside
limits can be set.
Direct
Sets the limits by entering values in [Input low] and [Input high]. If
the value entered is outside the limits, the value in the register
cannot be changed.
Dynamic limits
Set the limits by a designated register.
To use consecutive addresses, see Example 5.
On a cMT / cMT X model, the [Use consecutive addresses] option
can be deselected so that users can designate different addresses
to set the high and low limits respectively. When the scaling
method used is interpolation, both high and low limit addresses are
required.

Use alarm
color

Low limit
When the value in the register is outside the [Low limit], display
digits by the color set.
High limit
When the value in the register is outside the [High limit], display
digits by the color set.
Blink
When the value in the register is outside either limit, the digits
flash.
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Limit Tab
cMT, cMT X

eMT, iE, XE, mTV Series

Setting

Description

Limits

This section allows users to apply display limits to the values held in
the input register. The color when the register value is outside
limits can be set.
Direct
Sets the limits by entering values in [Input low] and [Input high]. If
the value entered is outside the limits, the value in the register
cannot be changed.
Dynamic limits
Set the limits by a designated register.
To use consecutive addresses, see Example 5.
On a cMT / cMT X model, with [Use different addresses] option
selected, the high and low limits can be set respectively by
designating different addresses. When the scaling method used is
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interpolation, both high and low limit addresses are required.
Use alarm
color

Low limit
When the value in the register is outside the [Low limit], display
digits by the color set.
High limit
When the value in the register is outside the [High limit], display
digits by the color set.
Blink
When the value in the register is outside either limit, the digits
flash.

Trigger Action Setting (cMT / cMT X)
Actions executed before/after writing can be classified into action groups. The groups are put
in sequence. The actions within the same group are executed at the same time. When all the
actions within the same group are completed, the actions in the next group are then executed.
Compared to the Notification actions selected in General tab, Trigger Action Setting offers
more flexible combination of actions. For more details about these settings, please also see
Action Trigger in Chapter 13.
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Setting

Description

Actions
before writing

The predefined action groups will be executed once the write
operation starts, and will not wait for it to be completed.

Actions after
writing

The predefined action groups will be executed when the write
operation is completed.

The rule of using Macro Subroutine
 There must be a return value and exactly one parameter.
Examples:
sub char test (short a) // (Correct)
sub test (char a) // (Incorrect, no return value.)
sub char test (char a, char b) // (Incorrect, two parameters.)
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 Use the Macro data type that corresponds to the object’s data format.
The mapping is as follows:
Macro Data Type
short
Int
unsigned short
unsigned int
float
long
unsigned long
double

Numeric Object Data Format
16-bit Signed
32-bit Signed
16-bit BCD, 16-bit HEX, 16-bit Binary, 16-bit Unsigned
32-bit BCD, 32-bit HEX, 32-bit Binary, 32-bit Unsigned
32-bit Float
64-bit Signed (cMT / cMT X only)
64-bit Unsigned (cMT / cMT X only)
64-bit Double (cMT / cMT X only)

For example, if the data format of the numeric object is 16-bit Unsigned, only the
corresponding Macro data type: unsigned short, is available.
Examples:
sub char test(unsigned short a) // (Correct)
sub char test(char a) // (Incorrect)
 Supports only the local HMI address.
Examples:
GetData(var, "Local HMI", LB, 0, 1) // (Correct)
GetData(var, "MODBUS RTU", 0x, 0, 1) // (Incorrect)
 The following system defined functions are unable to be invoked:
ASYNC_TRIG_MACRO, SYNC_TRIG_MACRO, DELAY, FindDataSamplingDate,
FindDataSamplingIndex, FindEventLogDate, FindEventLogIndex, INPORT, INPORT2, OUTPORT,
PURGE, TRACE
 The following statements are not supported:
For-Next, While-Wend

Example 2
If [Interpolation] is selected, the scaling equation is as the following:
If A indicates the original data and B indicates the displayed data:
B = [Engineering low] + (A - [PLC low]) × Ratio
where, Ratio = ([Engineering high] - [Engineering low]) / ([PLC high] - [PLC low])
As shown below, the original data is 15, after conversion, 40 will be displayed.
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Click [Test] button to preview the result of Interpolation. Enter a value in [PLC] field as shown in
the following figure, for example, enter value 15, and the result, which is 40, will be displayed.

Example 3
If the numeric format selected is not Float and decimal point is used, the decimal place of the
converted result will not be adjusted automatically, please adjust [Engineering high] to
correctly place the decimal point of the result gained in [Interpolation] mode. Please see the
illustration below.
1. Create two Numeric objects, set [Right of decimal Pt.] to 1 and select [Interpolation]
method for one of the objects as shown in the following figure.
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2.

Enter value “123”, the object set to [Interpolation] displays “246.0” instead of “24.6”.

3.

To move the decimal point one place to the left, adjust [Engineering high] as shown in the
following figure.

Example 4
If [Interpolation] is selected, set the [Engineering low] and [Engineering high] by a designated
register. When Dynamic Address is LW-n, where n is an arbitrary number, the rule of setting
[Engineering low] and [Engineering high] is:
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Content
16-bit
32-bit
Dynamic address
LW-n
LW-n
Engineering low
LW-n
LW-n
Engineering high
LW-n+1
LW-n+2
When address is LW-100, the rule of setting limits is:
Content
Dynamic address
Engineering low
Engineering high

16-bit
LW-100
LW-100
LW-101

32-bit
LW-100
LW-100
LW-102

64-bit (cMT / cMT X only)
LW-n
LW-n
LW-n+4
64-bit (cMT / cMT X only)
LW-100
LW-100
LW-104

Example 5
Set the limits by a designated register. When [Address] is LW-n and [Use consecutive addresses]
is selected, the rule of setting limits is:
Content
16-bit
32-bit
Address
LW-n
LW-n
Low limit
LW-n
LW-n
High limit
LW-n+1
LW-n+2
When address is LW-100, the rule of setting limits is:
Content
Address
Low limit
High limit

16-bit
LW-100
LW-100
LW-101

32-bit
LW-100
LW-100
LW-102

64-bit (cMT / cMT X only)
LW-n
LW-n
LW-n+4
64-bit (cMT / cMT X only)
LW-100
LW-100
LW-104

Example 6
The following demonstrates how to use [Macro subroutine] for scaling when configuring
Numeric object.
The following two macros are used, one for [Read conversion] and one for [Write conversion].

1.

Create two Numeric objects: NE_0 and NE_1 and use the same control address. Select
[Macro subroutine] for NE_1.
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2.

Enter 0 in NE_0 then NE_1 will execute [Read conversion]. The value gained will be 10.

3.

Enter 80 in NE_1, [Write conversion] is executed and the value gained will be 70. NE_0
displays 70.
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Note


If executing [Read conversion] and [Write conversion] by the same numeric object, the
value entered in this object is computed by the Macro subroutine of [Write conversion]
first, and then the result is computed by the Macro subroutine of [Read conversion]. In
Example 5, if the subroutine of [Write conversion] is set to b=a-20, then entering 80 in
NE_1 will get 60 after [Write conversion] and then the object displays 70 after [Read
conversion].

Security Tab
cMT, cMT X

Setting
Safety control
Enable/Disable

eMT, iE, XE, mTV Series

Description
Displays a confirmation request window before executing a command.
Use register status / value
With this option selected, whether an object is operable
depends on whether the specified condition occurs in the
designated address.
Use control token
With this option selected, whether an object is operable
depends on whether a control token is acquired or
unacquired.
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Action modes:
Do nothing when disabled
The object is not operable, and its status remains
unchanged when the specified condition does not occur in
the designated address.
Hide when disabled
The object is hidden when the specified condition does not
occur in the designated address.
Grayed label when disabled
The value in the object turns gray when the specified
condition does not occur in the designated address.

User
restriction
Sound

Set the security class of the object to be operated by an
authorized user.
When enabled, the selected sound will be played when the
object is touched.

Font Tab

Setting

Description

Color

When the value is within the limits, display digits using color set in
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this tab.
Align

Left: Align the number to the left.
Center: Align the number to the center.
Right: Align the number to the right.
Leading zero: The number is preceded with leading zeros when the
number of digits is less than that set.

Size

Set the font size.
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13.10. ASCII
Overview
ASCII object can be used to input or display ASCII or UNICODE characters held in designated
word registers.
Configuration

Click [Object] » [ASCII] icon on the toolbar to open an ASCII object property dialog box. Set up
the properties, press OK button, and a new ASCII object will be created.
General Tab
cMT, cMT X

eMT, iE, XE, mTV Series

Setting
Allow input

Description

Multi-line
display

If selected, the ASCII object can display multi-lined text. If a line
feed character LF (0xA) is used in the string, a newline will be
created.

If selected, the input features and relevant settings are enabled.
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Vertical
alignment

When [Multi-line display] is enabled, the method to vertically align
multiple lines of text can be selected.

Mask

If selected, any values entered will be masked by asterisks (*)..

Reverse
high/low byte

Normally an ASCII code is displayed in “high byte”, “low byte”
order. Reverse selection makes the system display ASCII characters
in “low byte”, “high byte” order.

Data format

Select encoding from UTF-8 (default), Unicode, or Latin-1.

Read address

Click [Setting] to select the [PLC name], [Address], [Device type],
[System tag], [Index register] of the word device that displays
characters. Users can select a defined address tag from Address Tag
Library, or set address in [General] tab while adding a new object.

No. of words
Select the maximum number of words to be displayed.
cMT / cMT X Series: max. 160 words
eMT/XE/mTV/iP: max. 64 words
Notification

With notification enabled, the state of the designated bit address
can be set on / off, before / after writing.
Notification works differently comparing cMT/cMT X Series with
eMT/iE/XE/mTV Series.
cMT/cMT X Series: Trigger the object to open a keyboard window »
Notification before writing » Enter a value and press ENTER » Start
writing operation » Notification after writing.
eMT/iE/XE/mTV Series:
Trigger the object to open a keyboard window » Enter a value and
press ENTER » Notification before writing » Start writing operation
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» Notification after writing.

Note


A UNICODE character uses 1 word, and an ASCII character uses 1 byte. Therefore 1 word
can be used as 1 UNICODE character or 2 ASCII characters. (1 word equals to 2 bytes)

Font Tab
cMT, cMT X

eMT, iE, XE, mTV Series

Setting

Description

Attribute

The font, size, color, and alignment can be set.

Text
Alignment

Multiline text is aligned within the label outline. The method to
align multiple lines of text can be selected.

Text area
position

Multiline text is aligned within the object outline.
The label outline is highlighted by red dotted line and the object
outline is highlighted by blue dotted line. Please note that this
feature is ineffective when [Multi-line display] is enabled in General
tab.
When object is selected.

When text is selected.
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Trigger Action Setting (cMT / cMT X)
Actions executed before/after writing can be classified into action groups. The groups are put
in sequence. The actions within the same group are executed at the same time. When all the
actions within the same group are completed, the actions in the next group are then executed.
Compared to the Notification actions selected in General tab, Trigger Action Setting offers
more flexible combination of actions. For more details about these settings, please also see
Action Trigger in Chapter 13.

Setting

Description

Actions
before writing

The predefined action groups will be executed once the write
operation starts, and will not wait for it to be completed.

Actions after

The predefined action groups will be executed when the write

writing

operation is completed.
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13.11. Indirect Window
Overview
Indirect Window object opens or closes a pop-up window assigned by a designated word
register. There are two ways to use Indirect Window object: The first is to use the profile of
Indirect Window object, and let the pop-up window be resized and displayed in the defined
profile; the second is to automatically resize the window according to the size of the pop-up
window to be displayed. To close the pop-up window, assign 0 to the designated word register.
The difference between Direct Window and Indirect Window is that Direct Window is
controlled by a bit register, while Indirect Window is controlled by a word register.
Configuration

Click [Object] » [Embed Window] » [Indirect Window] icon on the toolbar to open the object
property dialog box. Set up the properties, press OK button, and a new Indirect Window object
will be created.
General Tab
cMT / cMT X Series

eMT, iE, XE, mTV Series
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Setting

Description

Style

This setting is available only on cMT / cMT X Series. When a base
window contains an underlay window, this setting determines the
display style of an Indirect Window placed in the underlay window.
Please see Example 2 below.
Embedded in parent window
The Indirect Window is displayed in its parent window. When an
Indirect Window is placed in an underlay window, the Indirect
Window is displayed in the underlay window when it is called in the
base window.
Popup window
The Indirect Window is displayed in the base window. When an
Indirect Window is placed in an underlay window, the Indirect
Window is displayed in the base window when it is called in the
base window.
Title Bar Setting
When [Enable title bar] is selected, a field shows for entering the
caption in the title bar. The caption can be selected from Label Tag
Library.

Read address

Click [Setting] to select the [PLC name], [Address], [Device type],
[System tag], [Index register] of the word device that controls the
pop-up window. Users can also set address in [General] tab while
adding a new object.

Attribute

Style
Set the display style of the pop-up window. There are two styles:
 No title bar
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The pop-up window has no title bar and cannot be dragged.

 With title bar
The pop-up window has a title bar that can be dragged to move the
window.

Animation
(cMT / cMT X
Series)

Effect
Different effects may be used for Start (window appears) and End
(window disappears).
Effect Name

Transition

Fade

Fly

Float

Wipe

Split

Circle
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Clock

Zoom

Turn

Push

Duration
Specifies how many milliseconds (ms) a transition effect takes to
complete.
Direction
The direction of the transition.
Use window
no. offset

Sets the offset of the window number for selecting the pop-up
window. The window number of the pop-up window is calculated
by the value in the word register added to the offset. For example,
assume the value in the register is 20 and offset is 5, the pop-up
window number will be 25.
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Position
cMT / cMT X Series

eMT, iE, XE, mTV Series

Setting

Description

Auto. adjust
window size

Automatically resizes the Indirect Window and align the pop-up
window to the preset region.
Alignment
Sets a reference point of the pop-up window from one of the five
positions on the screen; for example, if the lower-right region is
selected, the lower-right corner of the pop-up window is aligned to
the lower-right region of the Indirect Window. See Example 1.

Dynamic
position

With this option selected, the position of the window on the screen
can be changed dynamically by the values in the designated
address.
Enable shift window animation
With this option selected, the window changes position with
transition effect.

Example 1
Here is an example of using Indirect Window. The setting is shown in the following figure, set
the address to LW-0 which assigns the window number. Create window no. 11 and 12 first.
1. Create an Indirect Window object, set address to LW-0, and select [Auto. adjust window
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2.

size].
Select the region where the window is to be displayed.

3.
4.
5.

Enter value 11 in LW-0, the pop-up window displayed is window no. 11.
Enter value 12 in LW-0, the pop-up window displayed is window no. 12.
Enter value 0 in LW-0, the pop-up window is closed.

To close the pop-up window, apart from entering 0 in the designated word register, another
way is to place a Function Key object in the pop-up window, and set the key to [Close window].

Example 2
Here is an example showing the difference between these two styles: [Embedded in parent
window] and [Popup window]. The style setting determines how an Indirect Window placed in
an underlay window is displayed when it is called in the base window.
1. Add two base windows: Window no. 10 and Window no. 11. Add an underlay window in
Window no. 10 and set Window no. 11 as the underlay window.

2.

Create several objects in Window no. 10.
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3.

In Window no. 11 create an Indirect Window object and a Numeric Input object. Set both
read addresses to LW-0.

4.

By entering a window number in the Numeric Input object, the Indirect Window is
displayed according to the selected style.
Embedded in parent window
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Popup window

Note





For eMT/iE/XE/mTV models, a screen can display up to 24 pop-up windows simultaneous
including System Message Window, Direct Window and Indirect Window. For cMT / cMT X
Series, the number of pop-up windows is not limited.
The system does not allow opening the same window with two Direct (or Indirect)
windows in one base window.
If the pop up window has monopoly property enabled, then when the window pops up,
all background windows may not be operated until the monopolizing window has been
closed.

Click the icon to watch the demonstration film. Please confirm your internet connection
before playing the film.
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13.12. Direct Window
Overview
Direct Window object opens or closes a pop-up window assigned by a designated bit register.
When the state of the bit register changes, the pop-up window appears at the predefined
location. The display area for the pop-up window is limited by the size of predefined location.
Returning the state of the bit register closes the pop-up window. The difference between
Direct Window and Indirect Window is that Direct Window is controlled by a bit register, while
Indirect Window is controlled by a word register.
Configuration

Click [Object] » [Embed Window] » [Direct Window] icon on the toolbar to open a Direct
Window object property dialog box. Set up the properties, press OK button, and a new Direct
Window object will be created.
General Tab
cMT / cMT X Series

eMT, iE, XE, mTV Series
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Setting

Description

Style

This setting is available only on cMT / cMT X Series. When a base
window contains an underlay window, this setting determines the
display style of a Direct Window placed in the underlay window.
Please see Example 2 in Chapter13.11 in this manual.
Embedded in parent window
The Direct Window is displayed in its parent window. When a
Direct Window is placed in an underlay window, the Direct Window
is displayed in the underlay window when it is called in the base
window.
Popup window
The Direct Window is displayed in the base window. When a Direct
Window is placed in an underlay window, the Direct Window is
displayed in the base window when it is called in the base window.
Title Bar Setting
When [Enable title bar] is selected, a field shows for entering the
caption in the title bar. The caption can be selected from Label Tag
Library.

Read address

Click [Setting] to select the [PLC name], [Address], [Device type],
[System tag], [Index register] of the bit device that controls the
pop-up window. Users can also set address in [General] tab while
adding a new object.

Attribute

Style
Set the display style of the pop-up window. There are two styles:
 No title bar
The pop-up window has no title bar and cannot be dragged.
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 With title bar
The pop-up window has a title bar that can be dragged to move the
window.

Window no.
Set the pop-up window number.
Animation
(cMT / cMT X
Series)

Effect
Different effects may be used for Start (window appears) and End
(window disappears).
Effect Name

Transition

Fade

Fly

Float

Wipe

Split

Circle
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Clock

Zoom

Turn

Push

Duration
Specifies how many milliseconds (ms) a transition effect takes to
complete.
Direction
The direction of the transition.

Position
cMT / cMT X Series

eMT, iE, XE, mTV Series
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Setting

Description

Auto. adjust
window size

Automatically resizes the Direct Window and align the pop-up
window to the preset region.
Alignment
Sets a reference point of the pop-up window from one of the five
positions on the screen; for example, if the lower-right region is
selected, the lower-right corner of the pop-up window is aligned to
the lower-right region of the Direct Window. See Example 1.

Dynamic
position

With this option selected, the position of the window on the screen
can be changed dynamically by the values in the designated
address.
Enable shift window animation
With this option selected, the window changes position with
transition effect.

Example 1
Create window no. 11 which can be controlled by a Toggle Switch with address LB-0.
1. Create a Direct Window object and set read address to LB-0.
2. In this example, the reference point for alignment is set to the lower-right region.

3.

When LB-0’s state is ON, window no. 11 will show.

4.

When LB-0’s state is OFF, window no. 11 will be hidden.
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Note


For eMT/iE/XE/mTV models, a screen can display up to 24 pop-up windows simultaneous
including System Message Window, Direct Window and Indirect Window. For cMT / cMT X
Series, the number of pop-up windows is not limited.



The system does not allow opening the same window with two Direct (or Indirect) Windows
in one base window.



If the pop up window has monopoly property enabled, then when the window pops up, all
background windows may not be operated until the monopolizing window has been closed.

Click the icon to watch the demonstration film. Please confirm your internet connection
before playing the film.
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13.13. Moving / Rotating Shape
Overview
Moving / Rotating Shape is an object that changes its state, moves, and/or rotates according to
the user-defined parameters. The state, moving distance, and rotation direction/angle are
determined by values in consecutive registers.
Configuration

Click [Object] » [Animation] » [Moving / Rotating Shape] icon on the toolbar to create the
object, set up the properties, press OK button, and a new Moving / Rotating Shape object will
be created.
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General Tab

Setting

Description

Read address

Click [Setting] to configure the [Device], [Device type], [Address],
[System tag], or [Index register] of the word devices that control
the display of object’s state and moving distance. Users can also set
the address in [General] tab while adding a new object.

Attribute

Select the object’s movement mode and range. See “13.13.2.1
Illustration of Modes” in the following part.

Display ratio

The size of shape in different states can be set individually as
shown in the following figure.

Rotate

Select Clockwise or Counterclockwise for Direction and define the
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angle range (unit in degree) within which the object may rotate.
The allowable range is 0~360 degrees, and the Max. angle should
be greater than Min. angle.
For more information please see “13.13.2.2 Rotation Modes”.
Limit address

The object’s moving range can be set by adjusting the data in the
designated register, see Example 1.

Example 1
Supposed that the object’s moving range is limited by register LW-n, the addresses in the
following table are used to limit the moving / rotating range.
Data format

16-bit

32-bit

64-bit (cMT / cMT X only)

Position - [Min. X] address

LW-n

LW-n

LW-n

Position - [Max. X] address

LW-n+1

LW-n+2

LW-n+4

Position - [Min. Y] address

LW-n+2

LW-n+4

LW-n+8

Position - [Max. Y] address

LW-n+3

LW-n+6

LW-n+12

Rotate – Input Low

LW-n+4

LW-n+8

LW-n+16

Rotate – Input High

LW-n+5

LW-n+10

LW-n+20

Rotate – Scaling Low

LW-n+6

LW-n+12

LW-n+24

Rotate – Scaling High

LW-n+7

LW-n+14

LW-n+28

Illustration of Modes
Available modes are: (Assume Read Address is LW-n)
 X axis only
The object is only allowed to move along the X-axis. The moving distance ranges from [Min. X]
to [Max. X].

Data format

16-bit

32-bit

64-bit (cMT / cMT X only)

Object state

LW-n

LW-n

LW-n

Moving distance on X-axis

LW-n+1

LW-n+2

LW-n+4

 Y axis only
The object is only allowed to move along the Y-axis. The moving distance ranges from [Min. Y]
to [Max. Y].
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Data format

16-bit

32-bit

64-bit (cMT / cMT X only)

Object state

LW-n

LW-n

LW-n

Moving distance on Y-axis

LW-n+1

LW-n+2

LW-n+4

 X & Y axis
The object is allowed to move along the X-axis and Y-axis. The moving range in X and Y
directions is defined by [Min. X], [Max. X] and [Min. Y], [Max. Y] respectively.

Data format

16-bit

32-bit

64-bit (cMT / cMT X only)

Object state

LW-n

LW-n

LW-n

Moving distance on X-axis

LW-n+1

LW-n+2

LW-n+4

Moving distance on Y-axis

LW-n+2

LW-n+4

LW-n+8

For example, if the object’s read address is LW-100 and the data format is [16-bit Unsigned],
LW-100 is used to control the object’s state, LW-101 is used to control the object’s moving
distance on the X-axis, and LW-102 is used to control the object’s moving distance on the Y-axis.
The following figure shows that the object’s read address is LW-100 and initial position is (100,
50). To move the object to the position (160,180) and change its state to State 2, assign 2 to
LW-100, 160-100 = 60 to LW-101, 180-50 = 130 to [LW102].
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 X axis w/ scaling
The object moves in X-axis only with scaling. Suppose that the value of the designated register
is DATA, the system uses the following equation to calculate the moving distance on the X-axis.
[Scaling high]-[Scaling low]
Displacement=(Data-[Input low])×
[Input high]-[Input low]
Data format

16-bit

32-bit

64-bit (cMT / cMT X only)

Object state

LW-n

LW-n

LW-n

Moving distance on X-axis

LW-n+1

LW-n+2

LW-n+4

 Y axis w/ scaling
The object is for Y axis movement with scale, and the equation to calculate the moving
distance on the Y-axis is the same as the one in [X axis w/ scaling].
Data format

16-bit

32-bit

64-bit (cMT / cMT X only)

Object state

LW-n

LW-n

LW-n

Moving distance on Y-axis

LW-n+1

LW-n+2

LW-n+4



X axis w/ reverse scaling

This works in the way as [X axis w/ scaling], but the moving direction is in reverse.
 Y axis w/ reverse scaling
This works in the way as [Y axis w/ scaling], but the moving direction is in reverse.
Rotation Modes
The addresses that control the moving / rotating shape are consecutive addresses starting
from Read Address (LW-n), and they may vary depending on the selected mode. Please click
[Usage…] to open the window that shows the control addresses relating to rotation
parameters.
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Rotate
Select rotating direction from clockwise or counterclockwise and set the Min. and Max.
angle range.
When rotation animation is enabled, two modes can be selected: Default and Shortest.
e.g. When the angle measure is set to clockwise and the rotating angle is changed from 10
degrees to 350 degrees, these two modes give different results:
Default: rotates 340 degrees clockwise (linear interpolation between the two numbers)
Shortest: rotates 20 degrees counterclockwise (in the direction that produces the shortest
animation path)



Rotate w/ scaling
Select rotating direction from clockwise or counterclockwise. The angle of rotation is
calculated by the formula as shown below.
[Scaling high]-[Scaling low]
Angle of Rotation =(Data-[Input low])×
[Input high]-[Input low]



Rotate w/ reverse scaling
Similar to [Rotate w/ scaling] but reverses the object from clockwise to counterclockwise
and vice versa.
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13.14. Animation
Overview
Animation object is defined by a pre-defined point set and states. Animation object will then
move to a given point in a given state defined by designated registers. The object state and
position depend on current value of two consecutive registers. The first register controls the
state of the object and the second register controls the position along the predefined path.
Configuration

Click [Object] » [Animation] » [Animation] icon on the toolbar. First, create the pre-defined
path. Move the mouse to each moving position, and click the left button to define positions
one by one. When it is done, right click on the screen, set up the properties, press OK button,
and a new Animation object will be created.

To change the object’s attributes, double click on the object to open Animation Object’s
Properties dialog box.
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General Tab

Setting

Description

Attribute

No. of states
Configure the number of states for this object.
Controlled by register
Use the designated registers to control the object’s state and
position. See Example 1.
Based upon time interval
The object’s state and position will change from time to time. [Time
interval attributes] is used to set the time interval for states and
positions.

Position speed: The speed of movement. The unit is 0.1 second.
Supposed that [Speed] is set to 10, the object’s position will change
each second.
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Image state change: Determines how state changes, either
[Position dependent] or [Time-based]. If [Position dependent] is
selected, the object state will change when position changes. If
[Time-based] is selected, the object position will change based on
[Position speed] and the object state will change based on [Image
update time].
Backward cycle: Assumed the object has four positions: position 0,
position 1, position 2, and position 3, and [Backward cycle] is not
selected. When the object moves to the last position (position 3),
the next position will be back to the initial position 0, and repeat.
The moving path is shown as follows:
position 0 → position 1 → position 2 → position 3 → position 0 →
position 1 → position 2…
If [Backward cycle] is selected, when the object moves to the last
position (position 3), it will move backwards to position 2, position
1 and then the initial position 0, and start over again. The moving
path is shown as follows.
position 0 → position 1 → position 2 → position 3 → position 2 →
position 1 → position 0…

Example 1
The object’s state and position are determined by the registers, and the addresses must be
configured correctly, as in the following table:
Data format

16-bit

32-bit

64-bit (cMT / cMT X only)

Object state

LW-n

LW-n

LW-n

Object position

LW-n+1

LW-n+2

LW-n+4

For example, if the designated register is LW-100 and the data format is [16-bit Unsigned], then
LW-100 represents object’s state, LW-101 represents position. In the picture below, LW-100 = 2,
LW-101 = 3, so the object’s state is 2 and position is 3.
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Profile Tab

Setting

Description

Shape rectangle size

Set the size of the shape.

Trajectory

Set the position of each point on the moving path.

Note


Since multiple pictures might be used by an [Animation] object, [Set to original dimension]
will not return all pictures to the original size.
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13.15. Bar Graph
Overview
Bar Graph object displays data as a bar graph for visualization.
Configuration

Click [Object] » [Chart] » [Bar Graph] icon on the toolbar to open Bar Graph dialog box. Select
properties, click OK button, a new Bar Graph object is created.
General Tab
cMT / cMT X
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eMT, iE, XE, mTV

Setting

Description

Read address

Click [Setting] to Select the [Device], [Device type], [Address],
[System tag], and [Index register] of the word devices that controls
how the bar graph displays.
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Outline Tab
cMT / cMT X

eMT, iE, XE, mTV

Setting

Description

Type

Choose either [Bar] or [Circular].

Attribute

Mode
Choose either [Normal] or [Offset]. If [Offset] is selected, an
original value [Origin] must be entered for reference.
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Direction / Degree
Bar: Determine the bar graph direction. Available options are [Up],
[Down], [Right], and [Left].
Circular: Determine the circular bar graph direction. Available
options are [Clockwise] and [Counter clockwise].

If [Full circle] is selected, set the start degree.
If [Full circle] is not selected, set the start and end degree.
Bar width ratio (%)
The ratio of bar to object width. The figure below shows two ratios,
100% and 50%.

Hole Radius (%)
The ratio of the radius of the hole to the radius of the whole
circular bar graph. The figure below shows two ratios, 0% and 50%.

Color/Style

Set the bar’s frame and background color, bar style, and bar color.
See the picture below.
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Dynamic
color

(For cMT / cMT X Series models only) With this option selected, the
interior color of the bar is determined by the value in the
designated address.

Range Tab

Setting

Description

Zero / Span

The percentage of filling can be calculated by the formula, see
Example 1.

Target
indicator

When the register value meets the condition, the color of filled
area will change to the target color, see Example 2.

Alarm
indicators

If the register value is larger than [High limit], the color of filled
area will change to [High color]. If the register value is smaller than
[Low limit], the color will change to [Low color].
Please note that when [Dynamic color] is enabled, the Target
indicator and Alarm indicator settings will not be present and their
colors are determined by the designated addresses.

Dynamic
taget/alarm

When [Enable] is selected, the [Low limit] and [High limit] of [Alarm
indicator] and the [Target Value] of [Target indicator] will use
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/zero(span)

designated registers, which is shown in their respective fields see
Example 3.

Example 1
The percentage of filling can be calculated by the following formula:
Percentage of filling =

Register value − [Zero]
× 100%
[Span] − [Zero]

Assume [Offset] is selected. If (Register value – [Zero]) is greater than 0, the bar will fill up from
[Origin]. If (Register value – Zero) is less than 0, the bar will be drawn below [Origin].
For example, [Origin] is 5, [Span] is 10, and [Zero] is 0.
For different value in read address, it will display as below:
If the value at read address is 4:
If the value at read address is 8:

Example 2
When the register value meets the following condition, the color of filled area will change to
the target color.
[Target Value] - [Tolerance] ≤ Register value ≤ [Target Value] + [Tolerance]
Assume [Target Value] is 5 and [Tolerance] is 1. As shown below, if the register value is equal to
or larger than 4 (=5-1) and equal to or less than 6 (=5+1), the filled area’s color of the bar will
change to the target color.
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Example 3
If [Dynamic target/alarm] is enabled, [Low limit] and [High limit] of [Alarm indicator] are
defined by designated registers as shown in the following table. Furthermore, if [Dynamic
zero/span] is used, [Zero], [Span] and [Origin] will be defined by designated registers. Assume
the address is LW-n, the limits are:
Data format

16-bit

32-bit

64-bit (cMT / cMT X only)

Alarm Low Limit

LW-n

LW-n

LW-n

Alarm High Limit

LW-n+1

LW-n+2

LW-n+4

Target

LW-n+2

LW-n+4

LW-n+8

Zero

LW-n+3

LW-n+6

LW-n+12

Span

LW-n+4

LW-n+8

LW-n+16

Origin

LW-n+5

LW-n+10

LW-n+20

Combo Setting
cMT / cMT X Series HMI support combo setting for Bar Graph, which allows setting of multiple
related objects at a time. Bar Graph can be set with Background and Dynamic Scale.

EasyBuilder Pro V6.08.01

13-99

Objects

Background

Setting

Description

Margin

Specify the space between the background edge and
the objects.

Color/Style

Customize

Select a suitable background pattern and color.
Picture

Use the default picture or choose a picture from
Picture Library.
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Dynamic Scale

Setting

Description

Style

The scale style will follow the bar type.

Tick Mark

Configure the number of tick marks for main and
sub scales. If the style is circular, the radius and tick
mark length can be specified.

Scale Label

Configure the font, font color, font size and other
attributes of scale label.
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13.16. Meter Display
Overview
Meter Display object displays the value of word register with a meter.
Configuration

Click [Object] » [Chart] » [Meter Display] icon on the toolbar to open the Meter Display dialog
box. Set the object’s attributes and then click OK to create a new Meter Display object.
eMT, iE, XE, mTV Series
General Tab

Setting

Description

Read address

Click [Setting] to select the [Device], [Device type], [Address],
[System tag], and [Index register] of the word devices that controls
the Meter Display object.
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Outline Tab

Setting

Description

Degree

Set the pointer to go around the meter clockwise or
counterclockwise.
Sets the object’s start degree and end degree measured clockwise
from the 12 o’clock position. The angle range is 0 to 360 degrees.
The following shows meters of different settings.
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Background



[Start degree] =290∘
[End degree] = 70∘



[Start degree] = 120∘
[End degree] = 240∘



[Start degree] = 40∘
[End degree] = 140∘



[Start degree] = 225∘
[End degree] = 315∘

Sets the object’s background color and profile color.
Full circle
When selected, the object will display the whole circle. Otherwise, the
object will only display a partial circle in the defined degree range, as
shown in the following figure.

Transparent
When selected, the object will not display the background and profile
color.
Tick marks

Configures the number of tick mark and color.

Pointer

Configures pointer’s style, length, width, and color.

Pin point

Configures the style, radius, and color of the pin point.
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Limits Tab

Setting

Description

Value

Sets the object’s display range. Meter Display object will use the
value of [Zero] and [Span] and the value of register to calculate the
pointer’s position. See Example 1.

Range limits

Configures the values of [Low limit], [High limit], their
corresponding display colors, and the width.

Use user-defined radius
Configures the radius to display range limits.
For example, set to 80:

Set to 30:
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Dynamic Limits
The low limit and high limit are set by registers. See Example 2.
Scale label

Select the attribute of scale label on Meter Display.

Example 1: Pointer position calculation
Set object’s display range. Meter Display object will use the value of [Zero] and [Span] and the
value of register to calculate the pointer’s position. For example, supposed that [Zero] is 0,
[Span] is 100, when the value of register is 30, [Start degree] is 0, and [End degree] is 360, then
the degree indicated by the pointer is:
{ (30 – [Zero]) / ([Span] – [Zero]) } * ([End degree] - [Start degree]) =
{(30 – 0) / (100 - 0)} * (360 – 0) = 108
Pointer will be pointing at 108 degrees.

Example 2: Dynamic Limits
The low limit and high limit are set by the register.
Suppose the address is LW-n, the following table shows the read address of low limit and high
limit:
Content

16-bit

32-bit

64-bit (cMT / cMT X only)

Low limit

LW-n

LW-n

LW-n

High limit

LW-n+1

LW-n+2

LW-n+4

For instance, when address is LW-100, the rule of setting limits is:
Content

16-bit

32-bit

64-bit (cMT / cMT X only)

Low limit

LW-100

LW-100

LW-100

High limit

LW-101

LW-102

LW-104
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cMT / cMT X Series
General Tab
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Setting

Description

Style

Select a style from the drop-down list. Available options include:
[Custom], [Style 1], [Style 2], and [Classical]. If [Custom] is selected,
properties such as the width / length of the pointer or the radius of
the pin point, etc must also be manually set.
The following background-related settings are available using [Style
1], [Style 2], or [Classical]:
Color
Sets the color of the background picture of meter.
Outline
The following is the outline of Style 1 when [Full circle], [Half
circle], or [Quarter circle] is selected.

The following is the outline of Style 2 when [Full circle], [Half
circle], or [Quarter circle] is selected.

Angle

Rotation
Rotates the background picture clockwise according to the angles
set.
Direction
Sets the range to label the scale, using twelve o’clock direction as
the 0∘reference.
Degree
Available options include: [Predefined] and [Custom]. With
[Predefine] selected, pick from the thumbnails configure directions
and angle ranges with ease.
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Enable
animation
Value
Read address
Indicator
Range limit

Scale

Full circle
If selected, the full circle is drawn according to the selected
direction and the start angle. The limits are determined by the
value set in [Minimum] and [Maximum] field under [Value].
If selected, the pointer slides to the designated position when the
read value changes; if not selected, the pointer directly points to
the designated position when the read value changes.
Sets the lower and upper limits of the meter.
Displays the value in meter according to the value in the designated
word register.
Sets the style of pointer and pin point. If [Custom] is selected, the
direction of the pointer must points upward to correctly display.
Sets the colors to indicate different ranges.
Dynamic limits
The low limit and high limit are decided by the register. See
Example 2 in the previous section.
Sets the number of main and sub scale, the color of tick marks and
scale label.

Click the icon to download the demo project. Please confirm your internet connection
before downloading the demo project.
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13.17. Trend Display
Overview
Trend display objects draw curves of the data recorded by Data Sampling object.
Configuration

Click [Data/History] » [Trend Display] icon on the toolbar to open a Trend Display object
property dialog box. Set up the properties, press OK button, and a new Trend Display object
will be created.
eMT, iE, XE, mTV Series
General Tab

Button

Description
Go to the earliest sampling data.
Go to the previous time interval.
Click to stop auto-scrolling. When the new sampling data is
generated, the display does not scroll, nor is the new data outside
the display range displayed.
Click to start auto-scrolling. The display scrolls as the new sampling
data is generated.
Go to the next time interval.
Go to the latest sampling data.
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Setting

Description

Data
Sampling
Object index

Select a Data Sampling object as the source data.

Refresh data
automatically

In history mode, when this option is selected, Trend Display will be
automatically refreshed every 10 seconds. If this option is not
selected, Trend Display can only be refreshed by changing window.

No line
connection
between
records if the
next record is
earlier

When HMI time is adjusted to an earlier time, and data sampling
keeps going on, selecting this option can prevent the system from
drawing a line to connect the gap between current trend curve
(earlier in time axis) and former trend curve (later in time axis). This
can slow down refresh speed.

Trend type

Select the mode of data source, either [Real-time] or [History].
Real-time
In this mode, the display object shows all sampled data since the
HMI started. The maximum number of records that can be sampled
is set in [Max.data records] (Real-time mode) of the Data Sampling
object. When the sampling data exceed this setting, the earlier
data will be deleted. To show older data, use [History] mode.
[Hold control]: Suspends the update of Trend Display. However, it
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does not stop the sampling process of Data Sampling object.
History
In this mode, the data comes from the history data files stored on
HMI. The history data files are sorted by dates, and each is given an
index. The system uses [History control] to select the history data
files that are created on different dates.
The system sorts the history data of sampling data by date; the
latest file is record 0 (typically the data sampled today), the second
latest file is record 1, and so on. If the value of designated register
in [History control] is n, the Trend Display object will display data
record n.
Here is an example to explain [History control]. If the designated
register is LW-0, and the sampling data files available are
pressure_20061120.dtl, pressure_20061123.dtl,
pressure_20061127.dtl, and pressure_20061203.dtl, and it is
2006/12/3 today, based on the value of LW-0, the sampling data
file which will be selected by [Trend Display] is shown as follows:
Value of LW-0

Selected sampling history data

0

pressure_20061203.dtl

1

pressure_20061127.dtl

2

pressure_20061123.dtl

3

pressure_20061120.dtl

If use with Option List object and select data source as [Dates of
historical data], the history data will be sorted by date and
displayed in Option List object, see “13.29 Option List”.
Pixel

[Distance] is used to set the distance between two sampling points,
as shown in the following figure.

Time

[Distance] is used to set the X-axis in unit of time, as shown in the
following figure.

EasyBuilder Pro V6.08.01

13-112

Objects

Select [Time] for [X axis time range] and go to [Trend] » [Grid] and
enable [Time scale]. Please refer to [Time scale] in the later section.
Dynamic
distance
between data
samples/
Dynamic X
axis time
range

Designate a 32-bit word register for adjusting the distance between
two sampling points (select Pixel), or the time unit represented by
X-axis (select Time). If no value is entered, the default value will be
used.
Click the icon to download the demo project. Please confirm
your internet connection before downloading the demo project.

Refresh data
automatically

If selected, every time when opening the window on which the
Trend Display object in history mode is placed, the display is
automatically refreshed every 10 seconds. Please note that:
 The refresh status can be observed from the control button of
Trend Display object.
Showing
button: The automatic refresh feature is
enabled.
Showing
button: The automatic refresh feature is





disabled.
When scrolling to the previous data, the automatic refresh
feature is disabled, the
button is shown.
If [Refresh data automatically] check box is selected, when
change back to the window, the display is refreshed, ignoring
the control buttons. For example, select [Refresh data
automatically], and scroll to the previous data, the automatic
refresh feature is disabled. In this case, changing to another
window and then change back will still refresh the display.
If [Refresh data automatically] check box is not selected when
building the project, the feature can still be enabled by
pressing
button on HMI. In this case, the automatic
refresh feature is disabled, that is, even when change back to
the current window, the display will not be refreshed.
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Hold control

When the register is set ON, suspend the update of Trend Display. It
does not stop the sampling process of Data Sampling object. This
setting is available only in Real-time mode.

Watch line

Use the [Watch line] function to display a “watch line” when user
touches the Trend Display object. It will also export the sampling
data at the position of watch line to the designated word device
and use Numeric objects to display the results, as shown in the
following figure.

[Watch line] can also export sampling data with multiple channels.
The system will consecutively write each channel to the specified
address and the following addresses, in the same order as in [Data
Sampling] object. The address assigned to [Watch line] is the start
address, and sampling data for each channel will be exported to
the word devices starting from “start address.” If the data format of
each channel is different, the corresponding address of each
channel is arranged from the first to the last. If the watch register is
LW-300, watch function will export each channel’s data to the
following addresses:
Register

Channel

Data format

LW-300

0

16-bit Unsigned (1 word)

LW-301

1

32-bit Unsigned (2 words)

LW-303

2

32-bit float (2 words)

LW-305

3

16-bit Signed (1 word)

Click the icon to download the demo project. Please confirm
your internet connection before downloading the demo project.
Time stamp
output

Time stamp output
Suppose the address is set to LW-n, then:
If enabled, the system will use the time of the first sampling data as
“time origin”, and write the time stamp of the most recent sampled
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data (relative to “time origin”) to [LW-n+2].
When clicking on the curve, the time stamp of the closest sampled
point will be written to [LW-n].
Clear real-time data address (Data Sampling object) will clear the
time origin as well.
Time stamp is recorded in seconds.
Trend Tab

Setting

Description

Transparent /
Frame /
Background

Select the color of frame and background.

Show scroll
controls

Enable or disable the scroll control as shown in the following figure.

Grid

Set the number of dividing lines and the line color. The number of
divisions depends on the setting in General tab » [Distance
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between data samples] / [X axis time range].
X-axis interval
The number of vertical grid lines.
 Select [Distance between data samples] in General tab:
Select how many sampling points will be included between two
vertical grid lines.
 Select [X axis time range] in General tab:
Select the time range between two vertical grid lines.
X-axis division
The number of vertical grid lines.
Y-axis division
The number of horizontal grid lines.
Time scale

Select [Time] / [Date] check box to display the time scale along the
x axis.

Font / Color / Size
Select the font, font color, and font size of the time scale.
The default font size is 8.
Time / Date

Relative time mode
When this mode is selected, the time of the earliest sampling data
will be the start time from which to count a relative time. This
mode works with time scale [SSSSSS] and under this mode, time
scale [Date] cannot be used.
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The time of the latest sampling data will be marked on the top left
corner of the object. This group box is used to set the time / date
display format and font color.
Channel Tab

Setting

Description

Y scale

Set Y-axis to be Main Axis or Aux. Axis. See “Y Scale Tab” for more
information.

Channel

Configure each sampling line’s format and color.
Dynamic limits
 Not selected:
[Zero] and [Span] are used to set the low limit and high limit of
sampling data. If the low limit is 50 and the high limit is 100 for one
sampling line, [Zero] and [Span] must be set as [50] and [100], so
that all the sampling data can be displayed in the trend display
object.
 Selected
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The low limit and the high limit are read from the designated word
devices, as shown below. When address is LW-n, the register’s
address:
64-bit
Data Format
16-bit
32-bit
(cMT /
cMT X
only)

Low limit

LW-n

LW-n

LW-n

High Limit

LW-n+1

LW-n+2

LW-n+4

For example, if LW-100 is used here, the low limit and the high limit
will be read from:
Data Format

16-bit

32-bit

64-bit
(cMT /
cMT X
only)

Low limit

LW-100

LW-100

LW-100

High Limit

LW-101

LW-102

LW-104

A typical usage of this is to zoom in and zoom out of Trend Display.
(Not available for cMT / cMT X Series). See Example 1.
Click the icon to download the demo project. Please confirm
your internet connection before downloading the demo project.
Channel
visibility
control

If [Enable] is selected, the bits of the assigned word register will be
used to show/hide each channel. The first bit controls the first
channel, and the second bit controls the second channel, and so
on. For example, suppose there are 5 channels and LW-0 is used,
channels which will be shown given the states of the control bits
are:
Channel
Control Bit
State
Displayed
1
LW_bit-000
OFF
YES
2
LW_bit-001
ON
NO
3
LW_bit-002
ON
NO
4
LW_bit-003
OFF
YES
5
LW_bit-004
OFF
YES
Note on using this feature: Each control bits are not reserved for
the channel. If a particular channel is not displayed, the control bit
is assigned to the next displayed channel. For example, if the third
channel of the 5 channels is not displayed, only 4 channels will be
displayed in Trend Display, and the used control bits will only be:
LW_bit-000~003.
Click the icon to download the demo project. Please confirm
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your internet connection before downloading the demo project.

Note



A Trend Display can display up to 64 channels simultaneously.
A Trend Display can only display channels with serial number ≤ 256; therefore, channels
with serial number greater than 256 cannot be selected.

Y Scale Tab

Setting
Y scale

Description

Scale font

Select the font, font color, and font size of the scale.

Dynamic
Y-scale
visibility

To show or hide Y-scale. If the control address is LW-50, then the
first axis is controlled by LW_Bit 5000, and the second axis is

Dynamic
main axis

To change the main axis. If writing 1 into LW-80, the main axis will
be Channel 1; if writing 2 into LW-80, the main axis will be Channel,
and so on.

Show whether Y-axis is Main Axis or Aux. Axis.
Y-axis will not be displayed when [none] is selected for Y scale in
Data Sampling Object group box. At most 32 Y axes can be
displayed, including one main axis and multiple aux. axes.

controlled by LW_Bit 5001, and so on.

EasyBuilder Pro V6.08.01

13-119

Objects

Note


A Trend Display on an eMT/iE/XE/mTV model can display 6MB of data in maximum.
Click the icon to watch the demonstration film. Please confirm your internet connection

before playing the film.
Click the icon to download the demo project. Please confirm your internet connection
before downloading the demo project.
cMT, cMT X Series
General Tab

The Trend Display on cMT / cMT X Series combines Real-time mode and History mode. Drag
left to scroll the Trend Display to view history data and drag right to view the latest sampling
data. Pinch two fingers together to zoom out Trend Display or spread them apart to zoom in.

Zoom In

Zoom Out

For more information about how sampling data is saved, see “8 Data Sampling”.
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Setting
Data
Sampling
Object index
Millimeter

Description

Time

Same as eMT, iE, XE mTV Series.

Pixel

Same as eMT, iE, XE mTV Series. The upper limit is 1920 pixels.

Dynamic
distance
between data
samples
Watch line

Same as eMT, iE, XE mTV Series.

Time stamp
output

When enabled, the number of seconds passed from the first

Select a [Data Sampling] object as the source data.
Same as eMT, iE, XE mTV Series. The upper limit is 500 mm.

Same as eMT, iE, XE mTV Series.
sampling data can be calculated.
Suppose the address is set to LW-n, then:
[LW-n]: The number of seconds passed from the first sampling data
to the closest sampled point.
[LW-n+2]: The number of seconds passed from the first sampling
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data to the most recent sampling data.
Enable day output
With this option selected, the number of days passed since
1970/1/1 can be calculated.
Suppose the address is set to LW-n, then:
[LW-n+4]: The number of days passed since 1970/1/1 to the closest
sampled point.
[LW-n+6]: The number of days passed since 1970/1/1 to the most
recent sampling data.
History
Control

Same as eMT, iE, XE mTV Series.
Enable reading multiple histories:
In the following two modes, days are calculated backward.
Number of days
Suppose the address is set to LW-n, then:
[LW-n]: The start day index from which to calculate number of days.
0: today, 1: yesterday, and so on.
[LW-n+2]: The total number of days before the start day.
Specific days
Suppose the address is set to LW-n, then:
[LW-n]: The start day index from which to calculate number of days.
0: today, 1: yesterday, and so on.
[LW-n+2]: The end day index, the specified value must be greater
than that of the start day index. For example, if start is 4 and end is
7, the specified days will be 4 days before to 7 days before.
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Display Tab

Setting
Option
button
visibility (cMT
Series)

Description
Show or hide the option button

of the object.

Predefined
Select [Enable] to show the option button.
Dynamic
Choose a bit address to control option button visibility.

Zoom button
visibility

Show or hide the zoom button

Display
option

Adapt to device screen pixel density (DPI)

of the object.

With this option selected, text size, position, and the spacing
between Y axes will be adjusted according to the DPI of the screen
of the connected device.
Show custom file name
This option appears when [Customized file handling] is selected in
Data Sampling. With this option selected, the customized file name
is shown as caption in Trend Display.
Connect data gaps
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Data sampling stops when PLC is disconnected, and after PLC is
reconnected, the trend curve of the disconnected period is plotted
with a gap. With this option selected, the system will draw a line to
connect the gap between the former trend curve (before
disconnected period) and the current trend curve (after
disconnected period).
Touch

Disable Y-axis scrolling with swiping up/down
With this option selected, dragging the object with your finger will
only scroll X-axis range while Y-axis remains being placed in the
middle of the object even if it is zoomed in/out.
Disable X axis zoom
With this option selected, dragging the object with your finger will
only scroll Y-axis range.
Disable Y axis zoom
With this option selected, dragging the object with your finger will
only scroll X-axis range.
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Trend Tab

Setting

Description

Transparent /
Frame /
Background

Select the color of frame and background.

Grid

Set the number of dividing lines and the line color. The number of
divisions depends on the setting in General tab » [Distance
between data samples] / [X axis time range].
X-axis interval
The number of vertical grid lines.
 Select [Distance between data samples] in General tab:
Select how many sampling points will be included between two
vertical grid lines.
 Select [X axis time range] in General tab:
Select the time range between two vertical grid lines.
X-axis division
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The number of vertical grid lines.
Y-axis division
The number of horizontal grid lines.
Time scale

Select [Time] / [Date] check box to display the time scale along the
x axis. The position of the time scale can be selected.
The default font size is 8.

Time / Date

Relative time mode
When this mode is selected, the time of the earliest sampling data
will be the start time from which to count a relative time. This
mode works with time scale [SSSSSS] and under this mode, time
scale [Date] cannot be used.
The time of latest sampling data will be marked on the top left
corner of the object. This group box is used to set the time / date
display format and font color.

Channel Tab

Setting

Description

Y scale

Set Y-axis to be Main Axis or Aux. Axis. See “Y Scale Tab” for more
information. At most 32 Y axes can be displayed, including one
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main axis and multiple aux. axes.

Channel

Configure each sampling line’s format and color.
Dynamic limits
 Not selected:
[Zero] and [Span] are used to set the low limit and high limit of
sampling data. If the low limit is 50 and the high limit is 100 for one
sampling line, [Zero] and [Span] must be set as [50] and [100], so
that all the sampling data can be displayed in the trend display
object.
 Selected
The low limit and the high limit are read from the designated word
devices, as shown below. When address is LW-n, the register’s
address:
64-bit
Data Format
16-bit
32-bit
(cMT /
cMT X
only)

Low limit

LW-n

LW-n

LW-n

High Limit

LW-n+1

LW-n+2

LW-n+4

For example, if LW-100 is used here, the low limit and the high limit
will be read from:
64-bit
Data Format
16-bit
32-bit
(cMT /
cMT X
only)

Channel
visibility
control

Low limit

LW-100

LW-100

LW-100

High Limit

LW-101

LW-102

LW-104

If [Enable] is selected, the bits of the assigned word register will be
used to show/hide each channel. The first bit controls the first
channel, and the second bit controls the second channel, and so
on. For example, suppose there are 5 channels and LW-0 is used,
channels which will be shown given the states of the control bits
are:
Channel
1
2
3
4

Control Bit
LW_bit-000
LW_bit-001
LW_bit-002
LW_bit-003

State
OFF
ON
ON
OFF

Displayed
YES
NO
NO
YES
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5
LW_bit-004
OFF
YES
Note on using this feature: Each control bits are not reserved for
the channel. If a particular channel is not displayed, the control bit
is assigned to the next displayed channel. For example, if the third
channel of the 5 channels is not displayed, only 4 channels will be
displayed in Trend Display, and the used control bits will only be:
LW_bit-000~003.

Note



A Trend Display can display up to 64 channels simultaneously.
A Trend Display can only display channels with serial number ≤ 256; therefore, channels
with serial number greater than 256 cannot be selected.
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Y Scale Tab

The scale along the Y axis of a specific channel can be displayed. To enable Y Scale, [Grid]
should first be enabled in [Trend] tab.
Setting

Description

Y Scale

Hide channel Y scale when channel data is invisible
This option is selected by default. With this option selected,
whether channel Y scale is shown or hidden is determined by the
settings in Channel Visibility Control.
Value alignment
Set the alignment of Y axis tick values.
Center on tick
Full text

Y Scale can be configured on the in cMT Viewer as shown in the following steps.
1.

Tap the

button on the upper right corner of Trend Display object.

2.

Tap [Trend Display Setting] » [Y Scale].
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3.

Set channel visibility.

Data Format Tab
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Setting

Description

Follow
settings in the
Data
Sampling

Use the [Right of decimal Pt.] setting in Data Sampling.

Right of
decimal Pt

The number in this field determines the number of decimal places
of the value displayed; for example, when 1 is entered in this field,
and the original value obtained by Data Sampling is 45, then 4.5
will be displayed in Trend Display as a result.

Example 1
The example explains how to zoom in or zoom out Trend Display. The feature described is not
available for cMT / cMT X Series.
In Channel tab select [Dynamic limits] check box. If the [Address] is set to LW-n, then LW-n
controls the low limit where LW-n+1 controls the high limit.

Set [Address] to LW-0 and create two Numeric objects for entering the low / high limit. The
address that controls the low limit is LW-0; the address that controls the high limit is LW-1.
Let’s suppose the data is between 0 and 30; set the [Low limit] to 0 and the [High limit] to 30,
the trend curve is displayed as shown in the following figure.

To zoom out the Trend Display, enter a value greater than 30 in [High limit] as shown in the
following figure.
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To zoom in the Trend Display, enter a value less than 30 in [High limit] as shown in the following
figure.

Click the icon to download the demo project. Please confirm your internet connection
before downloading the demo project.
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13.18. History Data Display
Overview
History Data Display object displays data stored by Data Sampling object. It differs from Trend
Display in that History Data Display object uses a table to display data. The following is an
example of a history data display object.

A History Data Display on an eMT/iE/XE/mTV model can display 6MB of data in maximum. The
data will not be displayed after exceeding the limit.
Configuration

Click [Data/History] » [History Data Display] icon on the toolbar to open a History Data Display
object property dialog box. Set up the properties, press OK button, and a new History Data
Display object will be created.
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General Tab
cMT, cMT X

eMT, iE, XE, mTV

Setting
Data
Sampling
object index

Description

Refresh Data
Automatically

The system will refresh data every 10 seconds. When this option is
not selected, data can be freshed only by changing windows.

Style

Select History Data Display object’s style.

Grid

Select a Data Sampling object as the source data.

Shows grids between rows and columns.
Color
Change the color of grids.
Column interval
Change the width of each column. The figures below are the
examples.
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Profile color

Change the color of frame and background. Use [Transparent] to
hide frames and background.

Text

Change the font and font size.

Time / Date

Time ascending
Put earliest data at the top and the latest data at the bottom.
Time descending
Put the latest data at the top and the earliest data at the bottom.

History
Control
(eMT, iE, XE,
mTV Series)

The history files are sorted by date and each file is given an index.
The latest one is assigned index 0 (in most cases: today), the
second latest file is assigned index 1, and so on. [History Control] is
used to specify the history data to be shown.

Watch (cMT /
cMT X Series)

By tapping on a record in History Data Display object, data in the
selected row can be output to the designated addresses.

History
Control (cMT
/ cMT X
Series)

Same as eMT, iE, XE mTV Series.
Enable reading multiple histories:
In the following two modes, days are calculated backward.
Number of days
Suppose the address is set to LW-n, then:
[LW-n]: The start day index from which to calculate number of days.
0: today, 1: yesterday, and so on.
[LW-n+2]: The total number of days before the start day.
Specific days
Suppose the address is set to LW-n, then:
[LW-n]: The start day index from which to calculate number of days.
0: today, 1: yesterday, and so on.
[LW-n+2]: The end day index, the specified value must be greater
than that of the start day index. e.g. start: 4, end: 7, the specified
days will be 4 days before to 7 days before.

Note


When using cMT / cMT X Series, use the gear icon in the upper-right corner of History
Data Display object in cMT Viewer to select the date and display the data.
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Click the icon to watch the demonstration film. Please confirm your internet connection
before playing the film.
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Display Tab
cMT, cMT X

eMT, iE, XE, mTV

Setting

Description

Time / Date

Enable or disable showing the time and date and configure its
format and color.
Move column [Date] to the front of column [Time]
Swap the position of column [Date] and column [Time].

Sequence no.

Show the sequence number of all records.

Row

Multi-line display
Display a specified number of lines of data. Data will be displayed
as specified regardless of the actual number of lines of data.
Show or hide the option button

Option
button
visibility (cMT
/ cMT X
Series)

.

Predefined
Select [Enable] to show the option button.
Dynamic

Designate a bit address to control option button visibility.
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Data Format Tab
cMT / cMT X Series

Setting
Channel

eMT, iE, XE, mTV Series

Description
Each History Data Display object can display up to 64 channels. Check
[Display] to select the channels to be shown on the screen. In the
figure above, there are 4 channels (channel 1 to channel 4) in the
Data Sampling object, and only Ch.1 and Ch.4 are selected. The data
formats are shown next to channel name. The data format of each
channel is decided by the corresponding Data Sampling objects. The
result is shown below:

When using cMT / cMT X models, Data Sampling’s Data Format
settings can be applied to History Data Display object.
Two display modes are available when displaying [String] format in
History Data Display object:
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Follow settings in the Data Sampling.
Reverse high byte and low byte data and then display.

Title Tab

Setting
Use headers

Description

Background

Transparent
When selected, hide the background for title area.
Color
Set the background color of title.
Defines the text to be shown on the title.
The text can be edited in Label Tag Library. Build the Label Tag
Library first, and in History Data Display settings dialog select the
checkbox in the Label Library column, and then select the label tag.

Setting

Enable or disable title, which is marked as shown below:
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Note


After running simulation on PC, to run simulation again using the same project that
contains some changed data, please find the HMI_memory, SD_card, or usb1 folder in
EasyBuilder Pro installation, and then delete the old data sampling records in it, to prevent
the system from reading old data in the second simulation.

Edit Tab
cMT / cMT X Series

Setting
Control
address

eMT, iE, XE, mTV Series

Description
LW-n: Command
Value

Description

1

The data in Data Address will
overwrite the data in data log.

2

The selected data log will be deleted.

LW-n+1: Result (cMT / cMT X Series)
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Data address

Value

Description

0

The command is executed
successfully.

1

The external device is not connected.

2

The command is not supported.

3

The record cannot be found.

The system will start reading row by row from the selected one in
History Data Display, and change the data log accordingly.
Please note that the settings in this address must be identical to
that in Data Sampling.

Select
address

By changing the value in Select Address, the corresponding row in
History Data Display can be selected.
Please note that:
1. When the value in Select Address is 0, no row will be selected,
and the value in Data Address will stay the same as that of the
previously selected row number.
2. When the value in Select Address exceeds the total number of
rows in History Data Display, the last row (the one with largest
row number) will be selected.

Note


When an external device is used to save data log, removing the external device will make
Edit function ineffective. Editing can keep on when the external device is inserted again
and the system starts reading historical data.
Click the icon to watch the demonstration film. Please confirm your internet connection

before playing the film.
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13.19. Data Block Display
Overview
Data Block is a combination of several word devices with continuous address, where the X axis
of Data Block Display object represents the address and the numbers on the Y axis represent
the data values in the corresponding address. Data Block Display object can display multiple
data blocks. For example, it can display two data blocks LW-12~LW-15 and RW-12~RW-15 in
trend curves simultaneously. It is very useful to observe and compare the difference of trend
curves.

The display result
Configuration

Click the [Object] » [Chart] » [Data Block Display] icon on the toolbar to open the property
dialog box. Set up the properties, press OK button, and a new Data Block Display object will be
created.
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General Tab

Setting

Description

Comment

Description of the object.

No. of
channel

Set the no of channel for this object. Each channel represents one
data block. The maximal number of channels is 12.

Watch Line

If enabled, when user touches the [Data Block Display] object, it
will display a vertical cursor line on it, and store the data on the line
to the designated registers. See Example 1.
Allow input (cMT / cMT X Series)
With this checkbox selected, entering a value in the specified
address for watch line can move the verticle watch line to the
desired position.
Select the channel to be configured.
Specify the control address also the data source.
Control address is used to control and clear the drawn curve. After
executing the operation below, the system will reset the control
word to zero.
Enter “0” = No action (default)
Enter “1” = Draw (Without clear first)
Enter “2” = Clear

Channel
Control
address
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Limit

Enter “3” = Redraw
No. of data address
If control address is LW-n, then LW-n+1 stores the number of word
devices in each data block, i.e. the number of data. The maximum
value is 1024.
Data storage start address
If [Offset to start address] is enabled, the [Offset value storage
address] will be set as [Control address] + 2.
If select 16-bit data format, the address for each data will be start
address, start address + 1, start address + 2 and so on.
If select 32-bit data format, the address for each data will be start
address, start address + 2, start address + 4 and so on.
For more information about control address, see Example 2 to 5.
Set the minimum and maximum limit for the curve.

Note


Without clearing the drawn lines, Data Block Display can be drawn a number of times by
entering value 1 in the control address repeatedly. The way to calculate the maximum
number of times is: 32 divided by the number of channels.
1 channel 32 times
2 channels16 times
16 channels2 times

Example 1
How to use watch (Cursor Line) feature
Use “Watch” function to check the value of any point of the curve. When the user touches
[Data Block] object, it will display a “cursor line”, and the system will write the index and value
of that data on the cursor line to the designated address.
Data Format

Index Value

Channel 1 Value

Channel 2 Value

16-bit

Address

Address + 1

Address + 2

32-bit

Address

Address + 2

Address + 4

Address

Address + 4

Address + 8

64-bit (cMT /
cMT X only)

When watch address is set to LW-n, the value written into LW-n represents the channel index
number to be called up. (Start form 0)

EasyBuilder Pro V6.08.01

13-144

Objects

Note



[Data Index] is a 16 bit unsigned integer. When the designated register of cursor line is 32
bit device, it will be stored in the bit 0-15.
If the channel to be viewed has no data, “0” will be displayed, as shown below. In the
example, there is no data in channel 1, when the cursor points at Data 4, “0” will be
displayed as shown below.



If there is less data in Channel 1, “0” will be displayed, as shown below.

Example 2
How to show a data block
1. Write the number of data to [No. of data address], i.e. “Control address+1”
2. Store the data consecutively beginning at [Data storage start address].
3.
4.

Write “1” to [Control address] to draw the curve without cleaning the plot. All previous
curves will not be erased.
The system will write “0” to [Control address] after marking the plot.
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Note


Do not change the content of [Control address], [No. of data address] and [Data storage
start address] between step 3 and step 4 above as doing so might cause error for the
trend curve plot.

Example 3
How to clear the graph
1. Write “2” to [Control address], all the trend curves will be cleared.
2.

The system will write “0” to [Control address] after the trend curve is cleared.

Example 4
How to clear the previous trend curve and display new one
1. Write the number of data to [No. of data address], i.e. “control address+1”
2. Store the data consecutively beginning at [Data storage start address].
3. Write “3” to [Control address], the previous trend curves will be cleared and the new
content in data block will be plotted on the screen.
4. The system will write “0” to [Control address] after the trend curve has been plotted.
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Example 5
How to use offset mode
If [Offset to start address] is selected, [Control address], [No. of data address], and [Offset
value storage address] will use 3 consecutive addresses.
For example, assume the total number of channels is 3 (start from 0 to 2), and the [Control
address] are LW-0, LW-100, and LW-200, respectively. Then, the other addresses will be set as
follows: (In the example, format 16-bit Unsigned is used and [Offset value storage address] are
all m).
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Item

Channel 0

Channel 1

Channel 2

Control Address

LW-0

LW-100

LW-200

No. of data
address

LW-1

LW-101

LW-201

Offset value
storage address

LW-2 (=m)

LW-102 (=m)

LW-202 (=m)

Data 1

LW-0+m

LW-100+m

LW-200+m

Data 2

LW-1+m

LW-101+m

LW-201+m

…

…

…

…

The following figure on the left shows the result when offset mode is not used while the figure
on the right shows the result when offset mode is used.

Note


When [Control address] is set to LW-n, [No. of data address] and [Offset value storage
address] are as follows:
Data Type
16-bit
32-bit
64-bit (cMT / cMT
X only)
Control address

LW-n

LW-n

LW-n

No. of data address

LW-n+1

LW-n+2

LW-n+4

Offset value storage address

LW-n+2

LW-n+4

LW-n+8



If the control registers are 32-bit devices, only bit 0-15 will be used for control purpose, bit
16-31 will be ignored. (as illustrated below)



When the value in [Control address] is not zero, the system will read [No. on data address]
and [Offset value storage address].
It is recommended to use [Offset to start address] for data block display with multiple
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channels and the same device type. As shown in the following figure, The control words of
channel 1 is located from LW-n, the control words of channel 2 is located from LW-n+3,
and so on.

Display Area

Setting

Description

Description

Data samples
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Configure the maximal number of data samples (points) to be
displayed.
Samples to scroll
Configure the number of data samples being scrolled.
Enable scroll switch
Clicking

displays the previous or next data point.

Clicking

displays the first or the last data point.

Profile

Set the color of the frame and background of the object.
Transparent
Hides the background. Color selection will not be available.

Grid

Set the number of horizontal and vertical divisions shown by grid.

Channel

Set the color, width and style of each curve.

Click the icon to download the demo project. Please confirm your internet connection
before downloading the demo project.
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13.20. XY Plot
Overview
XY Plot object is used to display values for two variables (x,y) for a set of data, where the data
comes from word registers. Up to 16 channels can be displayed simultaneously. This object
facilitates data observation and analysis. Additionally, negative numbers can be displayed as
well.
Configuration

Click [Object] » [Chart] » [XY Plot] icon on the toolbar to open a [XY Plot] object property dialog
box.
General Tab

EasyBuilder Pro V6.08.01

13-151

Objects

Setting

Description

Direction

There are four selections, right, left, up or down.

No. of
channels

Set the number of channels for observation.

Control
address

Controls the operation of all channels simultaneously. When the
[Control address] is LW-n, assigning values to LW-n will issue
commands to XY plot according to the table below. Meanwhile,
LW-n+1 l controls the number of data points plotted. After
operation, the [Control address] will be reset to 0.
Control Value
Result
address
LW-n
1
Plots point on XY curve.
(The plotted points are kept.)
2
Clears all XY curves.
3
Clears then plots new XY curve.
LW-n+1
Any
Controls the number of data points plotted.
number
No. of data address
Controls the number of data points. Each channel can plot up to
1023 points.

Channel

Select a channel to configure.

Read Address

Device
Select a PLC which will be the source of [X data] and [Y data] and
designate a read address.
The format of the data register blocks used for the display channels
depends on whether [Separated address for X and Y data] and/or
[Dynamic limits] has been selected. See Example 1.

Dynamic
limits

 When not selected (See Example 2)
The Low and High limits can be set by entering constants. The Low
and High limits are used for calculating X and Y range in
percentage.
 When selected (See Example 3)
A zoom effect can be created by changing the Low / High Limits.
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Example 1
The format of the data register blocks used for the display channels depends on whether
[Separated address for X and Y data] has been selected, and if [Dynamic limits] has been
selected. The following explains the situations where 16-bit register is used:
 If [Separated address for X and Y data] is not selected, and set [Read address] to LW-n:
Select [Dynamic limits]



Not select [Dynamic limits]

X data

Y data

X data

Y data

Low Limit

LW-n

LW-n+2

Constant

Constant

High Limit

LW-n+1

LW-n+3

Constant

Constant

1st data

LW-n+4

LW-n+5

LW-n+0

LW-n+1

2nd

data

LW-n+6

LW-n+7

LW-n+2

LW-n+3

3rd data

LW-n+8

LW-n+9

LW-n+4

LW-n+5

4th data

LW-n+10

LW-n+11

LW-n+6

LW-n+7

If [Separated address for X and Y data] is selected, and set [X data] to LW-m, [Y data] to
LW-n:
Select [Dynamic limits]

Not select [Dynamic limits]

X data

Y data

X data

Y data

Low Limit

LW-m+0

LW-n+0

Constant

Constant

High Limit

LW-m+1

LW-n+1

Constant

Constant

1st

data

LW-m+2

LW-n+2

LW-m+0

LW-n+0

2nd data

LW-m+3

LW-n+3

LW-m+1

LW-n+1

3rd data

LW-m+4

LW-n+4

LW-m+2

LW-n+2

4th data

LW-m+5

LW-n+5

LW-m+3

LW-n+3

Example 2
When [Dynamic limits] is not selected, the Low and High limits can be set. The Low and High
limits are used for calculating X and Y range in percentage.
Scale (%) =

Read Address Value − Low Limit
High Limit − Low Lmit

If [Separated address for X and Y data] is not selected and the address is LW-n, the
corresponding limits are retrieved from the addresses as shown in the following table.
Data format

16-bit

32-bit

64-bit (cMT / cMT X only)

X axis low limit

LW-n

LW-n

LW-n

X axis high limit

LW-n+1

LW-n+2

LW-n+4

Y axis low limit

LW-n+2

LW-n+4

LW-n+8

Y axis high limit

LW-n+3

LW-n+6

LW-n+12
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Example 3
If [Dynamic limits] is selected, a zoom effect can be created by changing the setting of Low /
High Limits.
In the following example, XL=X low limit, XH=X high limit, YL=Y low limit, YH=Y high limit, and
XY, XY1, XY2 are three XY data. When changing the high limits of X and Y axis, the result is
shown below:

Original

Change the high limit of Y axis to 25.
(zoom in)

Change the high limit of Y axis to
100 (zoom out)

For more information, see “13.17 Trend Display”.

Note


X and Y data can be set to different formats. For example: If X data uses 16-bit unsigned, Y
data uses 32-bit signed, please note the address setting.



When using a Tag PLC, such as AB tag PLC, X and Y must be in the same format. When using
different formats a warning will be shown.
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Display Area Tab

Setting

Description

Profile color

Select the color of the frame and the background, or select
[Transparent] check box to hide the frame and background.

Curve

For each channel select the properties of color, width, and line
style.

Maker

Select the style of XY Plot. For eMT/iE/XE/mTV series, there are
four different types of XY plot as shown below:
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For cMT / cMT X Series, , there are six different types of XY plot as
shown below:

See Example 4.
Pen property

Select color, width and style for the line in XY plot.

Brush
property

Select point width.

Reference line

Up to 4 horizontal reference lines can be shown on the graph. Fill in
high, low limits and Y axis percentage values. Different colors can
be selected for each reference line.
If [Limit from PLC] is selected, designate a register to be the read
address of reference line.

Example 4
The curve shown in the following figure is drawn with 7 points numbered from P0 to P6.
The steps the system draws the X-axis Projection are:
1. Calculates the two points in X-axis – (X0, 0) and (X6, 0).
2. Link all the points in the order of (X0, 0), P0… P6, (X6, 0) and returns to (X0, 0) at last.
3. Fill out all enclosed areas.

Similarly for Y-axis projection:
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Note


Without clearing the drawn points, XY Plot can be drawn a number of times by entering
value 1 in the control address repeatedly. The way to calculate the maximum number of
times is: 32 divided by the number of channels.
1 channel 32 times
2 channels16 times
16 channels2 times
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13.21. Alarm Bar and Alarm Display
Overview
Alarm Bar and Alarm Display objects are used to display alarm messages which are defined in
Event (Alarm) Log objects. When the trigger conditions are met, events or alarms will be
displayed as they occur in chronological order in Alarm Bar or Alarm Display object.
Alarm Bar scrolls all alarm messages in one single display line, whereas Alarm Display shows
alarm messages in multiple lines.
For more information, see “7 Event Log”.

Alarm Bar - Displays alarm messages in one scrolling line.

Alarm Display – Displays alarm messages in multiple lines.
Configuration

Click [Data/History] » [Alarm Display] or [Alarm Bar] icon on the toolbar to open the object
property dialog box. Set up the properties, press OK button, and a new object will be created.
General Tab
The difference between these two objects is that Alarm Display allows an [Acknowledge
address] and a [Scrolling control address] to be set.
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Setting

Description

Enable
acknowledge
function

If selected, the [Acknowledge value] selected for the associated
event, specified in Alarm (Event) Log » Message tab will be written to
the [Acknowledge address] designated in Alarm Display. For more
information, see “7 Event Log”.

Scrolling
control
address

If enabled, the value in the designated control address indicates the
number of lines to be scrolled down. The minimal value is 0, which
indicates the first line. Please note that with this address enabled,
the horizontal and vertical scroll bars will not be available on the
object; please make sure that the width of the object is enough for
completely showing the content.

Note


When using a cMT / cMT X Series model, press and hold the event on the screen to
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acknowledge an event; drag a finger on the screen to scroll.
When using a cMT / cMT X Series model, a default minimal row height exists in Alarm
Display objects that have enabled Acknowledge function. The minimal row height
prevents the rows to be touch by mistake. On a small-sized HMI, the row height may be
slightly taller when Acknowledge function is enabled.

Alarm Tab
Alarm Bar

Alarm Display

Setting

Description

Include
categories

Events in the selected category will be displayed. The categories are
set in Event (Alarm) Log object.
For example, if the category is set to “2 to 4” here, only events in
categories 2, 3, 4 will be displayed. For more information, see “7
Event Log”.
cMT / cMT X Series
Dynamic Category Range is an option available only for cMT Series
models. With this option selected, an address can be designated for
dynamically selecting event categories to be displayed.
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Display

Display settings are only available for Alarm Bar.

Scroll speed
Select one of the speed settings at which the messages scroll.
Multi-line display
Messages can be displayed in multiple lines with this option selected.
Move
smoothly

When this option is selected, the message will move along the alarm
bar more smoothly. Please note that enabling this may lead to high
CPU loading.

Caption

Caption settings are only available for Alarm Display on cMT / cMT X
Series.

Option
button
visibility (cMT
/ cMT X
Series)

Show or hide the option button

.

Predefined
Select [Enable] to show the option button.
Dynamic

Designate a bit address to control option button visibility.
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Sort Tab
Alarm Bar

Alarm Display

Setting

Description

Order (Alarm
Bar)

Time ascending
Latest event is placed last in the list (the bottom).
Time descending
Latest event is placed first in the list (the top).

Order (Alarm
Display)

Sort by:
Ascending – Priority Level (cMT / cMT X Series)
Event with highest priority level is placed last in the list (the
bottom).
Descending – Priority Level (cMT / cMT X Series)
Event with highest priority level is placed first in the list (the top).
Ascending – Occurrence Count
Event with highest occurrence count is placed last in the list (the
bottom).
Descending – Occurrence Count
Event with highest occurrence count is placed first in the list (the
top).
Ascending - Time

EasyBuilder Pro V6.08.01

13-162

Objects

Display order

Latest event is placed last in the list (the bottom).
Descending - Time
Latest event is placed first in the list (the top).
Select the items to be displayed and use the up and down arrow
buttons to adjust the display order of the alarms.

Date

Displays the date tag with each alarm message. The four formats of
date tag:
MM/DD/YY、DD/MM/YY、DD/MM/YY、YY/MM/DD

Time

Displays the time tag with each alarm message. The four formats of
time tag:
HH:MM:SS、HH:MM、DD:HH:MM、HH

Title Tab

Title settings are available on cMT Series. With [Use headers] selected, the text color and
column headers can be configured.
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Security Tab
Alarm Bar

Setting
Interlock

Alarm Display

Description
When [Use interlock function] check box is selected,
whether the object is operable is determined by the
state of a designated Bit address. As shown in the above
settings, if LB-0 is ON, the object is operable.
Hide when disabled
When the designated Bit is OFF, the object will be
hidden.

User
restriction

Set the security class of the object to be operated by an
authorized user.
Object class
“None” means any user can operate this object. Only
account “admin” can operate “Administrator” object
class.
Make invisible while protected
When the user's privilege does not match the object
class, the object will be hidden.
When this check box is deselected in Alarm Display
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object settings, the unauthorized user can see the Alarm
Display object, but cannot trigger the object or make any
change.
This check box is greyed out in Alarm Bar object settings.

Font Tab
Set the font size or select [Italic].

The font, color, and content of the alarm messages displayed in Alarm Bar and Alarm Display
objects are set in Alarm (Event) Log object:

Click the icon to download the demo project. Please confirm your internet connection
before downloading the demo project.
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13.22. Event Display
Overview
Event Display object is used to display event messages which are defined in Event (Alarm) Log
and have met a trigger condition. The triggered events are displayed in the chronological order.
Event Display object displays: the date and time the event occurs, the time the event is
acknowledged, the time the event returns to normal, the event message, the occurrence count,
and the elapsed time. Multi-lined messages can also be displayed.

Configuration

Click [Data/History] »[ Event Display] icon on the toolbar to open an Event Display object
property dialog box. Set up the properties, press OK button, and a new Event Display object
will be created.
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General Tab
eMT, iE, XE, mTV Series

Setting

Description

Mode

The available modes are: [Real-time] and [History].
 Real-time
All the events triggered since HMI starts up are displayed.
 History
The system reads the event log in HMI memory and displays
them. The content can be updated by changing window. In case
when the trend display shows history data from today, the
display will refresh once per second.

Acknowledge

When in Real-time mode and an event is acknowledged by touching
an active display line, the [Acknowledge value] specified in Event
(Alarm) Log object, Message tab, is output to the [Acknowledge
address] of Event Display object. For more information, see “7 Event
Log”.

History
Control

When in History mode and if:
 [Enable reading multiple histories] is not selected
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The history files are sorted by date and each file is given an index.
The latest one is assigned index 0 (in most cases: today), the second
latest file is assigned index 1, and so on. The history control address
is used to specify the history file to be displayed.
If control address is LW-100, and four files exist with dates:
EL_20100720.evt, EL_20100723.evt, EL_20100727.evt, and
EL_20100803.evt.
The index value given to each file is shown below:
Value in LW-100
The corresponding file
0
EL_20100803.evt
1
EL_20100727.evt
2
EL_20100723.evt
3
EL_20100720.evt
 [Enable reading multiple histories] is selected
Displays a list of events triggered in multiple days. The display range
is formed by two consecutive addresses. Please note that the history
control address is defined differently in “Number of days” mode and
in “Index of the last history” mode.
Number of days
Suppose the history control address is set to LW-n, then:
[LW-n]: The start day index (which is expressed as the number of
days before today. 0: today, 1: yesterday, and so on.)
[LW-n+1]: The total number of days to display. The days are
calculated backward from the start day.
Example: If today were 2010/6/10, and LW-n = 1, LW-n+1 = 3, then
the data range will start from 1 day before today, which is 20100609
(yesterday), and include data for 3 days: 20100607~20100609.

Index of the last history
Suppose the history control address is set to LW-n, then:
[LW-n]: The index value of the file to start. 0: the latest file, 1: the
second latest file, and so on.
[LW-n+1]: The index value of the file to end. The specified value
must be greater than that of the start index.
Example: If LW-n = 1 and LW-n+1 = 3, then file No.1, No.2, No.3 will
be displayed.

The maximum size of data that can be displayed is 4MB. Data
exceeding the limit will not be displayed.
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The following shows how data will be displayed according to data
size.
5 history data, each is 0.5MB  Data displayed: 8 x 0.5MB
5 history data, each is 1MB  Data displayed: 4 x 1MB
5 history data, each is 1.5MB  Data displayed:
2 x 1.5MB+1 x 1MB (partial)

Event
management

Scrolling
control

Click the icon to download the demo project. Please confirm
your internet connection before downloading the demo project.
Enable event management
If this check box is selected, writing a specific value into register
LW-n and LW-n+1, where n is an arbitrary number, will control [Event
Display] object with different commands as shown below:
Address Value Command
LW-n
0
Display all events.
1
Hide [Confirmed] events.
2
Hide [Recovered] events.
3
Hide [Confirmed] or [Recovered] events.
4
Hide [Confirmed] and [Recovered] events.
LW-n+1 1
In real-time mode, delete a single selected
event.
If enabled, the value in the designated control address indicates the
number of lines to be scrolled down. The minimal value is 0, which
indicates the first line.
In the following figure, there are 10 events recorded in the object,
and value 3 is set at the control address. The upper event object
displays the events in time ascending order, and begins at the 4 th
event; on the other hand, the lower one displays the events in time
descending order, and begins at the 7th event.

If [Scrolling control address] is enabled, the scroll bar cannot be used
for scrolling, but still shows the relative position of the content. If the
control address holds a value that is larger than the total number of
lines, the display will stroll to the end. Please note that with this
address enabled, the horizontal and vertical scroll bars will not be
available on the object; please make sure that the width of the
object is enough for completely showing the content.
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Click the icon to watch the demonstration film. Please confirm your internet connection
before playing the film.
cMT, cMT X Series

Setting

Description

Mode

The available modes are: [Real-time] and [History].
 Real-time
All the events triggered since HMI starts up are displayed.
 History
All events are displayed.

Scrolling
control
address

If enabled, the value in the designated control address indicates the
number of lines to be scrolled down. The minimal value is 0, which
indicates the first line.

History
Control

When in History mode and if:
 [Enable reading multiple histories] is not selected
The history files are sorted by date and each file is given an index
which is expressed as the number of days before today. 0: today, 1:
yesterday, and so on. The history control address is used to specify
the history file to be displayed.
 [Enable reading multiple histories] is selected
Displays a list of events triggered in multiple days. The display range
is formed by two consecutive addresses. Please note that the history
control address is defined differently in “Number of days” mode and
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in “Specific days” mode.
Number of days
Suppose the history control address is set to LW-n, then:
[LW-n]: The start day index (which is expressed as the number of
days before today. 0: today, 1: yesterday, and so on.)
[LW-n+1]: The total number of days to display. The days are
calculated backward from the start day.
Specific days
Suppose the history control address is set to LW-n, then:
[LW-n]: The start day index. 0: today, 1: yesterday, and so on.
[LW-n+1]: The end day index. The specified value must be greater
than that of the start day index.
Example: When start = 4 and end = 7, the specified days will be 4
days before to 7 days before.
For cMT / cMT X Series, all the events that occurred are displayed and updated in real-time.
Press the Option Button

in the upper-right corner of the object and set the start and

end date. If the dates are not set specifically, all the events are displayed.
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Event Display Tab
cMT / cMT X Series

eMT, iE, XE, mTV Series

Setting

Description

Include
categories

Events in the selected category will be displayed. The categories are
set in Event (Alarm) Log object.
For example, if the category is set to 2 to 4 here, only events in
categories 2, 3, 4 will be displayed. For more information, see “7
Event Log”.
cMT / cMT X Series
Dynamic Category Range is an option available only for cMT Series
models. With this option selected, an address can be designated for
dynamically selecting categories to be displayed.
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Acknowledge
style

Select [Click] or [Double Click] to acknowledge each single event.
When an event occurs the user can tap the event line once or twice
to acknowledge the new event.
When acknowledged, the text color of the event will change to the
selected color, and the acknowledge value associated with that event
will be sent to the register designated in [Acknowledge address]. If
the address is set to LW-100, and the acknowledge value is set to 31,
when user acknowledges the event, value 31 is written to LW-100.
This can be used in conjunction with Indirect Window object so that
when an event is acknowledged, the corresponding message window
is displayed.

Max. event
no. (eMT, iE,
XE, mTV
Series)

The maximum number of events to be displayed in this Event Display
object. When the number of the displayed events equals to the set
maximum number, the new coming event will overwrite the latest
event.

Color

Different colors indicate different event states, such as acknowledged,
returns to normal, or selected. The system draws a highlight box
around the latest selected event.

History background (eMT, iE, XE, mTV)
When using Event Display object and select History mode, the
background color of the history record can be customized.
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Grid

Displays a grid of rows and columns in the object. The color of the
grid lines can be selected.
Auto fit short column (cMT / cMT X Series Default style)
The column width automatically adjusts to the size of the content.

Caption (cMT
/ cMT X
Series)
Option
button
visibility (cMT
/ cMT X
Series)

Available styles are: Default, Crystal, and Flat.
With [Use caption] enabled, the font size, color, and name of the
caption can be specified for Recipt View object.
Show or hide the option button

.

Predefined
Select [Enable] to show the option button.
Dynamic

Designate a bit address to control option button visibility.
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Sort Tab

Setting

Description

Order

Sort by:
Ascending – Priority Level (cMT / cMT X Series)
Event with highest priority level is placed last in the list (the
bottom).
Descending – Priority Level (cMT / cMT X Series)
Event with highest priority level is placed first in the list (the top).
Ascending – Occurrence Count
Event with highest occurrence count is placed last in the list (the
bottom).
Descending – Occurrence Count
Event with highest occurrence count is placed first in the list (the
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Display order
Date
Time

top).
Ascending - Time
Latest event is placed last in the list (the bottom).
Descending - Time
Latest event is placed first in the list (the top).
Select the items to be displayed and use the up and down arrow
buttons to adjust the display order of the events.
Displays the date tag with each event message. The four formats of
date tag: MM/DD/YY、DD/MM/YY、DD/MM/YY、YY/MM/DD
Displays the time tag with each event message. The four formats of
time tag: HH:MM:SS、HH:MM、DD:HH:MM、HH

Title Tab

Title settings are available on cMT / cMT X Series. With [Use headers] selected, the text color
and column headers can be configured.

EasyBuilder Pro V6.08.01

13-176

Objects

Security Tab

Setting
Interlock

Description

User
restriction

Set the security class of the object to be operated by an
authorized user.

When [Use interlock function] check box is selected,
whether the object is operable is determined by the
state of a designated Bit address. As shown in the above
settings, if LB-0 is ON, the object is operable.
Hide when disabled
When the designated Bit is OFF, the object will be
hidden.

Object class
“None” means any user can operate this object. Only
account “admin” can operate “Administrator” object
class.
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Make invisible while protected
When the user's privilege does not match the object
class, the object will be hidden.
When this check box is deselected, the unauthorized
user can see the Event Display object, but cannot trigger
the object or make any change.
Font Tab
In Real-time mode: Users may select Italic font and set the font size. The font is displayed
according to the setting in Event Log object.
In History mode: Users may select Italic font and set the font size, font and color, or tick the
[Font from label library] check box.

Empty Warning

When [Use empty warning] is enabled, the text displayed when no event has occurred can be
specified. This feature is not supported on cMT / cMT X Series models.
Click the icon to download the demo project. Please confirm your internet connection
before downloading the demo project.
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13.23. Data Transfer
Data Transfer (Per-page)
Overview
Data Transfer (Per-page) object can transfer values from the source address to the destination
address when the window in which this object is placed opens. The data transfer operation can
be activated by manually pressing the object or by detecting the change of state of the
designated bit.

Note


When Data Transfer (Per-page) object in Bit-Trigger mode is placed in the common
window, it activates data transfer operation once the specified condition is met,
regardless of the current base window.

Configuration

Click [Object] » [Data Transfer] » [Data Transfer (Per-page)] icon on the toolbar to open the
property dialog box. Set up the properties, press OK button, and a new Data Transfer (Per-page)
object will be created.
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General Tab

Setting

Description

Source
address

Data Transfer object reads the data from [Source Address].

Destination
address

Data Transfer object writes the data to [Destination Address].

Attribute

No. of word
Enter the number of words to be transferred. Unit: word.
Mode
Touch trigger
Press the object to activate data transfer operation.
External trigger
The data transfer operation is activated when the state of the
designated bit address changes.
There is a further selection to make of whether the data transfer
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operation is activated after OFF to ON, ON to OFF transition, or at
both of the changes of state.
Trigger
address
Notification

Specify a bit address for [External trigger] mode.
When enabled, the system will set the designated address ON or
OFF when it’s ready for data transfer.
Follow
The notification bit will reset to its original state once the system
starts data transfer.
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Data Transfer (Global): Time-based
Overview
Data Transfer (Global) object in Time-based mode can transfer data from the source address to
the destination address based on a time schedule.
Configuration

Click [Object] » [Data Transfer] » [Data Transfer (Global)] icon on the toolbar and open the
Time-based tab. Click [New] and set up the properties, press OK button, and a new Data
Transfer (Global) object will be created. Please note that the data should be imported /
exported separately in Time-based mode and Bit Trigger mode of Data Transfer (Global).
cMT / cMT X Series

eMT, iE, XE, mTV Series
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General Tab
Click the [New] button in the Data Transfer management dialog box.

Setting

Description

Attribute

Address mode
Select the data type to be transferred from [Bit] or [Word].
No. of bit /No. of word
When [Bit] is selected in [Address mode], set the number of bits
transferred each time when data transfer is triggered.
When [Word] is selected in [Address mode], set the number of
words transferred each time when data transfer is triggered.
Interval
Select the time interval of data transfer; for example, when 3
seconds is set, the system will transfer data every 3 seconds.
Specifying a shorter time interval or a greater amount of data to
transfer may decrease overall system performance; therefore, a
longer time interval or a smaller amount of data to transfer is
recommended.
When a short interval is inevitable, please at least set an interval
longer than the time needed for data transfer operation; for
example, when the data transfer operation takes 2 seconds, the
interval must be longer than 2 seconds.
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Activate only
when
designated
window
opened

Data Transfer object transfers data only when the designated
window is opened.

Source
address

Data Transfer object reads the data from [Source Address].

Destination
address
Notification

Data Transfer object writes the data to [Destination Address].
When enabled, the system will set the designated address ON or
OFF when it’s ready for data transfer.
Follow
The notification bit will reset to its original state once the system
starts transferring data.
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Data Transfer (Global): Bit Trigger
Overview
Data Transfer (Global) object in Bit Trigger mode transfers data from the source address to the
destination address when HMI detects that the state of the designated bit address changes.
This feature is not supported on eMT, iE, XE, mTV models.
Operation

Click [Object] » [Data Transfer] » [Data Transfer (Global)] icon on the toolbar and open the Bit
Trigger tab. Click [New] and set up the properties, press OK button, and a new Data Transfer
(Global) object will be created. Please note that the data should be imported / exported
separately in Time-based mode and Bit Trigger mode of Data Transfer (Global).
cMT / cMT X Series
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General Tab

Setting

Description

Source
address

Data Transfer object reads the data from [Source Address].

Destination
address

Data Transfer object writes the data to [Destination Address].

No. of word

Set the number of words transferred each time when data transfer
is triggered.

Trigger
address

Set the address that controls data transfer and select the trigger
mode.
Trigger mode
Trigger data transfer when the state of the designated register
changes from OFF to ON, ON to OFF, or at both of the changes of
state.

Notification

When enabled, the system will set the designated address ON or
OFF when it’s ready for data transfer.
Follow
The notification bit will reset to its original state once the system
starts data transfer.
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13.24. Backup
Overview
Backup (Trigger-based) object and Backup (Global) object can transmit recipe data (RW, RW_A),
event log, recipe database, sampling data, and operation log to an external device (SD card,
USB disk), in a specified time range or format. For example, when the event log is saved in a SD
card, a USB disk can be inserted when HMI power is still ON, and use Backup object to copy the
data into USB disk from SD card, and then remove USB disk without turning off HMI power. The
data saved in USB disk can be used on PC for analyzing. When the system is backing up, the
state of system register [LB-9039] is set ON. With [e-Mail] option, information can be sent to
configured email contacts.
Backup (Trigger-based) object is triggered by pressing the object on the screen while Backup
(Global) object runs in the background regardless of screens being viewed. Backup (Global)
object is available only on cMT / cMT X Series models.
Configuration

On the toolbar click [Object] » [File Operation] to find [Backup (Trigger-based)] and [Backup
(Global) objects.
Open [Backup (Trigger-based)] object property dialog box, set up the properties, press OK
button, and a new Backup (Trigger-based) object will be created.
When using a cMT / cMT X Series model, [Backup (Global)] object is available. Open [Backup
(Global)] object managing dialog box, click [New] to open the object property dialog box, set
up the properties, press OK button, and a new Backup (Global) object will be created.

EasyBuilder Pro V6.08.01

13-187

Objects

General Tab
Backup (Trigger-based)
cMT / cMT X Series

eMT, iE, XE, mTV Series

Backup (Global) cMT / cMT X Series

Setting

Description

Source

[RW], [RW_A], [Recipe database], [Historical event log],
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[Historical data sampling], [Operation log], [SQL Query]
Select one from the above for the source. When backing up
[Historical data sampling], use [Data Sampling object index] to
select the one to back up.
Options other than RW, RW_A will be available only when they are
used in the project file.
Event
category

This groupbox will be available only when backing up a historical
event log in CSV format. Two options can be found in this group

range

box: All and Partial. Selecting partial and entering “3, 5, 8” in the
field will backup events in categories 3, 5, and 8. Selecting partial
and entering “3-8” will backup events in categories 3 to 8.

Range

Historical data sampling
Select a number of files. For example, if [Start] is set to [Current],
and [Within] is set to [5 file(s)], the latest five files in memory will
be backed up.
Historical eventlog
Select a number of days. For example, if [Start] is set to [Yesterday],
and [Within] is set to [2 day(s)], the files obtained yesterday and
the day before yesterday will be backed up. Select [All] to save all
files, and the maximum is 90 days.

Trigger

Mode
There are three ways to activate Backup function.
Touch trigger
Touch the Backup object to activate backup operation.
External trigger (bit)
Register a bit device to trigger the backup operation.
Select whether the backup operation is activated after Off to ON,
ON to OFF transition, or at both of the changes of state.
Click the icon to download the demo project. Please confirm
your internet connection before downloading the demo project.
External trigger (word)
Users can specify the number of days to backup data using [Trigger
address]. [Trigger address] usage (suppose LW-n is used):
LW-n: Will start to back up when the value changes from 0 to 1.
LW-n+1: The start date of backup.
LW-n+2: The number of days for backup. (The maximum: 90 days).
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On cMT-SVR, Backup (Trigger-based) object only supports [Touch
trigger] mode but not [External trigger (bit)] and [External trigger
(word)] modes.
Click the icon to download the demo project. Please confirm
your internet connection before downloading the demo project.
Trigger
address

When the state of the designated register is set ON, the backup
operation is activated. When the backup operation is done, the
state of the designated register is set OFF.

Note


All history files should have been saved in memory, either HMI memory, USB disk or SD




card. Otherwise, the Backup object will not work.
The maximum number of days for backup is 90 days.
When saving files to USB disk or SD card, the capacity of a FAT32 folder depends on the
length of the file names. Fewer files can be saved when the file names are longer.
For cMT / cMT X Series, see “7 Event Log” and “8 Data Sampling” that explain the

mechanism of synchronizing data to external device.
Click the icon to download the demo project. Please confirm your internet connection
before downloading the demo project.
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Output Tab
cMT / cMT X Series

eMT, iE, XE, mTV Series

Setting

Description

Backup
position

Select the destination where the source files will be saved to.
SD card / USB disk
The external device connected to HMI.
Remote printer/backup server (eMT, iE, XE, mTV Series)
This option is available when [System Parameters] » [Printer/Backup
Server] » [Use Remote Printer/Backup Server] is selected.
Please note that [Operation log] backup can only be saved to Remote
printer/backup server. To save into a SD card or USB drive, use the
control address of Operation Log object.
For more information, see “26 EasyPrinter”.
E-mail
To send backup using e-mail, go to [System Parameters] » [e-Mail] tab
to configure first, and then open Backup object’s e-Mail tab to
configure the recipient address, subject, and message.
FTP (cMT, cMT X Series)
To save backup to an FTP server, go to [System Parameters] » [FTP]
tab to enable the FTP function first, and then open Backup object’s
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Output tab to set the FTP path and the way to handle duplicate
filenames.
Save format

Select the desired format to back up the file.
eMT, iE, XE, mTV Series:
 HMI Event Log File (.evt) / HMI Data Log File (.dtl)
 Comma Separated Values (.csv)
The [Event] column is included in the backup file to indicate the type
of the event.

0 = Event is triggered
1 = Event is acknowledged
2 = Event returns to normal
EasyConverter can be used to easily convert HMI Event Log File (.evt)
and HMI Data Log File (.dtl) to .xls or .csv format.
 SQLite Database File (.db)
cMT / cMT X Series:
 SQLite Database File (.db) (Only for backup to e-mail)
 Comma Separated Values (.csv)
Split by
No split

Backup all historical data to the same file.

Date

Files are separated according to the date of
historical data.
When [Customized file handling] is used in
Data Sampling, the backup files are
separated in the same way they are by the
rules of customized file handing.

Number of rows

Files are separated according to the number
of rows set.

Add BOM (Byte Order Mark) to file header for EXCEL can
interpreting non-ASCII strings correctly.
To back up history logs in .csv format, open the csv file in EXCEL. The
BOM (Byte Order Mark) can be added to the file header so that
the .csv file containing non-ASCII strings can directly be opened in
EXCEL. The title, export time, occurrence count, and elapsed time can
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be included or omitted in the backed-up .csv file.

Enable checksum for data integrity
This option is provided for using Backup object to generate a backup
file with checksum. EasyConverter can then be used to examine data
integrity.
Advance Tab (eMT, iE, XE, mTV)

Setting

Description

Serial number

If enabled, when backing up history files, a user-defined, 5-digit
serial number can be appended to the end of the file name of the
history data backup.
The serial number is determined by the value in the designated
source address. After backup, the value of this LW address will
automatically increment by 1.
The range of the serial number is 0~65535
For example, if the serial number is 123, the appended 5 digits will
be 00123.
A data sampling file -20140407.dtl will be backed up as
2014040700123.dtl.
An event log file -20140407.evt will be backed up as
2014040700123.evt.
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Options

Remove old files after backup
If selected, the old history files will be removed after backup.

Note


cMT / cMT X Series does not support Advance settings.

e-Mail Tab

Setting

Description

Add .txt
extension to
the filename
to skip the
anti-virus

If selected, when sending backup data as an email attachment, the
filename extension .txt will be added to the file name. This
prevents the mail server or anti-virus software from blocking
emails.

detection
Recipients,
Subject,
Message

Back up the email address of the recipients, the subject of the
email, and the message content.
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13.25. Media Player
Overview
Media Player object plays video files on HMI. It can, for example, be useful in providing better
instructions onsite to facilitate maintenance.
This object does not work remotely on cMT Viewer.
Configuration

Click [Object] » [Media Player] icon on the toolbar to open a Media Player object property
dialog box. Set up the properties, press OK button, and a new Media Player object will be
created.
General Tab
cMT / cMT X (excluding cMT-SVR)

eMT, XE

Setting

Description

Control mode

No control: Disable manual control by user. Video playback starts
as soon as the window opens.
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Resume
mode
Control
address

Ext. device

Use UI control: Use built-in user interface to control media
playback.
Use command control: Use control addresses to control media
playback.
Defines where to resume video playback when changing back to a
window with media player. Options include Resume previous
playback and Resume after restart.
 Selected
Designate a word register to control the object operations.
 Not selected
No manual control. Video will be played automatically when the
designated window opens.
Command (control address + 0)
Enter a value in the Command register to designate which action is
executed.
Parameter 1 (control address + 1)
Enter a value in Parameter 1 associated with each command action.
Parameter 2 (control address + 2)
Enter a value in Parameter 2 associated with each command action.
Status (control address + 3)
Indicates the status or errors.
File index (control address + 4)
The file number in the designated folder. It is recommended to file
the video name with a number.
Start time (control address + 5)
The start time of the video (second). 0, normally.
End time (control address + 6)
The end time of the video (second). (The time length of the video)
Update video playing time
If enabled, the elapsed playing time of video will be written into
[Playing time] register at a rate set by [Update period] in seconds.
Update period
Update period of [Playing time], range from 1 to 60 (second).
Playing time (control address + 7)
The elapsed playing time of video (Second). Normally between
start time and end time.
Play video files in SD card / USB disk.
Folder name
The folder name of video files stored in SD card or USB disk. Files
must be stored in root directory. Subdirectories won’t be accepted.
(For example, “example\ex” is an invalid directory.)
[Folder name] cannot be empty, must be alpha-numeric, and all in
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Attribute

ASCII character.
Auto. repeat
When finish playing all the video files, replay from the first file.
Ex: Video 1 > Video 2 > Video 1 > Video 2
Background
The background color of the object.

Note


The data format for control address is 16-bit Unsigned or 16-bit Signed. If using 32-bit
Unsigned or 32-bit Signed, only the previous 16 bits will be effective.

Control command
The following are the settings of different commands.
 Play index file
[Command] = 1
[Parameter 1] = file index
[Parameter 2] = ignore (set 0)

Note




Files are stored with file names in ascending order.
If the file cannot be found, [Status] bit 8 is set ON.
Please stop the playing video before switching to another.



Play previous file
[Command] = 2
[Parameter 1] = ignore (set 0)
[Parameter 2] = ignore (set 0)

Note



If [File index] is zero, the same file is replayed.
If the file cannot be found, [Status] bit 8 is set ON.



Play next file
[Command] = 3
[Parameter 1] = ignore (set 0)




[Parameter 2] = ignore (set 0)
If there are no more files, the index 0 file is played.
If the file cannot be found, [Status] bit 8 is set ON.



Pause / Play Switch
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[Command] = 4
[Parameter 1] = ignore (set 0)
[Parameter 2] = ignore (set 0)


Stop playing and close file
[Command] = 5
[Parameter 1] = ignore (set 0)
[Parameter 2] = ignore (set 0)



Start playing from the designated time
[Command] = 6
[Parameter 1] = target time (second)
[Parameter 2] = ignore (set 0)

Note


Parameter 1 (target time) must be less than the ending of time or it plays the last second.



Forward
[Command] = 7
[Parameter 1] = target time (second)
[Parameter 2] = ignore (set 0)

Note




Going forward to the designated second in [Parameter 1]. If the video is paused, the
forwarding action will be started by playing.
When the designed time is later than the end time, it plays the last second.
Backward
[Command] = 8
[Parameter 1] = target time (second)
[Parameter 2] = ignore (set 0)

Note




Going Backward to the designated second in [Parameter 1], if the video is paused, the
backward action will be started by playing.
When the designed time is earlier than the beginning time, it plays from beginning.
Adjust volume
[Command] = 9
[Parameter 1] = volume (0 ~ 128)
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[Parameter 2] = ignore (set 0)

Note



Default volume is 128.
Set video display size
[Command] = 10
[Parameter 1] = display size (0 ~ 16)
[Parameter 2] = ignore (set 0)

Note



[Parameter 1 = 0]：Fit video image to object size.
[Parameter 1 = 1 ~ 16]：Magnification from 25% ~ 400% in 25% increments where 1 = 25%,
2 = 50%, 3 = 75% and so on.

 Status (control address + 3)
When playing a video the system sets [File Open (bit00)] and [File Playing (bit01)] to ON. If the
file cannot be found, or an invalid command is entered, the Command Error bit 08 is set ON. If
the file format is not supported, or a disk I/O error occurs, during playback, the File Error bit 09
is set ON.

00: File Opened / Closed
01: File Playing
08: Command Error
09: File Error

(0 = closed, 1 = opened)
(0 = not playing, 1 = playing)
(0 = accepted, 1 = incorrect)
(0 = accepted, 1 = incorrect)

Note


The figure shows the status value associated with each state:
Stop = 0, Pause = 1, Playing = 3



[Command], [Parameter 1], and [Parameter 2] are write addresses. All others are read
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only.
Preview Tab
Users can test whether the video format is supported by using the preview function.

Setting

Description

Forward << /
Backward >>

Go forward or backward of the video. (in minutes)

Play / Pause

Select to start playing video or pausing.

Stop

Stop playing and close the video file. To test another video, please
stop playing the current video first.

Load

Select a video to preview.

Note







Only one video file can be played at one time.
If [control address] is not enabled and [Auto. repeat] is not selected, after finish playing
the first file, the system will stop playing and close the video file.
If [control address] is not enabled, the system will find the first file in the designated
folder and start to play (in ascending order of the file name).
If the file can be previewed, the format is supported. If the video image quality is poor,
please adjust the resolution.
The supported formats: mpeg4, xvid, flv…etc.
The recommended frame rate for videos is 30fps.
Click the icon to download the demo project. Please confirm your internet connection

before downloading the demo project.
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13.26. BACnet Schedule
Overview
BACnet Schedule helps visualize and access schedule data (Schedule) in BACnet IP controller
with a graphical UI. This feature is only applicable for cMT / cMT X Series HMI.

Configuration

Add BACnet/IP driver into the device list in System Parameter Settings and check whether a
Scudule is contained in the scanned BACnet/IP device or the imported tag file.
Click [Object] » [Time Related] »[BACnet Schedule] icon on the toolbar to open the BACnet
Schedule property dialog box. Configure the parameters and then click OK, a BACnet Schedule
object is created.
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General Tab

Setting

Description

Device

Select the BACnet/IP device to be read.

Address
Option
button
visibility (cMT
/ cMT X
Series)

Select the address tag of the Schedule to be read.
Show or hide the option button

.

Predefined
Select [Enable] to show the option button.
Dynamic

Designate a bit address to control option button visibility.

Example 1
After downloading the project to HMI, the HMI will automatically read the schedule settings in
the BACnet IP device as shown below.
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Click

and then select Value Editor to configure the Values table containing these

columns: Name, Value, Data Type, and Color, as shown below.

Click

to add a schedule setting. Click

to refresh schedule data by reading from the

BACnet device.
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As shown in the following screenshot, in a schedule settings window, the Weekday, start time
(From), end time (To), and Value should be configured. Value can be selected from the value
table. (Clicking

open Value Editor for editing the value table as well.)

After the time settings are completed, the values will be written to the corresponding schedule tags
in BACnet device.
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13.27. PLC Control
Overview
PLC Control object can execute commands when it is triggered.
Configuration

Click [Object] » [PLC Control] icon on the toolbar to open the PLC Control Object management
dialog box. To add a PLC Control object, click [New], set up the properties, press OK button and
a new PLC Control object will be created.

Click [New] and the following dialog box appears. See “13.27.2.1 Type of Control”.

Note



The [General PLC Control] option is not available for cMT / cMT X Series.
Triggering [Screen hardcopy] in cMT Viewer will result in files being saved into the USB
disk / SD card connected to the cMT / cMT X HMI. Likewise, the [Back light control] option
in cMT Viewer will control the backlight of the HMI itself.
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Selecting [Change window] or [General PLC Control] as [Type of control] will require more
than one trigger word (consecutive). Using a user-defined tag PLC will require declaring an
array datatype.
Type of Control



Change window

Setting

Description

Active only when
designated
window opened

Allow this operation only if a particular screen is displayed.

Turn on back light

The backlight is turned ON when the window is changed.

Clear data after
window changed

Reset the value at trigger address to zero when the window
object is changed. If [Use window no. offset] is selected, this
option will only show when a negative offset is used.

Use window no.
offset

Select the check box and select a window offset, the new
window no. to change to will be the value in [Trigger address]
plus the offset. For example, if [Trigger address] is LW-0 and
offset is set to -10. When the value in LW-0 is 25, the system
will change to window no. 15 (25-10=15). The range of the
offset is -1024 to 1024.

Note


If [LB-9017] is set ON, the write-back function will be disabled, the new window number is
not written back into a designated address.

Place a valid window number in the designated trigger address to change the base screen to
the new window number. The new window number is written back into the designated
EasyBuilder Pro V6.08.01

13-206

Objects

address.
For example, if current window is window no. 10, and [Trigger address] is set to LW-0,
When LW-0 is changed to 11, the system will change the current window to window no. 11,
and then write 11 to LW-1.
Click the icon to watch the demonstration film. Please confirm your internet connection
before playing the film.
When the window is changed, the new window number is written back into the address that is
calculated by [Trigger address] and the data format, as shown in following table.
Data Format

Trigger address

Write address

16-bit BCD

Address

Address + 1

32-bit BCD

Address

Address + 2

16-bit Unsigned

Address

Address + 1

16-bit Signed

Address

Address + 1

32-bit Unsigned

Address

Address + 2

32-bit Signed

Address

Address + 2

64-bit Unsigned

Address

Address + 4

64-bit Signed

Address

Address + 4

Click the icon to download the demo project. Please confirm your internet connection
before downloading the demo project.
 Write data to PLC (current base window)
Each time the base window is changed, the new window number will be written into the
[Trigger address]. If [Use window no. offset] is selected, the window number of the base
window plus the window number offset will be written into the [Trigger address].
 General PLC Control (eMT, iE, XE, mTV)
Transfer word data blocks from PLC to HMI, and vise-versa, and the transfer direction is
controlled by the value in the [Trigger address].
Value in
[Trigger address]

Action

1

Transfer data from PLC register  HMI RW register

2

Transfer data from PLC register  HMI LW register

3

Transfer data from HMI RW register  PLC register

4

Transfer data from HMI LW register  PLC register
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Four consecutive word registers are used as described in the following table:
Address

Purpose

Description

[Trigger
address]

Determine the
direction of data
transfer

The valid values are listed in the
above table. When a new control
code is written into the register,
HMI will start to transfer. After data
transfer is finished, the value will
be set to 0.

[Trigger
address] +1

The size of data
to transfer.

The unit is word.

[Trigger
address] +2

Offset to the
start address of
PLC register

Assume the value is “n”, where n is
an arbitrary number, the start
address of PLC register is [Trigger
address + 4 + n].
Take an OMRON PLC as an
example:
If [Trigger address] uses DM-100,
[Trigger address + 2] will be
DM-102. If the value in DM-102 is
5, the start address of data source
would be DM-109 (100 + 4 + 5 =
109).

[Trigger
address] +3

Offset to the
start address of
LW or RW

Take OMRON PLC as an example:
If set [Trigger address] to DM-100,
[Trigger address + 3] will be

memory in HMI

DM-103. If the value in DM-103 is
100, the start address of memory
in HMI is RW-100 or LW-100.

Example 1
To use PLC Control object to transfer 16 words data in OMRON PLC, starting from address
DM-100, to the HMI address, starting from RW-200. The setting is shown below:
1. Firstly, create a PLC Control object, set [Type of control] to [General PLC control], and set

2.

[Trigger address] to DM-10, that is, to use the four sequential registers start from DM-10
to control data transfer.
Confirm the data size and the offset addresses.
Set DM-11 to 16, since the number of words to transfer is 16 words.
Set DM-12 to 86, which indicates the address of data source is DM-100 (100=10+4+86).
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3.

Set DM-13 to 200, which indicates the destination address is RW-200.
Set DM-10 according to the direction of data transfer.
If set DM-10 to 1, the data will be transferred from PLC to HMI RW register,
If set DM-10 to 3, the data will be transferred from HMI RW register to PLC.

 Back light control (write back)
When [Trigger address] is turned ON, HMI backlight will be turned ON/OFF and [Trigger
address] will be turned OFF. Any touch on the screen will turn the backlight on.
 Back light control
When [Trigger address] is turned ON, HMI backlight will turn ON/OFF and the state of [Trigger
address] will not be changed.
 Sound control
When the state of the designated [Trigger address] changes, the HMI will play the sound
selected from the sound library. There is a further selection determines whether the sound is
played after Off to ON, ON to OFF transition, or at both of the changes of state.
 Execute macro program
Select a pre-defined Macro from the drop-down list. When the state of the designated [Trigger
address] changes, the selected Macro is executed. There is a further selection determines
whether the Macro is executed after Off to ON, ON to OFF transition, or at both of the changes
of state. If select [Always active when ON], the macro will be executed repeatedly. (The
shortest time interval between runs is 0.5 second.)
 Screen hardcopy
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When the state of the designated [Trigger address] changes, print the selected screen. If select
[SD card] or [USB disk] as [Printer], a “hardcopy” folder will be generated in the selected
external device for saving the printed screen in JPG format. The name of the JPG files starts
from yyyymmdd_0000.
To print the screen using a printer, go to System Parameter Settings » Model tab and set the
printer.
To print the screen using a remote printer, go to System Parameter Settings » Printer/Backup
Server tab and configure the parameters.
There are three options to specify the source window for hardcopy:
Current base window
Print the base window currently opened.
Window no. from register
Print the window designated by the value in a designated word address.
Designate window no.
Directly select a window to be printed.
Customized File Handling
This feature can be used to customize naming of the folders and the JPG files.
Setting

Description

Folder name

The folder name can be an alphanumeric name, and
certain half-width symbols are allowed:
!@#$%^&()_+{}`-=;',.
The folder name can also be specified by a naming syntax.
Dynamic format
The folder names can be set by a designated word
address, or by a naming syntax indicating the current
system time. The syntax can be specified by selecting
time buttons or entering the syntax in Format field. The
length limit is from 1 to 25.
Note: Up to 10 layers of folders can be created. The
exceeding layers will be ignored.

File name

The way to specify a file name is similar to specifying a
folder name.
Note: If the file name already exists, the system will add
“_0001” to the file name as a serial number. The numbers
of the later files add up until “_9999”. The files after
“_9999” will be ignored.
For example, if the three file names exist: “A.jpg”,
“A_0001.jpg”,“A_0003.jpg”. When trigger screen
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hardcopy with the same file name, the coming files will
be named in this order: “A_0002.jpg”, “A_0004.jpg”,
”A_0005.jpg”, and so on.
Crop window
With this option selected, taking a cropped screenshot is possible.

Note







A background printing procedure is performed when the printed window is not the
current base window.
If the hard-copied window is a background window, its [Direct Window] and [Indirect
Window] objects will not be printed.
When using a dynamic format name, the system will use a “_” sign as a substitute for
invalid symbols.
When using a dynamic format name, if screen hardcopy is triggered without specifying
the format first, the system will save the file in the default directory, which is:
hardcopy\yymmdd_0000.JPG
On cMT / cMT X models, a triggered bit address is reset to its original state automatically,
whereas on eMT/iP/iE/mTV models, the state of a triggered bit address is retained.
Click the icon to download the demo project. Please confirm your internet connection

before downloading the demo project.
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13.28. Scheduler
Overview
Scheduler object turns bits ON/OFF, or writes values to word registers at designated start times.
It works on a weekly basis.
Configuration

Click [Object] » [Time-related] » [Scheduler] icon on the toolbar to open the Scheduler
management dialog box, click [New] to open the Scheduler property setting dialog box.

The following two demonstrations explain the usage of Scheduler.

Example 1
A motor is scheduled to power - ON at 9:00 and power – OFF at 18:00, Monday to Friday.
We are using LB-100 to control the motor state. LB-100 will be set ON at 9:00 and OFF at 18:00.
1. Click the Scheduler icon on the toolbar to open the Scheduler management dialog box,
click [New].
2. In [General] tab, select [Bit ON] in [Action mode] and set [Action address] to LB-100.

3.

In [Time Set] tab, select [Constant].
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4.
5.
6.

Enter [Start] time as 9:00:00 and select Monday to Friday. Do not select [Setting on
individual day].
Enter [End] time as 18:00:00 and select [Enable termination action] check box.
Click [OK], a new Scheduler object will be created on the [Scheduler] list.

Example 2
A thermal heater is scheduled to heat up to 90°C at 08:00 and cool down to 30°C at 17:00,
Monday to Friday. LW-100 is used to store the set point value.
1.
2.
3.

Click the Scheduler icon on the toolbar to open the Scheduler management dialog box,
click [New].
In [General] tab, select [Word write] in [Action mode] and set [Action address] to LW-100.
Select [Constant] for [Word write value settings] and enter 90 in [Start value].

4.
5.

In [Time set] tab select [Constant].
Enter [Start] time as 8:00:00 and select Monday to Friday. Do not select [Setting on

6.
7.
8.

individual day].
Enter [End] time as 17:00:00 and select [Enable termination action] check box.
Return to [General] tab and enter 30 in [End value].
Click [OK], a new schedule object will be created on the [Scheduler] list.
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General Tab

Setting

Description

Power ON
start/end

Execute the defined action when the HMI is powered ON.
 Enabled

action

When HMI is powered ON within the scheduled time range, the
start action will be performed automatically. When HMI is powered
ON outside the scheduled time range, the termination action will
be executed.



Disabled

When the HMI is powered ON at a time later than the start time,
the start action will not be performed, but the termination action
will be performed. When the termination action is not defined, the
scheduled range is not recognized and no action is performed.
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Action mode

Choose the action to do at the given time.
Bit ON
At the start time, set the designated bit ON. At the end time, set
the designated bit OFF.
Example: Start time : 09:00:00 End time : 17:00:00

Bit OFF
At the start time, set the designated bit OFF. At the end time, set
the designated bit ON.
Example: Start time : 09:00:00 End time : 17:00:00

Word write
The [Write start value] entered here is transferred to the
designated [Action address] word register at the start time. At end
time, the [Write end value] entered here is written to the [Action
address]. The valued can be entered manually or be set by using
[Address] mode. In [Address] mode, the value in the specified
address is the start value where the value in [Address + 1] is the
end value.
Example: Device address: LW-100
Start time: 09:00:00 End time: 17:00:00
Write start value: 10 Write end value: 0
Use register: If control address is LW-n, then enter 10 in LW-n and
enter 0 in LW-(n+1).
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Note


Only is an [End time] is set in the [Time set] tab will the [Write end value] box appear.

Time Set
Specify start time and end time. [Constant] allows specifying a date or period and time.
[Address] allows controlling the time by the designated address.



Constant

Setting on individual day
If [Setting on individual day] is selected
The same start time and end time can be assigned to different days of the week.
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Note
 Start and end time must be entered.
 Start and end time must be on a different time, or same time but different day.
If [Setting on individual day] is not selected
Start time and end time entered must start and end within 24-hours.

Note



Start time and end time must be on a different time, different day.
If an end time is earlier than a start time, the end action will occur in the next day.

 Address
The scheduler object retrieves the start/end time and day of week information from word
registers, enabling all parameters to be set and changed under PLC or user control.
Designated as the top address in a block of 11 sequential registers which are used to store time
setting data.
The format of the 11 word registers should normally be 16-unsigned integer. If a 32-bit word
address is chosen, only bits 0-15 are effective, and bits 16-31 should be written as zero.
The following describes each register.
Control (Time setting address + 0)
When [Control] bit is ON, the HMI will read and update [Action mode], [Start time], and [End
time] values.
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Note


HMI will not regularly read the data from [Action mode] (address + 2) to [End time]
(address + 10). Please turn [Control] ON when the settings are changed.
Status (Time setting address + 1)
When the read operation is completed, Bit00 of this register turns ON. If time data read is out
of range or incorrect in any way Bit01 turns ON.

Note


After the scheduler reads the data and the status is turned ON (The value in [Address + 1]
= 01), the control bit must be turned OFF (address = 0). The status bit and error bit will be
turned OFF (10) at the same time.

EasyBuilder Pro V6.08.01

13-218

Objects

Action mode (Time setting address + 2)
Enable/disable [Enable termination action] and [Setting on individual day]. Whatever the
[Enable termination action] bit is, all the time data, from [Control] to [End time (second)], will
be read.

Note



If [Enable termination action] is OFF, all 11 registers are still read but end time is ignored.
If [Setting on individual day] is ON, make sure that all start end times are entered. If more
than one start / end day bit is ON, and error will occur.

Start/End Day (Start Day: Time setting address + 3, End Day: Time setting address + 7)
Designates which day of week is used to trigger the start or end action.

Start/End Time (Start Time: Time setting address + 4 to + 6, End Time: Time setting address +
8 to + 10)
Hour: 0 – 23 Minute: 0 – 59 Second: 0 - 59
Values outside these ranges will cause error.

Note


16-bit unsigned integer format must be used; BCD format is not supported here.



In [Address] mode, [Control] bit should be set after HMI reboots to update scheduler
time.
When using RW address, [Control] bit should be set after HMI reboots to update
scheduler time. Placing a Set Bit object with [Set ON when window opens] selected in the
common window is recommended, this can retain last settings after HMI reboots.
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End time depends on [Action mode] (address + 2). [Enable termination action] (Bit 00)
and [Setting individual day] (Bit 01) are related:

Prohibit tab

Before the scheduled action is performed, the HMI will read the specified bit state. If it is ON,
the scheduled start/end action will be skipped. Otherwise, it will be performed normally.

Note



The maximum number of Scheduler objects in a project is 64.
A time schedule applies one action only when the start time is reached.



[Write start/end value] and [Prohibit] bit is read only once before start action. After that,
even to change the state of [Prohibit] bit or [Write start/end value], the end action and
the value written will not be affected. Also, to read data of [Write start/end value] and
[Prohibit] bit, there is a delay of start action due to the communication.
Each time RTC data is changed, scheduler list entries that possess both start and end
times will be checked for in-range or out-range conditions. For in-range, the start action
will occur. If the end action is not set, the new range is not recognized, the action will not
occur.
If several Scheduler objects are set to the same start time or end time, the action is
performed in ascending order of the schedule number.
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In [Time Set] » [Address] mode, the system will read [Control] word regularly. The length
of the period depends on the system.
In [Time Set] » [Address] mode, when start time and end time is out- range, error occurs
in the set action time. (Note: BCD is not an acceptable format)
In [Time Set] » [Address] mode, the action will not start up until the first time the time
data is successfully updated.
Click the icon to download the demo project. Please confirm your internet connection

before downloading the demo project.
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13.29. Option List
Overview
Option List object displays a list of items that the user can view and select. Once the user
selects an item, the corresponding data will be written to a word register.
There are two forms of this object – [List box] and [Drop-down list]. The [List box] lists all items
and highlights the selected one. The [Drop-down list] normally displays only the selected item.
Once the object is pressed, the system will display a list (which is similar to list box) as shown in
the following figure.

Configuration

Click [Object] » [Option List] icon on the toolbar to open an Option List object property dialog
box. Set up the properties, press OK button, and a new Option List object will be created.
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Option List Tab
cMT / cMT X Series

eMT, iE, XE, mTV Series

Setting

Description

Attribute

Mode: The list style, either [List box] or [Drop-down list].
Style: This option is available only when the selected mode is
[Drop-down list]. Available styles are: [Standard] and [Classic]. The
appearance of the obejects will be shown in cMT / cMT X Style
when [Standard] is selected, and shown in iE/eMT/XE style when
[Classic] is selected. When the project is converted from iE/eMT/XE
to cMT / cMT X, the default style will be [Classic].
Item no.: Set the number of items for the object. Each item
represents a state displayed in the list and the corresponding value
will be written to the [Monitor address].
Background: Set background color.
Selection: Set background color for the selected item.
Row height: Set the row height for the drop-down list.
Font size: When [Same size as label] is selected, the font size set in
Label tab will be used for the drop-down list. When [Fixed size] is
selected, the system default font size will be used for the
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drop-down list.
Source of item data: There are 4 sources available: [Predefine],
[Dates of historical data], [Item address], and [User account]. See
13.29.2.1..
Monitor
address

The corresponding value of the selected item will be written to
[Monitor address].
Write when button is released
If this check box is selected, the selected item value will be written
to [Monitor address] after the button is released.

Send
notification
after writing
successfully

Set On/Off the designated bit address after successfully writing
data to PLC.

Note


The [write when button is released] option is not available on cMT / cMT X Series models.
Source of item data

 Predefine
The list is manually defined in [Mapping] tab.
The number of items can be adjusted by [Item no.], and each item represents one state. Each
item has a corresponding value which will be written to [Monitor address].
 Dates of historical data
cMT / cMT X Series

eMT, iE, XE, mTV Series

Option List object can be used with historical data display objects, such as Trend Display object,
History Data Display object and Event Display object to control which history file should be
shown. The figure below is an example of Option List used with Trend Display.
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Setting

Description

Type

Two options are available: [Event (Alarm) log] and [Data sampling].

Date

Set the date format. YYYY means a four digits year (EX: 2012), YY
means a two digits year (EX: 12), MM means month and DD means
day.

Data
Sampling
object

Select which Data Sampling object is displayed when [Type] is [Data
Sampling], and it should be the same as the [Data sampling object
index] configured in [Trend Display] or [History Data Display].

Enable
[delete
history data]
function

If selected, a control address can be set. Writing “1” to this address
will delete the history data of the specified date.

Note



In [Dates of historical data] mode, since the system automatically reads the historical data
and finds the date information, it is not necessary to configure in the [Mapping] tab.
The error message displayed in Option List can be modified in [Mapping] tab.

 Item address
The list will be read from the given [Item address] and controlled by [Control address]. The
following options will be available:
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Setting

Description

Control
address

[Address]: If the value at this address is changed to 1, the option
list would be replaced by items defined at [Item address]. After
updating, the value will be restored to 0.
[Address + 1]: Define the number of items in [Item address].

Item address

Assign the item address
UNICODE
The item will use UNICODE characters, such as Chinese characters.
The length of each item
Define the number of letters for each item, the unit is Word.

Note





The UNICODE characters used here should be used by Text object, so that EasyBuilder Pro
will compile the needed fonts and download these fonts to HMI, then the UNICODE
letters can be correctly displayed.
[The number of items] multiplied by [The Length of each item] must be less than 4096
words.
The system automatically disables [Mapping] tab in [Item address] mode.
Click the icon to download the demo project. Please confirm your internet connection

before downloading the demo project.
 User account
If [Enhanced Security] mode is enabled, [User account] would appear in the [Source of item
data] and it lists the names of users.
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Setting

Description

Sort

Select the sorting method from [Ascending] of [Descending].

Display

If [Privilege] is selected, the privileges for each user will be
displayed in option list.
If [Secret user] is selected, even though it is defined to be hidden in
[System parameter settings] » [Security] » [Enhanced Security], the
users will still be displayed in [Option List].

Note


The address that controls user index is [Control Address +2 (LW-n+2)] which is set in
[System Parameters] » [Security] » [Enhanced Security].

Mapping Tab
This table displays all available states/items, their item data and values. To change the number
of available items, please go to [Option list tab] » [Attribute] » [Item no.].
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Setting
Item
Value

Item data
Import item
data from
recipe record

Description
The system lists all available items. Each item represents a state
that will be displayed in the list. This field is read-only.
Here user can assign value for each item, basing on the following
two criteria:
For reading: If the value in [Monitor address] is changed, the object
selects the first-matched item. If no item is matched, the status
goes to error state and signals the notification bit register (if
requested).
For writing: The system writes this value to [Monitor address] when
user selects an item.
Text displayed for each item. The Option List object displays the
text of all items in the list for users to review and select.
This feature is enabled when select [Recipe-Selection] as [Monitor
address]. Click [Import item data from recipe record] to open the
[Records of Recipe Database] setting dialog box. Select [Item data
source], the data belonging to the selected column will all be
imported to Option List object.
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Before importing, the number of items in Option List changes
according to the number of items defined in Records of Recipe

Error state

Set default
Error
notification

Database.
After importing, modifying Records of Recipe Database will not
change the content of Option List.
On error state, the list box removes the highlight to represent no
item is selected and the drop-down list displays the data of error
state. Only the drop-down list uses error state, list box is not able to
use error state.
For example, item number 8 is the error state when specifying 8 in
[Item no.]. (The first item number is 0)
Reset all values or states to default. That is, set 0 for item 0, 1 for
item 1, and so on.
The system will set ON/OFF to the specified bit register when error
is detected. The signal of the bit register could be used to trigger a
procedure for correcting the error by using objects such as Event
Log, Alarm Bar, or pop-up window.

Click the icon to download the demo project. Please confirm your internet connection
before downloading the demo project.
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13.30. Timer
Overview
Timer object can be used to count the time in a specified mode. Timer object uses the
following 6 variables:
Timer Variable

Type

Input bit (IN)
Measurement bit (TI)

Bit
Bit

Description

The main switch of Timer.
Turns ON when the Timer begins
counting time.
Output bit (Q)
Bit
Activated when the Timer finishes
counting time.
Preset time (PT)
Word
Presets a time before the Timer
begins counting time.
Elapsed time (ET)
Word
Displays the elapsed time.
Reset bit (R)
Bit
Resets the elapsed time (ET) to 0.
Timer (Per-page): The Timer can be placed in a project window and be activated only in that
window.
Timer (Global): Regardless of which window is displayed on HMI, the Timer starts counting
time when the Input bit is in ON state.

Configuration

Click [Object] » [Time-related] » [Timer] icon on the toolbar to open the property dialog box as
shown in the following figure.
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Note



[Constant preset time] is only available for cMT / cMT X series.
In a cMT / cMT X project, after the [Timer (Global)] icon is clicked, a Timer management
window opens in which timers can be added by clicking [New].

EasyBuilder Pro V6.08.01

13-231

Objects



On delay
Mode

Register
Input bit (IN): The main switch of Timer.
Measurement bit (TI): Turns ON when the Timer
begins counting time.
Output bit (Q): Turns ON when the Timer finishes
counting time.
Preset time (PT): Presets a time before the Timer
begins counting time.
Elapsed time (ET): Displays the elapsed time.
Description

Period 1: When the IN turns ON, TI turns ON and the ET starts counting. The Q remains OFF.
Period 2: When the ET equals to the PT, the TI turns OFF and the Q turns ON.
Period 3: When the IN turns OFF, the Q turns OFF and the ET is reset to 0.
Period 4: When the IN turns ON, the TI turns ON and the ET starts counting. The Q remains
OFF.
Period 5: Turns IN OFF before the ET reaches the PT, the TI turns OFF, and the ET is reset to 0.
Since the ET doesn’t reach the PT, the Q remains OFF.


Off delay
Mode

Register
Input bit (IN): The main switch of Timer.
Measurement bit (TI): Turns ON when the Timer
begins counting time.
Output bit (Q): Turns OFF when the Timer finishes
counting time.
Preset time (PT): Presets a time before the Timer
begins counting time.
Elapsed time (ET): Displays the elapsed time.
Description

Period 1: When the IN turns ON, the TI remains OFF and the Q turns ON, the ET is reset to 0.
Period 2: When the IN turns OFF, the TI turns ON and the Q remains ON, the ET starts
counting.
Period 3: When the ET equals to the PT, the Q and TI turn OFF.
Period 4: When the IN turns ON, the TI remains OFF and the Q turns ON, the ET is reset to 0.
Period 5: When the IN turns OFF, the TI turns ON and the Q remains ON, the ET starts
counting.
Period 6: Turns the IN to ON before the ET reaches the PT, the TI turns OFF, the Q remains
ON, and the ET is reset to 0,.
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Pulse
Mode

Register
Input bit (IN): The main switch of Timer.
Measurement bit (TI): Turns ON when the Timer
begins counting time.
Output bit (Q): Turns ON when the Timer begins
counting time and turns OFF when the Timer
finishes counting time.
Preset time (PT): Presets a time before the Timer
begins counting time.
Elapsed time (ET): Displays the elapsed time.
Description

Period 1: When the IN turns ON, the TI and Q turn ON simultaneously, and the ET starts
counting.
Period 2: When the ET equals to PT, the TI and Q turn OFF simultaneously. Since IN is turned
OFF when counting time, the ET is reset to 0.
Period 3: When the IN turns ON, the TI and Q turn ON simultaneously, and the ET starts
counting.
Period 4: When the ET equals the PT, the TI and Q turn OFF simultaneously.
 Accumulated ON delay
Mode

Register
Input bit (IN): The main switch of Timer.
Measurement bit (TI): Turns ON when the Timer
begins counting time.
Output bit (Q): Turns ON when the Timer finishes
counting time.
Preset time (PT): Presets a time before the Timer
begins counting time.
Elapsed time (ET): Displays the elapsed time.
Reset bit (R): Resets ET to 0
Description

Period 1: When the IN turns ON, the TI turns ON and the elapsed time ET starts counting, the
Q remains OFF.
Period 2: When the IN turns OFF, if the ET doesn’t reach the PT, the TI turns OFF, and at the
same time the Q remains OFF. The ET is in the retentive state.
Period 3: When the IN turns ON, the TI turns ON. The timer measurement starts again and
the ET starts counting from the kept value. The Q remains OFF.
Period 4: When the ET reaches the PT, the TI turns OFF and the Q turns ON.
Period 5: When the IN turns OFF, the Q turns OFF. Turning ON the reset bit R will reset the ET
to 0, and then the reset bit turns OFF.
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Accumulated OFF delay
Mode

Register
Input bit (IN): The main switch of Timer.
Measurement bit (TI): Turns ON when the Timer
begins counting time.
Output bit (Q): Turns OFF when the Timer finishes
counting time.
Preset time (PT): Presets a time before the Timer
begins counting.
Elapsed time (ET): Displays the elapsed time.
Reset bit (R): Resets ET to 0
Description

Period 1: When the IN turns ON, the TI remains OFF and the Q turns ON.
Period 2: When the IN turns OFF, the TI turns ON and the Q remains ON. The ET starts
counting.
Period 3: When the IN turns ON, the TI and Q remain ON, and the ET is in the retentive state.
Period 4: When the IN turns OFF again, the ET starts counting from the kept value.
Period 5: When the ET equals to the PT, the TI and Q turn OFF simultaneously. Turning ON
the reset bit R will reset the ET to 0, and then the reset bit turns OFF.
Click the icon to download the demo project. Please confirm your internet connection
before downloading the demo project.
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13.31. Video In
Overview
HMI provides the video In feature that enables users to monitor sites with cameras. The
images/video can also be stored in external devices for further analysis. Sampling applications
include site monitoring, or vehicle/building surveillance…etc.
The following tables show the video input and image capturing behaviors for different models.
cMT-FHD
Model

iP

iE

eMT

mTV

XE

cMT-SVR

cMT-FHDX
cMT-HDM

Supported

Other
cMT/cMTX
IP Camera

N/A

N/A

Y

N/A

Y

N/A

Y

Y

USB Camera

N/A

N/A

Y

Y

Y

N/A

Y

Y

Video Input

N/A

N/A

N/A

N/A

N/A

N/A

N/A

device type

Model

eMT3121A
eMT3151A

Non-cMT Series – Image Capture

IP Camera

cMT / cMT X Series – Image Capture/
Video Recording
Image Capture: one image is captured
at the trigger moment.
Image
Capturing

One image is captured at the trigger moment.
USB Camera

Video Recording: video is recorded, for
a pre-determined duration, around the
trigger moment.

Video Input

Several images are captured around the trigger moment.

Configuration

Click the Video In icon on the toolbar to open the property dialog box. Set up the properties,
press OK button, and a new Video In object will be created.
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General Tab
eMT, iE, XE, mTV Series
Video Input

USB Camera

IP Camera
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cMT, cMT X Series
USB Camera

IP Camera

Setting

Description

Input channel

Select the Video Input channel from channel 1 or channel 2.
(Analog video systems)

Encode
format

Select the format from NTSC or PAL. (Analog video systems)

RTSP

Enter the IP camera’s RTSP address.
When account and password are required for accessing the IP
Camera, an RTSP address with credentials embedded can be used.
For example:
admin:admin@192.168.1.119:554/cam/realmonitor?channel=1&subtype=0

Streaming over TCP
Select this check box to stream video over TCP.
Capture
address

Select [Use capture function] check box and configure the settings.
A non-cMT model can capture images while a cMT / cMT X model
not only can capture images but also can record an avi video from n
seconds before to n seconds after the triggering time of the
designated address.
Capture address
Designate the address that triggers image capturing.
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Storage medium
Designate the storage device.
Information about storage type and input type:
Input Type

Storage Type

Analog Input SD card or USB disk.
USB Camera

SD card only. Exception: cMT3092X

IP Camera

SD card or USB disk.

Record time (cMT / cMT X Series)
The camera records the video from and to the specified recording
time (n seconds before and after the triggering time of the
designated address). The video is then saved to the specified
storage device. Please note that after the video is recorded, the
HMI may take a while to compress the video. The time needed for
compressing the video may differ between models depending on
CPU performance. A red dot appears in the object indicating that
recording or compressing is in progress. The HMI will not record
the next video during compression.
Record time (eMT Series)
Set a period of time to capture the images.
System

Method

Analog video
system





The longest period can be set from 10
seconds before triggering [Capture address]
to 10 seconds after triggering.
The time interval of image capturing is once

every second.
 The captured .jpg file will be named in the
following format:
Before or after [Capture address] is
triggered: YYYYMMDDhhmmss.jpg
The moment that [Capture address] is
triggered: YYYYMMDDhhmmss@.jpg
For example, set [Record time] “Before” and
“After” to “5” seconds. When the state of [Capture
address] changes from OFF to ON, the system will
start capturing one image per second, from 5
seconds before the triggering time to 5 seconds
after the triggering time, which is 11 images in
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total including the one captured at the triggering
moment.
USB
Camera

Only the image of the triggering moment is
captured. The name format:
YYYYMMDDhhmmss.png.

IP Camera

Only the image of the triggering moment is
captured. The naming format:
YYYYMMDDhhmmss.png.

Click the icon to download the demo project. Please confirm your
internet connection before downloading the demo project.
Control
address

If enabled, enter certain value to the control address and the
following addresses can control Video Input object. For example, if
the designated control address is LW-n (n is any address), enter
certain value to the designated addresses will execute commands
as the following table.
Analog Video Systems
Address

Value

Command

LW-n

0
1

Address

Value

Command

LW-n

0
1
1
string

Stop displaying image
Start displaying image
Pause / resume the video
RTSP address for IP camera (64

Stop displaying image
Open channel 1 and display the
image on HMI
2
Open channel 2 and display the
image on HMI
3
Open channel 1 but don’t display the
image on HMI (Capture function
operable)
4
Open channel 2 but don’t display the
image on HMI (Capture function
operable)
LW-n+1 1
Pause / resume the video
LW-n+2 1~100 Adjust the contrast ratio
(Analog video systems only)
LW-n+3 1~100 Adjust the brightness
(Analog video systems only)
USB Camera / IP Camera

LW-n+1
LW-n+2
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words)






After changing the value in [Control address (LW-n)], the
system will keep the new value.
After changing the value in [Control address + 1 (LW-n+1)],
the system will execute the command and then reset the
value to 0.
If [Use control function] check box is not selected, the system
will play the image of the selected channel.
If [Display adjustment] check box is selected, the contrast
ratio and brightness can be adjusted. (Analog video systems)

Note


Only one channel can be opened at a time, regardless of the type of camera used.

About analog video systems:
 Real-time images can still be captured when Video In is paused.
 Recommended analog video systems and resolutions:
1:1
50%
NTSC
720 x 480
360 x 240
PAL
720 x 576
360 x 288
Click the icon to download the demo project. Please confirm your internet connection
before downloading the demo project.
About cMT / cMT X Series Video Recording
 Compressing the recorded video may take a period of time depending on the video
length.
 When HMI is compressing a video, it will not record new video even if the designated
address is triggered.
About USB Camera:
 USB camera cannot be viewed on cMT Viewer.
 When the USB Camera is disconnected during video playing, video will not resume when
camera is connected again. If [Control address] is used in the project, please use the
control address to stop and restart video. If [Control address] is not used, switch to
another screen and then return, or restart HMI in order to resume the video.
 The maximum size of Video In object of eMT3070A is 340*240, as for eMT3105P,
eMT3120A, eMT3150A, XE, and mTV Series, the maximum size of Video in object is
640*480.
 When using a USB Camera, the display resolution of the run-time video is determined by
the resolution supported by the USB Camera that is closest to the size of the object. The
resolution supported by the USB Camera may not be identical to the size of the object.
Therefore, it is good practice to adjust the size of object according to the actual resolution
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of the video.
When using a USB Camera, the right and bottom edge of the Video In object will keep a
distance of 50 pixels away from the window edge to prevent the run-time video from
exceeding the window.
 When using a USB Camera, the background color of Video In object is black. If the
resolution of the run-time video is smaller than the object, the empty area is colored
black. Therefore, it is good practice to adjust the size of object according to the actual
resolution of the video. The tested and available USB Cameras are: Logitech C170,
Logitech C310, Logitech C910, LifeCam VX-2000.
Click the icon to watch the demonstration film. Please confirm your internet connection
before playing the film.
Click the icon to download the demo project. Please confirm your internet connection
before downloading the demo project.


About IP Camera:
 Viewing IP camera on cMT Viewer may be possible on a Windows PC, provided that
appropriate third-party codecs are used.
 As compatibility may vary, testing with an actual device is recommended.
 A RTSP address is required for using IP camera. The RTSP address can be found in the
configuration tool of the IP camera, or possibly from an online repository.
 When the IP Camera is disconnected during video streaming, video will not resume when
the camera is connected again. If [Control address] is used in the project, please use the
control address to stop and restart video. If [Control address] is not used, switch to
another screen and then return, or restart HMI in order to resume the video.
 When using an IP camera, the display resolution of the run-time video will be same as
that of the object drawn in the EasyBuilder Pro project. If the actual video resolution is
different from the size of the object, the resolution will be adjusted to fit the object,
which may cause distortion of video image. Therefore, it is good practice to adjust the size
of object according to the actual resolution of the video.
 Use the IP cameras that comply with ONVIF standard, and use RTSP for video streaming.
 To ensure the quality and smoothness of the video, and not to affect HMI’s general
performance, adjust the settings of IP camera when video lags or high CPU loading is
observed. As the project complexity and hardware specs vary from one case to another,
please fine-tune the video parameters accordingly.
 Recommended video specification:
Resolution
960x544 (max.)
Format
H.264, MJPEG
Refresh Rate
15 fps
Transmission Speed
800kbps (max.)
Click the icon to download the demo project. Please confirm your internet connection
before downloading the demo project.
Click the icon to watch the demonstration film. Please confirm your internet connection
before playing the film.
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13.32. System Message
Overview
If objects use [Display confirmation request] or [local HMI supports monitor function only] is
turned on/off, the corresponding messages configured here will be displayed in pop-up
message boxes.
Configuration

Click the System Message icon on the toolbar to open the setting dialog box.
System Message

Setting

Description

Dialog Size

Select the size for pop-up window and texts.

Confirmation
required

If an object uses [Display confirmation request], this message
would pop up when the object is used. [Message] shown on
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confirmation dialog box, and the text label of the 2 buttons, [OK]
and [Cancel], can be set. Please use the same font for the labels of
[Message], [OK] and [Cancel]. Additionally, only when selecting
[Label Library] for [Message], the use of Label Library for [OK] and
[Cancel] buttons can be enabled.
Deny
write-command

Displays when system tag LB-9196 (local HMI supports monitor
function only) is turned ON.

Allow

Displays when system tag LB-9196 (local HMI supports monitor

write-command

function only) is turned OFF.
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13.33. Recipe View
Overview
Recipe View object can be used to display a specific recipe. All items and values of the recipe
can be viewed by using this object.
Configuration

Click the Recipe View icon on the toolbar to open a Recipe View object property dialog box. Set
up the properties, press OK button, and a new Recipe View object will be created.
General Tab
cMT / cMT X Series

eMT, iE, XE, mTV Series
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The name of each part of the Recipe View object is shown in the following figure.

Setting

Description

Filter enabled

When selected, entering keywords in Recipe View to search for
specific text is possible.
When selected, editing Recipe Database directly in Recipe View is
possible.
When selected, the system will automatically refresh Recipe View
when recipe is changed; otherwise, Recipe View will be refreshed
after window change.
Recipe name
Choose the recipe name or look for other recipes from the
drop-down list.
Display
Choose an item to be displayed by selecting its checkbox.
Configure how the items are sorted. [Ascending] and [Descending]
can be selected.

Allow in-cell
editing
Refresh data
automatically
Recipe table

Default sort
method
Style
(cMT / cMT X

Available styles are: Default, Crystal, and Flat.

Series only)

Caption
(cMT / cMT X
Series only)

Title

Profile

Grid

With [Use caption] enabled, the text, font size, color, and name of
the caption can be specified. (Use caption is only available when
the selected style is Crystal or Flat.)
The item name assigned in [Data/History] » [Recipe Database].
Transparent
If selected, the title row has no shading; the color selection is not
available.
The frame and background color of the object can be set.
Transparent
Select to hide the background, the color selection is not available.
The dividing lines between columns and rows.
Enable
Select to show the grid.
Auto fit short column (cMT / cMT X Series Default style)
The column width automatically adjusts to the size of the content.
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Selection
Control

Shading color of the selected row.

Note


There are 4 system registers that can be used to view/update/add/delete recipe database:
Selection
Current selection of record in Recipe View object, and it is numbered from zero. If the first
record is chosen, the value of Selection will be 0. When the value of Selection is changed,
the corresponding values will be updated, such as “No”, “Timer_1”, “Timer_2”, as shown
in the following figure.

Count
Show the number of records in current recipe.
Command
Enter certain value will send command to the selected record.
Enter “1”: Add a new recipe record.
Enter “2”: Update the selected recipe record.
Enter “3”: Delete the selected recipe record.
Enter “4”: Delete all recipe records.
Enter “5”: Write the selected recipe record to PLC.
Enter “6”: Update the recipe record selected from PLC.
Result
View the result of executing commands.
Displays “1”: Command successfully executed.
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Displays “2”: The selected record does not exist.
Displays “4”: Unknown command.
Displays “8”: Records reach limit (10000 records), no new records can be added.
Display “16”: Another command is being executed.
Display “32”: Transfer command failed.
Please go to [Data/History] » [Recipe Database] tab to create the recipe data before
using Recipe View object. See “24 Recipe Editor”.
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Example 1
In this example, a recipe database is created to be displayed by Recipe View object. When you
select a recipe record on Recipe View object, the value of [Selection] and the corresponding
values will change accordingly. When finish designing, you can modify the recipe database by
entering a value in [Command].

1.

Create a recipe as shown in the following figure.
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2.

In Data tab create a number of records as shown in the following figure.

3.
4.
5.

Create a Recipe View object and use the recipe database created in the preceding steps.
Create 4 Numeric objects using registers “Selection”, “Count”, “Command”, and “Result”.
Create corresponding input objects for “No”, “Name”, “Timer_1”, …, “Timer_4”, “Speed”.
For example, “Name” is an ASCII item with size “10”. Create an ASCII object and set device
type to “RECIPE” » “Name”.

6.
7.

The project is then completed.
As shown above, “Mars” is selected and the corresponding items are also updated. There
are 5 records so the “Count” displays “5”. Try selecting different rows of the Recipe View
object. Fields “Name”, “Timer_1”, …will change accordingly.

8.


Try the following operations:
Add:
To add current data as a new record, enter “1” in “Command”.
Update:
To update recipe database, enter “2” in “Command”.
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Delete:
To delete the selected record, enter “3” in “Command”.
Sort the items.
Click the title to change the order.
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Example 2
In this example, [RECIPE_Bit] can be used to read / write individual bits of Recipe data.
Although BOOL type items cannot be added to Recipe Database, individual bit access of 16bit /
32bit data is possible.
As shown in the following figure, select [RECIPE_Bit] for the read address of Bit object and
point to the target item, and then the available Bit selections will be displayed. In this manner,
Recipe Database can be used to record, read, and write bit data.
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13.34. Flow Block
Overview
Flow Block object displays the flow status of the blocks in the pipe or the status of the
transportation lines. Unlike Moving Shape object which requires a precise measurement
between two points when drawing a straight line provided by users, the blocks flow at a fixed
interval in a horizontal or vertical straight line. For cMT / cMT X Series models, drawing
non-horizontal and non-vertical lines is possible.
The features of Flow Block:
 Each section of the Flow Block must be a horizontal or vertical straight line and the blocks
flow at a fixed interval within it. For cMT / cMT X Series models, drawing non-horizontal
and non-vertical lines is possible (angle limit: 5 degrees).
 Dynamic speed and direction adjustment (Speed and direction can be controlled by a
designated register.
 Security mechanism (Interlock), which hides Flow Block when the status of designated bit
is invalid.
Configuration

Click on the Flow Block icon on the toolbar or select [Objects] » [Animation] » [Flow Block] to
create object.
General Tab

Setting

Description

Reverse
direction

The blocks flow in the direction the object is drawn (the blue
arrow). If select this check box, the blocks flow in the opposite
direction.
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Dynamic
speed

Read address
The direction and speed at which the blocks flow can be controlled
by a designated register. The valid rage is -25 to 25. When a
negative value is entered, the blocks flow in a reversed direction.
Setting
Displays the address and format of the designated register. [System
register], [Index register], and [Tag Library] can be set here.

Flow speed

25 flow speed levels, the valid range is 0 to 25 when [Dynamic
speed] is not selected. A larger value indicates a faster speed.

Outline Tab
For setting the outline property of Flow Block. The following illustration shows each item.
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Setting

Description

Pipe

Sets the properties of the pipe within which the blocks flow. The
background color, border width and color can be set. When the
[Border] check box is selected, the background color must be set.

Block

Sets the properties of blocks. Style, width, length, interval and color
can be set.
Available styles are Rectangle and Arrow. The direction in which the
arrows point to indicates the direction of the flow block.

Dynamic
color

Rectangle:
Arrow:
Allows dynamic color change with 256 customized colors,
numbered from 0 to 255 allowed. The color is selected by entering
a value in the designated register. Entering a value greater than the
largest color number changes the Flow Block to the last color in the
list.

Note


If both [Reverse direction] and [Dynamic speed] check boxes are selected in [General] tab,
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when entering a negative value in the designated register of dynamic speed, the blocks
flow in the direction the object is drawn.
When both [Arrow] and [Dynamic speed] are selected, the arrow will only show when a
value is given to the designated address.
To avoid the pipe lines from overlapping when drawing a turn, there is a minimum width
planned at each turn. As shown in Fig. 34.1, the sign on the cross cursor defines the
minimum width. Fig. 34.2 demonstrates that each turn is drawn in the minimum width.

(Fig. 34.1)
(Fig. 34.2)
The valid range of the length, width, and height of the Flow Block can be adjusted
according to the size of the object drawn and the size of the window.
As shown in the following figure, when the size of the Flow Block is larger, the valid range
is restricted to prevent the flow block from exceeding the window size. When the size of
the object is smaller, the adjustment range will be larger.

To prevent the flow block from overlapping itself, when the distance between two lines is
shorter (Section A), the valid range is restricted. When the distance is longer (Section B),
the adjustment range will be larger.
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Example 1
The demonstration below shows how to use [Dynamic speed] to control the direction and
speed of Flow Block by a designated word register.
1. Create a Flow Block object and select [Dynamic speed] check box. Set [Address] to LW-0,
and set the format to 16-bit Signed.

2.

Create a Numeric object, set [Address] to LW-0. The high limit is 25, and the low limit is
-25. The format is 16-bit Signed.

3.

Execute simulation or download the project to HMI. When entering a positive value in
LW-0, the blocks flow in the direction the section is drawn. A larger value indicates a faster
speed. When a negative value is entered, the blocks flow in a reversed direction, and the
smaller value indicates a faster speed. When 0 is entered, it stops flowing.
Click the icon to download the demo project. Please confirm your internet connection.
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13.35. Operation Log
Operation Log Settings
Overview
Operation Log records user’s operation steps and displays the record in real-time. When an
error occurs, use operation log to analyze the problem. The backup tables can be used to
review the process in order to resolve the errors. Operation log, if configured properly, may
also be used to satisfy the requirement for audit trail and electronic signature.
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Configuration

Select the objects to be recorded. Click [Data/History] » [Operation Log Setting], and then
select [Enable operation log function] check box.
cMT, cMT X Series

eMT, iE, XE, mTV Series

Setting

Description

Object

With Operation Log function enabled, user login/logout activities
and the objects that can be recorded are listed in the setting dialog
box sorted by window numbers.
[Filter]: By clicking
icon, all recordable objects are listed. Users
can use the filter to more easily locate the desired objects.

Enable

The selected objects are recorded by Operation Log.

Label Library

Use the labels in Label Library to display the comments in different
languages.

Comment

The description of the object. The selected label will be shown in
this column, and if Label Library is not used, the comment in the
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object’s settings will be shown as below.

By clicking
are listed.

icon, all objects whose comments contain the string

Select all

Selects all the listed objects. If [Filter] is used, clicking [Select all]
only selects the objects in the list.

Discard all

Discards all the selected objects. If [Filter] is used, clicking [Discard
all] only discards the objects in the list.

Automatically
enable
operation log
for new
objects
Storage
settings

With this option selected, new objects created will automatically
be enabled for Operation Log.
Sets the way the records are stored.
Maximum record no. in HMI memory
Sets the maximum number of records that can be stored in HMI
memory.
External devices for synchronization / backup
Stores backup data to SD card or USB disk. Backup data can be
synchronized to database (cMT / cMT X Series).
Behavior when HMI space is insufficient
When HMI memory space is insufficient, two options are provided:
[Stop saving operation log]: Stops saving new records in order to
keep the earlier records.
[Synchronize to external device]: Stores the Operation Log to the
external device. When the device does not exist, the HMI clears the
oldest records in its memory.

Control
address

Entering different values in the control address sends
corresponding commands to Operation Log and returns the result
of executing the command.
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If control address is LW-n (where n is an arbitrary number), the
address that returns the result of executing the command is
LW-n+1.
Control address (LW-n):
(1): Clear all records.
(2): Copy the records to the USB disk.
(3): Copy the records to the SD card.
(4): Copy the records to the USB disk and clear the records in HMI
memory.
(5): Copy the records to the SD card and clear the records in HMI
memory.
(6): Enable Operation Log.
(7): Disable Operation Log.
(8): Use history data stored in USB disk after changing HMI.
(9): Use history data stored in SD card after changing HMI.
(10): Copy the records to the database server. (cMT / cMT X Series)
(11): Copy the records to the database server and clear the records
in HMI memory. (cMT / cMT X Series)
(12): Use existing historical data in database after changing to
another HMI. (cMT / cMT X Series)
Execution result (LW-n+1):
(0): Processing.
(1): Execution succeeded.
(2): The device does not exist.
(3): The record does not exist.
(4): Unknown error.

Note





Operation Log can only record the operation of the objects that are manually triggered.
Objects that cannot be manually triggered are not recorded, such as Time Based Data
Transfer object.
When running off-line or on-line simulation, Operation Log is stored under EasyBuilder
installation directory: HMI_memory\operationlog\operationlog.db
Triggering Macro with a Set Bit object generates two records, the triggering of bit and the
triggering of Macro.

EasyBuilder Pro V6.08.01

13-260

Objects

Operation Log View
Overview
Operation Log View can be used to review the Operation Log.
Configuration
Before using Operation Log View, please follow the steps described in the preceding
part to finish Operation Log Settings. Click [Data/History], and then click [Operation
Log View].
General Tab
cMT, cMT X Series

eMT, iE, XE, mTV Series
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Title

Selection
Control
Profile
Frame &
Background

Grid

Setting

Description

Style

The style of Operation Log View object can be selected
from Default, Crystal, and Flat.

Title/Profile/Grid/

These attributes can be configured when the chosen style

Selection control

is Default.

Font

Sets the color, font, and font size of the text displayed in
Operation Log View object.

Option button
visibility (cMT /
cMT X Series)

Show or hide the option button

.

Predefined
Select [Enable] to show the option button.
Dynamic

Designate a bit address to control option button visibility.
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Title Tab
cMT, cMT X Series

eMT, iE, XE, mTV Series

Setting

Description

Use Caption

Sets the caption displayed in Operation Log View object.

Title

Sets the title name of the columns displayed in Operation Log View
object.

Sort

Sorts the records in time ascending or descending order.

Display order

Sets the order of the displayed item. If [Display chars.] is 0, all
characters are displayed.

Date / Time

Sets the format of date and time displayed in Operation Log View
object.

Operation Log Printing
Overview
Operation Log Printing can generate an Operation Log sheet by printing out using a printer or
by saving as JPEG file into an external device. Before using this function, please go to Operation
Log Settings to finish the settings.
Operation Logs printed using cMT Viewer will be saved to the USB disk / SD card connected to
the cMT / cMT X HMI.
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Configuration

Select “Enable [Operation Log] printing” check box and click [Settings] button to open the
Operation Log Printing dialog box.

General Tab

Setting

Description

Printer

Select the device to save the Operation Log sheet. If a printer is
selected, the paper size should be A4. If an external device is
selected, the Operation Log sheet is saved as a JPEG file. The
system generates a folder named "operationlogsheet", and the files

EasyBuilder Pro V6.08.01

13-264

Objects

saved in the folder are named "print date_sequence number". For
example, the first JPEG file saved on 2013/05/08 is named
130508_0000 and so on.
Orientation

Sets the layout of the Operation Log sheet to be horizontal or
vertical.

Font

Sets the font and the font size to of the Operation Log sheet. The
following table lists the corresponding size.

Range

Size

Title

Content

Large

20 pt.

16 pt.

Middle

16 pt.

12 pt.

Small

12 pt.

8 pt.

Sets the range of the Operation Log to be included in the sheet.
Date
Sets the range by date, counted from the start day through the
number of days entered. The maximum available range is 30 days.
Record
Sets the range by the number of records. The maximum available
range is 10000 records.

Trigger
address

Sets the register to control Operation Log Printing. When the
register is set ON, it starts printing. When the printing is done, the
register is set OFF automatically.

Preview

Preview the result before generating the Operation Log sheet.
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Layout Tab

The layout of each part is shown in the above figure.
Setting

Description

Title

Sets the content of the title. The title is limited to one line.
Printed on all pages
If selected, the title is shown on each page; otherwise, the title is
shown on the first page.

Header

Sets the content of the header. The header can have 5 lines in
maximum.
Printed on all pages
If selected, the header is shown on each page; otherwise, the
header is shown on the first page.

Footer

Sets the content of the footer. The footer can have 5 lines in
maximum.
Printed on all pages
If selected, the footer is shown on each page; otherwise, the footer
is shown on the last page.

Date/Time

If selected, the date/time the in the sheet is shown on the
lower-right corner of each page; otherwise, the date/time is not
shown.

Page number

Shown on each page.
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Content Tab

Setting

Description

Title

Sets the title displayed.

Sort

Time ascending
The latest record is placed at the bottom.
Time descending
The latest record is placed at the top.

Date/Time

Sets the format of date and time displayed.

Demonstration

Example 1
The following demonstration explains how to create an Operation Log project.
1. Create a Toggle Switch object and a Numeric object on window number 10.
2. Go to Operation Log Settings; enable the Toggle Switch object and Numeric object on
window number 10.
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3.
4.

Create an Operation Log View object and finish relevant settings.
Run off-line simulation, trigger Toggle Switch and Numeric object. Operation Log is
displayed by Operation Log View object.

Click the icon to download the demo project. Please confirm your internet connection.

Example 2
Upload Operation Log to PC by using Utility Manager or use Backup object to send the file by
email.
 Upload by Utility Manager
1. Open Utility Manager, click [Upload].
2. Select [Operation log], enter file name and HMI IP, and then click [Upload].
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1.
2.

Send the sheet by e-mail
Open [System Parameter Settings] » [e-Mail] tab. Set e-mail server and the address of
recipient and sender.
Create a Backup object, under [Source] select [Operation log], and under [Backup
position] select [e-Mail].

For more information about e-Mail settings, see “5 System Parameter Settings”.
Click the icon to download the demo project. Please confirm your internet connection
before downloading the demo project.
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13.36. Combo Button
Overview
Combo Button can execute multiple commands. The former way was to overlay multiple
objects in the same position, and the commands are executed in the order of the layer of the
objects. This takes time to test the order when planning the project. Combo Button allows
users to easily set multiple commands with one object, and freely adjust the order of executing
commands.
The following are the features of Combo Button:
 Executes multiple commands.
 Allows adjusting the order of executing multiple commands.
 Displays the state in Bit or Word Lamp.
Configuration

Click on the Combo Button icon on the toolbar or select [Objects] » [Combo Button] to create
object. Configure object properties, click OK, a new Combo Button object will be created.
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eMT, iE, XE, mTV
General Tab

Setting

Description

Lamp

The mode to display the state of a designated bit or word register.
None: Not using lamps to show states.
Bit Lamp
Displays the state of a designated bit address.
[Invert Signal] Reverses the display of ON / OFF states. For example,
if [Invert signal] check box is selected, when the designated bit is
OFF, the object displays ON state.
Word Lamp
Displays the state according to the value of a designated word
register.
[No. of state]: The number of states used by the object. The state is
numbered from 0, so the number of states minus 1 will be the state
number. If the value in the word register is ≥ [No. of states] defined
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in Attribute, the highest state will be displayed.
If the number of states is set to 8, the valid states will be 0, 1, 2, …,
7. In this case if the word value is 8 or higher, the system will
display the state 7 shape.
[Change state by ranges]: Displays the state according to the range.
When two ranges overlap, the state is determined by the priority.
The priority is Default when the value is not within any range.

Actions

A combo button can execute up to 20 actions.
Key
Description
Add actions.
Delete the selected action.
Change the order of the actions.
Copy the selected action.
Paste the copied action.

Add

Delay
Delays the action for a few milliseconds. A combo button can set
one [Delay] action only.
Set Bit
Sets the designated bit ON or OFF.
Set style
Description
Set ON
Set ON the designated bit of the device.
Set OFF
Set OFF the designated bit of the device.
Toggle
Alternates the bit state each time pressed.
Set Word
Sets the value in the designated register.
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Set style
Write
Constant
Value
JOG+

JOG-

Dynamic
limits

Description
Writes a constant value to the designated
register.
Increases value in register by a set amount in
[Inc. value] each time when the button is
pressed, to the [Upper limit].
Decreases value in register by a set amount in
[Dec. value] each time when the button is
pressed, to the [Bottom limit].
Sets the Upper / Bottom limit by a designated
register.
When Dynamic Address is LW-n, where n is an
arbitrary number, set upper limit when using
[JOG+], and bottom limit when using [JOG-].

Change Window
Switch to the designated window.
cMT / cMT X Series
General Tab
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Bit/Word Lamp actions are explained in 13.36.2.1 eMT, iE, XE, mTV.
For cMT Series, actions can be classified into action groups, whichs are put in sequence.
Actions within a group are executed at the same time, and after the actions in the current
group have been all triggered, the actions in the next group will then be triggered. Please see
Ch13.53 Action Trigger for more information on the notes about action groups.
Setting

Description

Down actions

Execute action when the button is pressed.

Up actions

Execute action after the button is pressed and released.

Delay

Delay action for the specified time (ms).

Set Bit

Sets the designated bit address ON or OFF.
Set ON
Sets ON the designated bit.
Set OFF
Sets OFF the designated bit.
Toggle
Alternates the bit state.
Momentary
Momentary is a two-step action where pressing the button (Down
action) will set the bit ON and then releasing the button (Up action)
will set the bit OFF. Corresponding Down and Up actions will be
created.

Set Word

Changes the value in the designated word address.
Write constant value
Writes the constant value to the designated register.
Increment value (JOG+)
Increases value in register by a set amount in [Inc. value], up to the
[Upper limit].
Decrement Value (JOG-)
Decreases value in register by a set amount in [Dec. value], down to
the [Bottom limit].
Dynamic Limits (JOG+, JOG-)
Sets the [Upper limit](JOG+) and [Buttom limit](JOG-) by a
designated register.
Write constant string
Writes the constant string to the designated register.

Change
window

Switches to the designated window.
Change full-screen window: Changes to another base window.
Change common window: Changes common window.
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Return to previous window: Changes from current screen to the
previous one displayed. For example, when window no. 10 is
changed to window no. 20, this function can be used to return to
window no. 10. This function is only available for base window.
Animation Setting:
The effects are: Fade, Fly, Float, Wipe, Split, Circle, Clock, Zoom,
Turn, Push. Different effects may be used for Start (window
appears) and End (window disappears).
[Duration] specifies how many milliseconds (ms) a transition effect
takes to complete.
[Direction] The direction of the transition.
Execute
Macro

Executes one of the Macros from the drop down list that has
already been configured by users. In an action group, [Execute
Macro] is seen as completed as soon as it is triggered. Ever if a
particular macro takes longer to complete, the system will not wait
for the macro to complete running before moving on to the next
action group.

Popup
Window

Opens a designated window.

Close
Window

Closes currently opened window.

Keyboard
Input

Configures the button as a keypad key, and the character it enters,
via [Numeric] or [ASCII] objects.
Enter: Same as the keyboard’s “Enter” function.
Backspace: Same as the keyboard’s “Backspace” function.
Clear: Clear the value in the word register.
Esc: Same as the [Close window] function; it is used to close the
keyboard window.
Delete: Same as the keyboard’s “Delete” function, deletes the
number or character on the right side of the text cursor.
Left: Same as the keyboard’s “←” key moves the text cursor to the
left side of the previous number or character.
Right: Same as the keyboard’s “→” key moves the text cursor to the
left side of the next number or character.
Inc: Increment by 1.
Dec: Decrement by 1.
ASCII/UNICODE: Specify the character to be entered by this key.

Screen

Saves current screen as a hard copy file into a SD card or USB disk.
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Hardcopy
Acknowledge
all events
(Alarms)
Import Data

Acknowledges all events once.
Imports e-mail contacts or user accounts, or is used as USB Security
Key login.
Data Position:
[SD card] or [USB disk].
Account import mode:
If [Overwrite] is selected, the existing accounts will be overwritten
by new accounts. If [Append] is selected, accounts are appended.
Delete file after importing user accounts:
The system will delete the account data saved in the external
device after importing; this can prevent the account data from
leaking out.

Wait Until

The next group will be executed only when the condition set for a
designated bit or word address is met.

Data Transfer
(Global)
File Transfer

Sends the value in the designated address to another address.
Transfer files by FTP. HMI will connect to the FTP server in passive
mode.
General Tab:
Download: Transfer file from FTP server to local HMI.
Upload: Transfer file from local HMI to FTP server.
Server address:
[Direct]: Designate server address related settings in EBPro.
[Dynamic]: Designate an address for changing the server address
related settings dynamically on HMI.
Suppose the dynamic address is set to LW-n, then:
LW-n: Host usage (0: IP, 1 Domain name)
LW-n+1: IP (4 words)
LW-n+5: Port
LW-n+6: Authentication (0: None, 1: Account)
LW-n+7: Username (16 words)
LW-n+23: Password (16 words)
LW-n+39: Domain name (64 words)
Delete the source file after successful transfer
Following successful transfer, the source file will be deleted. When
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transferring in [Download (FTP -> HMI)] mode, please make sure
that the account has the write permission on the FTP server.
File Tab:
Set file position and full path of FTP server / Local HMI. When a
folder path is specified, all the files in that folder will be
transferred, not including files in subfolders. When a file with
identical file name already exists, it will be overwritten regardless.
Status Tab:
Designate an address for showing file transfer result and FTP server
response. Please use the following link for more information on FTP
server return codes.
https://en.wikipedia.org/wiki/List_of_FTP_server_return_codes

Note




One Combo Button can only do one of these window actions, and only once: [Change
Window], [Popup Window], and [Close Window].
At most 20 groups can be created in a Combo Button, and at most 20 actions can be
added into a group.
File Transfer Error Codes:
Error Code

Description

0

File transferred successfully.

1

The HMI directory for download does not exist.

3

USB disk or SD card is not found.

4

HMI or FTP directory is empty.

5

Uploaded file does not exist.

8

Operation rejected by FTP server.

9

USB disk or SD card is full.

10

Unknown error.

Click the icon to download the demo project. Please confirm your internet connection
before downloading the demo project.
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13.37. Circular Trend Display
Overview
Circular Trend Display object draws the trend curve of Data Sampling in a polar coordinate
system, where y-axis represents the radial coordinate and the x-axis represents the angular
coordinate. The way to use this object is similar to using Trend Display object.

Configuration

Click the Circular Trend Display icon on the toolbar to open the property dialog box. Set up the
properties, press OK button, and a new Circular Trend Display object will be created.
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General Tab
eMT, iE, XE, mTV

cMT, cMT X

Setting

Description

Data Sampling

Selects the data source for drawing the trend curve.

Type (eMT, iE, XE,

Selects the type of the trend from [Real-time] or [History].

mTV Series)

Real-time
In this mode, it displays a fixed number of sampling data
from the moment HMI starts to present. The number of
sampling data is determined by the [Max. data records
(real-time mode)] setting of Data Sampling object. If the
number of sampling data exceeds this number, the earlier
data will not be displayed. To display earlier data or the
data in other days, please select [History] mode.
[Hold control] address can be used to pause refreshing the
display. This only stops displaying new data in the Circular
Trend Display object, and the data is still being sampled by
Data Sampling object.
History
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In this mode, it displays the sampled data sorted by date.
Select the data source from [Data Sampling], and then use
[History control] address to view the records of different
dates.
Note
If [Show scroll control] check box in Trend Tab is not
selected, the earlier data cannot be viewed when
exceeding the specified [Distance].
For example: Set [Distance] to 1 (hour.), then sampling data
earlier than one hour is not displayed.
Refresh data
automatically

If enabled, the window in which the Circular Trend Display
object (in history mode) is placed will be refreshed once
per second.
 The scroll controls can be used to check the refresh
status.
If
button is displayed, the Circular Trend Display





will be automatically refreshed.
If
button is displayed, the Circular Trend Display
will stop being refreshed.
Scrolling backward and viewing earlier data will
disable [Refresh data automatically]. The button
displayed is
at this moment.
If [Refresh data automatically] is selected, the display
is refreshed when change back to this window,
regardless of the use of scroll controls.

Example: If [Refresh data automatically] is selected,
scrolling to the earlier display stops auto-refresh. At this
moment change to another window and then change back,
the Circular Trend Display is still refreshed.
If [Refresh data automatically] is not enabled when
building the project, to enable it directly on HMI, simply
press
. Please note that auto-refresh remains disabled
after window change.
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Distance

Defines the time length that the circle represents, the unit
is hour, the range is 1 to 24 (hours).

Start position

The position from where to start drawing the trend curve.
(Up)
(Right)

(Down)

(Left)

Dynamic X-axis
time range

If selected, a word register can be designated to control the
time length of Circular Trend Display. The unit is hour. If no
value is entered, the distance is set to default.

Zoom in / out

Enlarge or reduce the size of the object. The maximum size
is 10 times larger. If 0 is entered in the designated register,
the effect equals entering 1, the object remains the original
size.

Hold control

When the register is set ON, suspend the update of Circular
Trend Display. It does not stop the sampling process of
Data Sampling object. This setting is available only in
Real-time mode.

History control

History data is sorted by date. The system uses [History

(eMT, iE, XE, mTV
Series)

control] to select the history data that are created in
different dates and then displays it by Circular Trend
Display object.
If the value of the designated register in [History control] is
0, the Circular Trend Display object displays the latest
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record. If the value is 1, the second latest record is
displayed and so on. This setting is available only in History
mode.
If use with Option List object and select data source as
[Dates of historical data], the history data will be sorted by
date and displayed in Option List object, see “13.29 Option
List”.
In the following example, when history control address is
set to LW-n, and there are 4 sampling data: 20061120.dtl,
20061123.dtl, 0061127.dtl, 20061203.dtl. The
corresponding data selected by the value in history control
address is as the following list.

History control
(cMT, cMT X
Series)

Value in LW-n

The sampling data displayed

0

20061203.dtl

1

20061127.dtl

2

20061123.dtl

3

20061120.dtl

Same as eMT, iE, XE mTV Series.
Enable reading multiple histories:
In the following two modes, days are calculated backward.
Number of days
Suppose the address is set to LW-n, then:
[LW-n]: The start day index from which to calculate number
of days.
0: today, 1: yesterday, and so on.
[LW-n+2]: The total number of days before the start day.
Specific days
Suppose the address is set to LW-n, then:
[LW-n]: The start day index from which to calculate number
of days.
0: today, 1: yesterday, and so on.
[LW-n+2]: The end day index, the specified value must be
greater than that of the start day index. For example, if
start is 4 and end is 7, the specified days will be 4 days
before to 7 days before.

Watch line

Displays a watch line when user touches the Circular Trend
Display object, and the sampling data at the position of the
watch line is output to the designated register. To display
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sampling data with multiple channels, the system
consecutively writes the data of each channel to the
designated word register and the following registers. If the
data format of each channel is different, the channels are
sorted by the data format of its corresponding register.
In the following example, when watch address is set to
LW-n, and there are 4 sampling data, the format of each
data is: 16-bit Unsigned, 32-bit Unsigned, 32bit Signed, and
16-bit Signed. The corresponding watch address is as the
following list.

Time stamp output

Channel

Data Format

Data Length Watch Address

0

16-bit Unsigned

1 Word

LW-n

1

32-bit Unsigned

2 Words

LW-n+1

2

32-bit Signed

2 Words

LW-n+3

3

16-bit Signed

1 Word

LW-n+5

If selected, the system will start counting time from the
first data sampled, and output the elapsed time counted of
the latest data sampled to the register designated in [Time
stamp output + 2]. When pressing a point on the trend
curve, the relative time of the nearest data sample is then
output to [Time stamp output address].
Note
The format of the register designated in [Time stamp
output] and [Time stamp output + 2] must be 32-bit. [Time
stamp output + 2] is only available for Real-time mode
while [Time stamp output] is available for Real time mode
and History mode.

Display Tab

Display settings in this page are only supported on cMT / cMT X Series models.
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Setting
Option
button
visibility

Description
Show or hide the option button

.

Predefined
Select [Enable] to show the option button.
Dynamic

Designate a bit address to control option button visibility.
Display
option

Adapt to device screen pixel density (DPI)
With this option selected, text size, position, and the spacing
between Y axes will be adjusted according to the DPI of the screen of
the connected device.
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Trend Tab
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Setting

Description

Profile

Frame
Sets the color of the frame of the object.
Background
Sets the color of the background of the object.
Show scroll controls
The scroll controls are displayed for scrolling to view
the sampling data of other time range. The
minimum scrolling unit is determined by the setting
of [Distance] in General tab. If [Show scroll controls]
check box is not selected, the earlier data cannot be
viewed when exceeding the specified [Distance].
For example: Set [Distance] to 1 (hour.), then
sampling data earlier than one hour is not displayed.

Grid

Sets the number and the color of the dividing lines.
Y-axis
Sets the number of divisions on Y axis.
Font size
Sets the size of the font which labels the time scale
or channel scale.
Time scale
If enabled, displays the time scale. When the time
length is longer than 1 hour, the scale division is 1
hour. When the time length is set to 1 hour, the scale
division is 15 minutes.
Channel scale
If enabled, displays the channel scale. The color of
the font which labels the channel scale corresponds
to the setting of the trend curve of each channel.

Time / Date

Time
Sets the display format of time.
Date
Sets the display format of date.
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Channel Tab

Setting

Description

Channel

Sets the style and the color of the trend curve, and
the upper and lower limit of data that can be drawn
on the trend curve. Up to 8 channels are supported
simultaneously.
Not selecting [Dynamic limits]
The upper and lower limits of the data are set by
constants.
Selecting [Dynamic limits]
The upper and lower limits are set by the designated
register. When the address is LW-n, the
corresponding addresses are as the following list.
Data format

16-bit

32-bit

Lower limit

LW-n

LW-n
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Upper limit
Channel Visibility
Control

LW-n+1

LW-n+2

If [Enable] is selected, the bits of the designated
word register will be used to show/hide each
channel. First bit (Bit-0) controls the first channel;
second bit (Bit-1) controls the second channel, and
so on.
Display channel when the corresponding bit is:
If [ON] is selected, when the corresponding bit is
OFF, the channel is hidden. If [OFF] is selected, when
the corresponding bit is ON, the channel is hidden.
In the following example, the control address of
channel visibility is set to LW-0 and each channel
shows when the corresponding bit is OFF. If there
are 5 channels, the visibility of the channels is as the
following list.
Channel Control address Bit state Display
0

LW_bit-000

OFF

YES

1

LW_bit-001

ON

NO

2

LW_bit-002

ON

NO

3

LW_bit-003

OFF

YES

4

LW_bit-004

OFF

YES
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13.38. Picture View
Overview
Picture View object plays slideshow of picture files saved in an external device such as a USB
drive or SD card.
This object does not work remotely on cMT Viewer.
Configuration

Click the Picture View icon on the toolbar to open the property dialog box. Set up the
properties, press OK button, and a new Picture View object will be created.
General Tab
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Setting

Description

File position

Select the file source of the picture files from [SD card] or
[USB disk].

Directory

Specify the directory where the picture files are saved. The
directory can be the one used for Video Input’s capture
feature or Function Key’s screen hardcopy feature. The
picture file saved in the external device can be
immediately displayed.
Dynamic folder path
Designate folder path by a local address.

File selection

Automatically display the newly generated image
When a new image is generated in the designated folder
path, Picture View object will automatically display the
new image.
Send notification when switching to a new picture
When [Automatically display the newly generated image]
is selected, the state of the designated address changes to
On/Off when the new picture is displayed on HMI.
Specify file from address (hide toolbar)
When enabled, the displayed picture is designated by a file
name in a local address, and the toolbar will be hidden.

Note


The file name must be all in ASCII characters, and the Unicode characters are not
supported.




The supported picture formats are: .jpg, .bmp, .gif, .png.
The size of the picture that can be displayed on an iP/iE/eMT/XE/mTV model is calculated
in the following formula:
(image.width × image.height) < (screen.width × screen.height) × 4
Pictures with sizes exceeding this range cannot be displayed on HMI.
Two-finger zoom in / out gestures are supported on capacitive touchscreens.
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Outline Tab

Setting

Description

Outline

Specify the position, background color, and font of Picture
View object. (Supported only on iP/iE/eMT/XE/mTV
models.)
Hide delete button
When selected, the delete button for deleting the viewed
picture will be hidden in the Picture view object.
Display with original size when a picture size is smaller
than the object size.
When selected, the picture will be displayed in its original
size if it is smaller than the Picture View object. This can
avoid distortion caused by enlarging the picture.

Click the icon to download the demo project. Please confirm your internet connection
before downloading the demo project.
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13.39. File Browser
Overview
File Browser object can display filenames and their directories saved in the SD card or USB disk.
Apart from browsing for the files in the external devices, the filenames and the directories
selected in File Browser object can be written to the designated address.
This object does not work remotely on cMT Viewer.
Configuration

Click the File Browser icon on the toolbar, or select [Object] » [File Browser] to open a File
Brower object property dialog box and set up the properties.
General Tab
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Setting

Description

Folder path address

Current directory.

File name address

The file name of the currently selected file.

Full (folder + file
name) address

The full directory and file name of the currently
selected file.

Control address

Designate the control address used for deleting a
file or changing file name in File Browser.
Command: Control Address
0: None
1: Delete
2: Rename
3: Select (only supported on cMT / cMT X Series
models)
Result: Control Address+1
0: Success
1 or more: Error
New File Name: Control Address +2
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Outline Tab

Setting

Description

Folder position

Select the position of the file from SD card or USB
disk.

File type

File types to be displayed. Options include all files,
CSV files, or image files. For cMT / cMT X Series
models, there is also a PDF file option for use in
conjunction with PDF reader.

Font / Background
/ Color

Set the attributes and font of the object.

Note




The file name and the directory of the selected file will be written to the designated
address. To change file selection in File Browser to another file by changing the address,
please enter the position of the file and then use the select command (=3).
The system will read the folder path address and file name address when the HMI is
restarted or when an external device is inserted to the unit. If valid data is can be read
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from the designated address, the system will then automatically navigate to the
appropriate directory and highlight the file according to the data read. If [Folder path
address] is not enabled, the data at Full (folder + file name) address will be read.
Click the icon to watch the demonstration film. Please confirm your internet connection
before playing the film.
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13.40. Import/Export
Overview
With Import/Export object, Recipe Database or String Table can be imported or exported.

Configuration

Click the Import/Export icon on the toolbar to open the Import/Export Object management
dialog box. To add an Import/Export object, click [New], set up the properties, press OK button
and a new Import/Export object will be created.
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General Tab

Setting

Description

Type

Select the file source from Recipe Database or
String Table.

File position

Select the position of the file to be imported /
exported from SD card, USB disk, or Remote HMI
(cMT / cMT X Series). When Remote HMI is
selected, please note that only files in cMT / cMT X
Series models can be imported.

Recipe

Select the recipe. This option is hidden when select
String Table.

Control address

Designate the control address used for performing
import/export, or displaying the result.
Control: Control Address
Recipe Database:
0: None
1: Import
2: Export (no overwrite)
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3: Export
String Table:
0: None
1: Delete
2: Import
4: Export (no overwrite)
5: Export
Status: Control Address+1
0: Idle
1: Busy
Result: Control Address +2
1: Success
4: The file already exists, no overwriting.
Other: Error
File name address

The name of the imported/exported file. If [Include
folder path] is selected, the full directory and file
name will be included at this address.

Folder path address

The directory of the imported/exported file.

Remote HMI address

When the file position is [Remote HMI (cMT / cMT
X Series) ], please enter the remote HMI’s IP
address in this field.

Example 1
The following is an example on recipe export/import settings.
Field

Setting

File position

USB disk

Recipe

Recipe_A (or other recipe)

Control address

LW-100

File name address

LW-200

Folder path address

LW-250

1.
2.

Create two ASCII Input objects. Set address to LW-200 and LW-250 respectively.
Enter the file name in LW-200: 2015_recipe.csv.

3.
4.

Enter the folder path in LW-250: Setting.
Use a Set Word object to write value 3 to LW-100. Then, Recipe_A will be exported to the
USB disk, in the “Setting/2015_recipe.csv” file.
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Note


When performing “Export (no overwrite)” command, if the target file already exists, the
export operation will be canceled, and the result value will be set to “4”.
The following lists the result values and the information.
Result (HEX)

Information

0x1

Success.

0x4

File already existed and will not overwrite.

0x10

Invalid command.

0x100

Data contains non-numeric data.

0x101

Path contains invalid string “..”.

0x102

Communication error while updating Recipe DB.

0x103

Error while reading Recipe DB information from
project file.

0x200

General exception.

0x201

General status error.

0x202

Import to unknown database type.

0x203

Error while validating Recipe DB table definition.

0x204

Error while validating Recipe DB table data.

0x205

Error while writing Recipe DB table definition.

0x206

Error while writing Recipe DB table data.

0x300

File error: Unknown error.

0x301

File error: Empty file name.

0x302

File error: The external device does not exist.

0x303

File error: Invalid file name (directory or special
files), or a folder with the same name already exits.

0x304

File error: Unable to remove file.

0x305

File error: Open file stream error.

0x306

File error: Unhandled BOM.

0x307

File error: Error while parsing CSV file (incorrect
formats).

0x308

File error: Insufficient space on the external device.

0x309

File error: Unable to find the file.

0x30A

File error: The CSV file contains over 10000 data
rows.

0x400

Database general exception.
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0x401

Database error: Unable to open table.

0x402

Database error: Unable to get rows.

0x403

Number of columns in CSV file and in Recipe DB do
not match.

0x501

Unable to connect remote HMI.

0x503

Import from remote HMI database is prohibited.

0x504

Import from remote HMI database is not
supported.

Click the icon to watch the demonstration film. Please confirm your internet connection before
playing the film.
Click the icon to download the demo project. Please confirm your internet connection before
downloading the demo project.
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13.41. Pie Chart
Overview
The Pie Chart object draws a pie chart that is divided into slices to illustrate numerical
proportion, according to the value of the designated read address.
Configuration

Click the Pie Chart icon on the toolbar to open the property dialog box. Set up the properties,
press OK button, and a new Pie Chart object will be created.
General Tab

Setting

Description

Angle

Set the [Start degree] of the chart. Choose the Chart
to be [Clockwise] or [Counter clockwise].
If [Full circle] isn’t selected, then [End degree] must
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be set.

Hole

Set the size of the hollow circle in the center of Pie
Chart.

No. of channels

Set the number of channels to be displayed in the
chart. The range is from 2 to 16.

Border color

Set the color of the border.

Data display

The [Style] can be set as [None], [Value] and
[Percentage]. The [Font] and [Size] are for the text
on the chart. For Value Style, the [Right of decimal
Pt.] can set the value on the chart to be displayed
with the decimal point. The [Right of decimal Pt.]
option is only available for [Value] style.

Read Address

The address is for channel 1. The following
consecutive addresses are for the rest of the
channels. For example, if the Read Address is LW-0,
then the Read Address for channel 2 is LW-1;
channel 3 is LW-2…and so on.

Channel

Set the [Text color], [Background color], [Pattern
color], and [Pattern style] of the selected channel.
The [Background color] is for the [Pattern style] that
has background. If the [Pattern style] doesn’t have a
background, then the [Background color] doesn’t
need to be set.
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Combo Setting
cMT / cMT X Series HMI support combo setting for Pic Chart, which allows setting of multiple
related objects at a time. Pic chart can be set with Background and Legend.

Background
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Setting

Description

Margin

Specify the space between the background edge and
the objects.

Color/Style

Customize

Select a suitable background pattern and color.
Picture

Use the default picture or choose a picture from
Picture Library.
Legend
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Setting

Description

Title

Set whether to use a title for Pic Chart, and set the
font size / font color of the title. The title can be
selected from Label Library.

Channel

Set the channel label. When using Label Library, the
number of the channels should be the same as the
number of states in the library.

Click the icon to download the demo project. Please confirm your internet connection
before downloading the demo project.
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13.42. Barcode
2D Barcode Display
Overview
The 2D Barcode Display object transfers the information from the read address into QR Code or
Aztec Code.
Configuration

Click the 2D Barcode Display icon on the toolbar to open the property dialog box. Set up the
properties, press OK button, and a new 2D Barcode Display object will be created.
General Tab

Setting

Description

Mode

Supports QR code and Aztec code.
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Correction level

2D barcodes have error correction capability to restore data
if the barcode is dirty or damaged.
QR code
Four correction levels are available: L, M, Q, and H. The data
restoration rate is listed below. (The data restoration rate for
total codewords. Codeword is a unit that constructs the data
area.)
Correction Level
L
M
Q
H

Color
UNICODE

Reverse
high/low byte
Read address

7%
15%
25%
30%

Aztec code
Aztec code supports error correction levels from 5% to 95%.
Specifying a higher correction value results in a larger printed
symbol and increases accuracy.
Set the 2D barcode color.
By default, the 2D barcode is generated via ASCII encoding. If
this check box is selected, the 2D barcode is generated via
UNICODE encoding.
For characters that are not ASCII defined English alphabets or
numbers, for example, Chinese or Korean characters, please
select the Unicode check box.
By default, the 2D barcode is displayed in high byte then low
byte order. With this option selected, the 2D barcode is
displayed in a reverse order, low byte then high byte.
The 2D Barcode Display object will display the 2D barcode
generated from the information entered by the read address.
The word length limit of QR code: 1 ~ 1024.
The word length limit of Aztec code: 1 ~ 2048.

Push Notification Barcode Display
Overview
Push Notification Barcode Display object displays the QR code needed for setting up
EasyAccess 2.0 push notification via messaging applications.
Configuration

Click the [Object] » [Barcodes] » [Push Notification Barcode Display] to open the property
dialog box. Set up the properties, press OK button, and a new Push Notification Barcode
Display object will be created.

EasyBuilder Pro V6.08.01

13-307

Objects

General Tab

Setting

Description

Mode

Supports QR code and Aztec code.
2D barcodes have error correction capability to restore data
if the barcode is dirty or damaged.
QR code
Four correction levels are available: L, M, Q, and H. The data
restoration rate is listed below. (The data restoration rate for
total codewords. Codeword is a unit that constructs the data
area.)
Correction Level

Correction level

L
M
Q
H

7%
15%
25%
30%

Color

Aztec code
Aztec code supports error correction levels from 5% to 95%.
Specifying a higher correction value results in a larger printed
symbol and increases accuracy.
Set the 2D barcode color.

UNICODE

Cannot be changed by default.

Reverse
high/low byte

Cannot be changed by default.
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Read address

Cannot be changed by default.

System Parameter Settings

Setting
EasyAccess
Server

Description
Global: Supports push notification features of Wechat,
Facebook, and Line.
China: Supports push notification features of WeChat only.

Push Notification Settings
After downloading the project file to HMI, the QR code will be shown on HMI screen. For more
information on setting up push notifications in WeChat, Facebook, and LINE, please refer to the
link below (see version 2.8 and later).
https://support.ihmi.net/ea20/release-notes
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Barcode Scanner (Android Camera)
Overview
By connecting an Android device (smartphone/tablet) equipped with a camera to a cMT / cMT
X HMI using cMT Viewer installed on the Android device, the camera can be used to scan 1D or
2D barcodes.
Configuration

Click the Barcode Scanner icon on the toolbar or click [Objects] » [Barcodes] and then select
[Barcode Scanner]. Configure the parameters and click OK; a Barcode Scanner object will be
created.
General Tab

Setting

Description

Control address

Control address: Gives Command to Barcode
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Scanner.
0: None
1: Start and Clear
2: Stop
3: Clear
Control address + 1: Shows Execution Status.
0: None
1: Success
2 or more: Error Code
Control address + 2: Shows data length scanned.
Status address

Status address: Shows camera status is On / Off.
0: Off
1: On
Status address + 1: Shows whether scanning is
ready.
0: Stopped
1: Ready for scanning

Barcode address

The address that stores the data read, UNICODE is
allowed.

Read byte limit

If the data read exceeds this setting, the execution
status turns to 2 (error code).
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Security Tab

Setting

Description

Sound

If Enable is selected, when data is read, a sound is
emitted. The supported sound file format is .wav.

Note





Barcode Scanner is currently supported on cMT-SVR and cMT3151 models. Barcode
Scanner cannot be opened using simulation mode or cMT Viewer.
Supports: EAN/UPC, Code 128, Code 39, Interleaved 2 of 5 and QR Code.
On the device, if other applications are also using the camera, or the camera is locked,
cMT Viewer may not operate properly.
In the project, when multiple cMT Viewer devices are connected, since the same address
is shared between the devices, the devices will simultaneously scan if they are displaying
the same window with Barcode Scanner.
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Example 1
The following demo project shows how to scan QR code using a tablet.
1. At the beginning, the display is dark.

2.

Tap Start button, the status of Scanning turns ON, the display turns bright, and is ready for
scanning.

3.

When a QR code is read, the Execute Status turns 1, and the QR code is captured, its
content will be displayed in Barcode Address group box. Unicode is also supported.
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4.

If the size of the data read exceeds the maximum allowable size set in Read Byte Limit (10
bytes in this project), the Execution Status turns to 2 (error code). The exceeding part will
still be displayed in the ASCII objects in Barcode Address group box, since the data length
displayed depends on the ASCII object settings (20 words in this project).

5.

After changing to another page, Scanning turns OFF, the parameters are reserved. The
parameters will be cleared when next time Start button is tapped, or Clear button is
tapped.
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Click the icon to download the demo project. Please confirm your internet connection before
downloading the demo project.
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13.43. String Table
Overview
By pre-configuring the texts and their corresponding numbers in the String Table, the text can
be changed dynamically on HMI. String Table can also be used in a multi-language
environment.
Configuration

Click [Project] » [String] to open the property dialog box. Set up the properties, press OK
button, and a new String Table object will be created.

Setting

Description

Section

New

A list of all the existing String Tables.
[New Section] Add a new String Table.
[Delete Section] Delete the selected String Table.
Add a new string in the table.

Settings

Set the content of the selected string.

Export CSV File…

Export all the existing String Tables as a *.csv file.

Import CSV File…

Import *.csv file into the String Table.

Export EXCEL File…

Export all the existing String Tables as a *.xls file.

Import EXCEL File…

Import *.xls file into the String Table.

Note


The font of each language in the String Table must be specified in Label Text Library.
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Number of rows from all sections combined is limited to 10000.

Example 1
1.
2.

Create a String Table using the same settings as the preceding figure.
Create a Text object, select [Use string table] check box. In String ID group box, select
[Dynamic] and set read address to LW-0.

3.

Create a Numeric object, set address to LW-0.

4.

When the value in LW-0 is 0, the No. 0 string is displayed; when the value in LW-0 is 1, the
No. 1 string is displayed.
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13.44. Database
Database Server
Overview
Database Server object enables connection with MySQL or MS SQL database server, allowing
users to send data log or event log to the database, or use SQL Query to access data from the
database.
Configuration

Click the Database Server icon on the toolbar to create a Database Server object. Or, click
[Data/History] » [Database Server] in the menu.
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General Tab

Setting

Description

Server system

Supported server systems: MySQL, MS SQL Server

IP

Enter the IP address of the database.

Use domain name
Supports designating a server using a domain name.
Use server name

This option is only available when the selected server
system is MS SQL Server. An instance stands for a
communication port number, and the port number can
be used to identify multiple database servers on the
same computer.
A server name can be in one of the following formats.
 <Computer name>\<Instance name>
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Port
Username
Password
Database name
Customize timeout

<Computer name> (Connect to Default Instance :
MSSQLSERVER)
<IP address>\<Instance name>
<IP address> (Connect to Default Instance :
MSSQLSERVER)

Enter the port number of the database.
Enter the username for connecting the database.
The maximum is 32 words.
Enter the password for connecting the database.
The maximum is 32 words.
Enter the name of the database for collecting historical
data.
Timeouts for the following operations can be customized.
Connect timeout
The timeout for connection attempts. Connection
attempts will be terminated when the timeout is
reached.
Read timeout
The timeout for read operations.
Write timeout
The timeout for write operations.
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TLS/SSL Tab

Setting

Description

Enable

Enable TLS/SSL security. TLS version can be selected
from: TLS 1.0, TLS 1.1, and TLS 1.2.

Server verification

Enable
Verify whether the server certificate is signed by CA
(certificate authority) certificate. Server certificate is
sent from server during connection.
Server name must match certificate’s information
Verify whether the server’s domain name or IP
matches the records in the server certificate.
Domain name and IP records are stored in Subject
Alternative Name of the certificate.
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Status/Control Tab

Setting

Description

Status address

LW-n: Displays the connection status of Database
Server.
Value
Description
0
Not attempting to connect to
database.
1
Failed to connect to database.
2
Connection succeeded.
LW-n+1: Error indicator.
Value
Description
0
No error.
1
Unknown error.
2
Failed to connect to database.
3
Database blocks the
unauthorized connection.
4
Incorrect database name.
5
Invalid domain name.
6
Exceeded connection limit.
LW-n: Controls the operation of Database Server.
Value
Description
0
Ready
1
Start
2
Stop

Control address
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3
Update
LW-n+1: Sets the IP address of the database.
LW-n+5: Sets the port number of the database.
LW-n+6: Sets the username for connecting database.
LW-n+22: Sets the password for connecting database.
LW-n+38: Sets the name of the database for collecting
historical data.

Note








If sampled data is successfully synchronized to the SQL database, three tables will be
generated in the database, and the sampled data is saved in *_data table.
Table
Description
<HMI NAME>_<DATALOG NAME>_data
Saves data sampling
<HMI NAME>_<DATALOG NAME>_data_format
System folder
<HMI NAME>_<DATALOG NAME>_data_section
System folder
When synchronizing event log, the three tables generated in the database are listed as the
following table, and the event log is saved in *_event table.
Table
Description
<HMI NAME>_event
Saves event log
<HMI NAME>_event_log
System folder
<HMI NAME>_event_update_time
System folder
If the content of data sampling / event log, such as data format or event message, is
changed and downloaded to HMI, please delete the tables listed above first, and then the
new content will thus be effective.
Azure SQL Server is supported. To use Azure SQL Server, select MS SQL as server system
and use domain name. Azure SQL Server has firewall settings, please add the client into
whitelist, and see how to configure by opening the link below:
https://docs.microsoft.com/en-us/azure/azure-sql/database/single-database-manage#ma
nage-an-existing-server

Example 1
1.

Create a Database Server object, set Status Address to LW-0, and Control Address to
LW-10.
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2.

Create a Data Sampling object, in [Sync. to database] group box select [Enable], and set
Control Address to LW-80, to update or clear HMI historical data.

3.

If the database is successfully connected, the status indicator LW-0 displays 2 (connection
succeeded), and the error indicator LW-10 displays 0 (no error).
Write 2 in LW-80 (sync. data). Open SQL database, the data can be found in table <HMI
NAME>_<DATALOG NAME>_data.

4.
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Click the icon to watch the demonstration film. Please confirm your internet connection before
playing the film.
Click the icon to download the demo project. Please confirm your internet connection before
downloading the demo project.
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SQL Query
Overview
SQL Query can exchange data with SQL database. Before enabling SQL Query, please configure
Database Server.
Configuration

Click [Data/History] » [SQL Query] to open the settings dialog box. Configure the parameters
and click OK; a SQL Query will be created.
General Tab

Setting

Description

Advanced Mode

Without [Advanced Mode] selected:
Click [New] to add a new row or click [Import from
server] to import an existing database.
With [Advanced Mode] selected:
Manually enter syntax in Command tab to control
MySQL/MS SQL database. Please note that returning
from Advanced Mode to General Mode is not
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Description
Database

File path

Table name
Schema

possible.
User’s description about this query.
Select the source database to read from.
Local: The source database is the SQLite database
stored in a USB disk or SD card attached to HMI.
Click the icon to watch the demonstration film.
Please confirm your internet connection before
playing the film.
Remote: The source database is the designated
Database Server.
Use [Static] or [Dynamic] directory for a local
database. When [Static] is selected, please enter the
directory in this dialog box. When [Dynamic] is
selected, please designate an address as the data
source for the file path.
Enter the name of this query table.
The data read from database will be filled into the
corresponding address specified in the schema.
Please manually set Address Format after reading
data.

Note



A Primary Key should contain only numeric values.
In MySQL, Auto Increment must be enabled for Primary Key.
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Command Tab

Setting

Description

Control address

Designate five consecutive registers to execute SQL
commands and show results. Of the results, the
length of error message can be customized.
In standard mode (without checking Advanced mode
box), the four basic commands of SQL (Create, Read,
Update, and Delete) and their command ID are
shown.

Command

Click the icon to download the demo project. Please confirm your internet connection
before downloading the demo project.

Advanced Mode
In the Command table in Advanced Mode, [No. of arguments], [No. of outputs], and [Action]
columns can be found. Outputting multiple results to consecutive addresses at a time is
possible.
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Setting

Description

Control address

Specify the ID number used to give this command.

Row selection

Specify a row.

Status

Displays the execution status. See Ch13.44.2.4.

Error code

Displays the execution result. See Ch13.44.2.5.
Displays the error message sent from database
server. The default length of the error message is 64
words. Customizing the length of the error message
is also possible, and the upper limit is 200 words.
Displays the number of output results.

Error message

No. of results
New / Delete /
Settings / Copy

Add, delete, set, or copy a SQL Query command.
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Query Tab

Setting

Description

Command ID

Specify the ID number used to give this command.

Description

Enter the description of this command.
Enter the syntax for this command. An argument
should be enclosed in braces: ${argument no.}
With this checkbox selected, the result of executing
this command will not be shown in SQL Query Result
Viewer object. This checkbox can be selected for
commands that are done directly to the database
without the need for returning a result, such as
INSERT INTO, UPDATE, DELETE…etc.

SQL Query
Discard result
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Argument Tab

If argument is used in the syntax of a command in [Query] tab, the system will refer to the
address specified in this tab according to the argument number enclosed in ${argument no.}.
Output Tab
After reading database under Advanced Mode, the result will be stored in the addresses
specified in this tab. Selecting [Multiple results] option can output multiple query results to
consecutive addresses at a time.
[Multiple results] not selected
[Multiple results] selected

Setting

Description

Bulk address

Designate the start address for bulk output of
results. The upper limit of data records is 10000
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Maximum number
of results

Show the
addresses of the
Nth results

(maximum number of results x number of columns).
The upper limit is 1000 results. Suppose maximum
number of results is set to 100, and the returned
number of query results is 300, then:
When [Row selection] is set to 20, the 20th~119th
results are output to bulk addresses.
When [Row selection] is set to 260, the 260th~299th
results are output to bulk addresses.
Shows the output address of the Nth result in the
Address column of the table below this setting.
If the address of the output of the first result is
LW-200 and the number of words in a result is
OFFSET, the address of the output of the Nth result is
LW-200+OFFSET*N.

Click the icon to download the demo project. Please confirm your internet connection
before downloading the demo project.
Status
Value

Meaning

0

Normal

1

Query result exceeds 1000 records. Using LIMIT clause can
constrain the number of rows in one page.
Error Code

Error Code

Meaning

0

No mistakes

1

Unknown error

2

Invalid command

3

Database Server is not connected yet

4

Argument cannot be read

5

Cannot write and output

6

Incorrect number of arguments

7

Error in MySQL, please read error message

8

Unsupported datatype

9

Number of columns exceeds the limit

10

Number of rows exceeds the limit

11

Unable to read local database directory

12

Name of local database does not exist
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13

Internal error
Converting Datatype

Converting datatype as shown in the following table will take place after reading MySQL
database. If conversion cannot run properly, error code 5 will show. For example, when
converting MySQL’s INT into EasyBuilder Pro’s 16-bit Unsigned, if the value exceeds the limit of
16-bit Unsigned, error code 5 will show.
MySQL data format

EasyBuilder Pro datatype

TINYINT
SMALLINT
MEDIUMINT
INT
BIGINT
BIT

16/32-bit BCD
16/32-bit HEX
16/32-bit Binary
16/32-bit Signed
16/32-bit Unsigned

FLOAT
DOUBLE

32-bit Float

DECIMAL
DATETIME
CHAR, BINARY
VARCHAR, VARBINARY
TINYBLOB, TINYTEXT
BLOB, TEXT
MEDIUMBLOB, MEDIUMTEXT
LONGBLOB, LONGTEXT

String
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SQL Query Result Viewer
Overview
SQL Query Result Viewer shows the results obtained by running SQL Query.
Configuration

Click on [Data/History] » [SQL Query Result Viewer] to open the settings dialog box. Configure
the parameters and click OK; a SQL Query Result Viewer will be created.
General Tab

Setting

Description

Comment

User’s comment about this result viewer.

SQL Query

Select an existing SQL Query to show its result.

Style/ Style Color

Select a style and a color for this result viewer.
Set the font, font size, and font color for the texts
shown in this result viewer.

Text
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Caption
Table

Filter enabled

Set the font size and font color for the caption of this
result viewer.
This group box opens when selecting Default as
style. The attributes of the result query table can be
configured.
With this checkbox selected, entering keywords in
SQL Query Result Viewer to search for specific text is
possible.
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13.45. Dynamic Scale
Overview
Dynamic Scale offers customizable tick marks and scale labels and can be used together with
objects such as Trend Display, Bar Graph…, etc.
Configuration

Click the Dynamic Scale icon on the toolbar to open a Dynamic Scale object property dialog box.
Set up the properties, press OK button, and a new Dynamic Scale object will be created.
General Tab

Setting

Description

Style

Select the style from [Circular], [Horizontal], or [Vertical]. If select
[Circular], set the [Direction] and [Degree].
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Direction
Select from [Clockwise] or [Counterclockwise].
Degree
If [Full circle] is selected, set the start degree.
If [Full circle] is not selected, set the start and end degree.

Tick Mark

Select the color of the tick mark, and set the number of ticks for the
main and sub scale (major and minor tick mark).
For [Circular] style, the length of the major and minor tick mark, and
the radius of the circular tick mark can be set.

Scale Label

Displays major tick labels.
Circular

Set the font, font color, font size, and decimal point of the scale
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label.
Set the radius start from the center of the object to the position to
place the scale label.
Virtical / Horizontal

Set the font, font color, font size, and decimal point of the scale
label.
Set the position to display the scale label.
The Max. and Min. limits of the scale label can be specified. If
[Dynamic limits] is selected, the Max. and Min. limits can be set by
the designated word addresses.

Click the icon to download the demo project. Please confirm your internet connection
before downloading the demo project.
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13.46. Dynamic Drawing
Overview
Dynamic Drawing object enables drawing a shape in a specified region on HMI screen at run
time. The shape can be a line, a rectangle, a circle, or a dot. By setting the Attributes Addresses,
the style and the color of the shape can be customized.
Configuration

Click the Dynamic Drawing icon on the toolbar to open a Dynamic Drawing object property
dialog box. Set up the properties, press OK button, and a new Dynamic Drawing object will be
created.
General Tab

Setting

Description

Clear Address

Clears the drawing.
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Attributes Address

Changes the attributes in the drawing.

Entering different values in different Attributes Addresses brings different effects, as shown in
the following table.
Attributes
Address

Attributes
Address+0

Default

0

Line

Attributes
Address+1

Attributes
Address+2

Ones

Tens

0: Non-arrow

0: Small

0: Solid line

1: Single-ended arrow (Hollow)

1: Large

1: Dashed line

2: Double-ended arrow (Hollow)

2: Dotted line

3: Single-ended arrow (Solid)

3: Dash Dot line

4: Double-ended arrow (Solid)

4: Dash Dot Dot line

1

Attributes
Address+3

Attributes
Address+4

Customizable

Customizable

Line color

5 and up: Solid line
with thicknesses greater
than 2
0: Hollow
Rectangle

Circle

Drawn in Line mode

Interior pattern

2

Rectangle color
1: Solid

Drawn in Pattern mode

0: Hollow

Drawn in Line mode

Interior pattern

3

Circle color
1: Solid

Dot

4

Ellipse

5

Dot color
Drawn in Line mode

Interior pattern
Ellipse color

Ellipse from

1: Solid

Drawn in Pattern mode

0: Hollow

Drawn in Line mode
Ellipse color

Rectangle

1: Solid

Pie

8

color

Drawn in Pattern mode
Drawn in Line mode

0: Hollow

Arc color

Drawn in Line mode

Interior pattern
Pie color

1: Solid
Move Origin

color
Interior pattern

6

7

color

Drawn in Pattern mode

0: Hollow

Arc

color

color

Drawn in Pattern mode

21

Attributes
Address

Attributes
Address+0

Attributes
Address+5

Attributes
Address+6

Attributes
Address+7

Attributes
Address+8

Default

0

Line

1

Start point X

Start point Y

End point X

End point Y

Rectangle

2

Left-top point X

Left-top point Y

Attributes
Address+9

Right-bottom point Right-bottom point
X
Circle

3

Center point X

Center point Y

Dot

4

Dot X

Dot Y

Ellipse

5

Center point X

Center point Y

Y

Radius

Radius on the X

Radius on the Y
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axis

axis

Ellipse from
6

Left-top point X

Left-top point Y

Width

Height

Arc

7

Center point X

Center point Y

Radius

Start degree

End degree

Pie

8

Center point X

Center point Y

Radius

Start degree

End degree

Move Origin

21

New origin X

New origin Y

Rectangle

The values in [Attributes Address+2] represent different Line or Pattern styles, as shown in the
following table.
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Color Tab

Setting

Description

New

Adds a color to be used in the drawing.

Delete

Deletes the selected color.
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Example 1
The following demo project demonstrates how to dynamically draw an arrow or a circle on HMI
screen. To build the project, follow these steps:
1. Create a Dynamic Drawing object, set Clear Address to LB-0, and Attributes Address to
LW-0.
2. Create a Toggle Switch object, set address to LB-0, and select Toggle as switch style, for
clearing the drawing.
3. Create 10 Numeric objects, set addresses to LW-0~LW-9, for specifying the attributes in the
drawing.
4. Run simulation or download the project to HMI to see the result. By entering 1 in LW-0, a
line is drawn, and entering different values in LW-1~9 can change the style, the color, and
the position of the line.

5. Press Clear Pattern button, and enter 3 in LW-0, a circle is drawn, and entering different
values in LW-1~9 can change the style, the color, and the position of the circle.
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Note









Before using Attributes Address, please define [Attributes Address + 1] ~ [Attributes
Address + 9]. The system will reset the Attributes Address, after it is used.
If the drawing is not cleared, the new drawing will overlap the previous one, and the
maximum acceptable number of drawings in a Dynamic Drawing object is 1000.
The maximum number of line styles is 19, which means the maximum thickness of a solid
line is 16. The style numbers that exceed 19 will be displayed as 19.
Find the color number in Color tab.
The range of the start and end degree for Arc and Pie is 0 to 360 degrees.
Origin position is relative to left-top corner (0,0). Giving “move origin” command will
make (x1, y1) the new origin, and x1, y1 will keep on accumulating until being reset to (0,0)
by clearing the drawing.
If cMT Viewer is used to monitor a Dynamic Drawing object on a cMT / cMT X model, then
PLW address is recommended to be used as the Attribute Address, so that drawing
commands can be given to the cMT Viewer device’s PLW addresses. This prevents the
issue where the HMI and the cMT Viewer device show different drawing results.
Click the icon to download the demo project. Please confirm your internet connection

before downloading the demo project.
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13.47. PDF Reader
Overview
PDF Reader object enables viewing of PDF documents on HMI.
Configuration

Click the PDF Reader icon on the toolbar to create a PDF Reader object. Or, click [Object] »
[Media] » [PDF Reader] in the menu.
General Tab

Setting

Description

File position

Select the position where the PDF file is stored.

Path

The directory of the PDF file stored in the external
device.

Page Control

Current page
The page number of the current page. Set a value to
change the current page.
Total pages
Total number of pages of the PDF file.
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Zoom ratio

Current zoom ratio. Set a value to change the zoom
ratio. Unit: %; i.e., the number 100 indicates 100%
display (1:1).

Note



PDF Reader cannot be opened using simulation mode or cMT Viewer.
The PDF files protected by passwords or restrictions cannot be read using PDF Reader.




CPU loading may rise when multiple PDF Reader objects are opened simultaneously.
When entering a page number in the Page Control register under multi-page view mode,
the specified page will be opened in single-page view.
Two-finger zoom in / out gestures are supported on capacitive touchscreens.



Click the icon to download the demo project. Please confirm your internet connection
before downloading the demo project.
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13.48. Table
Overview
Table object allows users to draw a table in the project window and customize the border, grid,
and pattern of the table.
Configuration

Click the Table icon on the toolbar to create a Table object. Or, click [Object] » [Table] in the
menu.
General Tab
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Setting

Description

Preview Window

Displays the settings result.

Vertical

Sets the number of columns in the table. Range:
1~255

Horizontal

Sets the number of rows in the table. Range: 1~255

Spacing

The available options are [Equal] and [Free]. When
[Free] is selected, the user can manually adjust the
column width or row height in the editing window.

Border

Sets the type, width, and color of the border. [Line
width] setting is available only when Solid line type
is selected. The range of width is 0~8. The line will
become invisible when the width is set to 0.

Grid

Sets the type, width, and color of the grid. [Line
width] setting is available only when Solid line type
is selected. The range of width is 0~8. The line will
become invisible when the width is set to 0.

Fill

Sets the pattern style and color.

Alignment

By dragging the objects into the cells in the Table,
the objects can align to the preset position. Different
alignments can be set for each cell in the Table, by
default the objects are center-aligned, and nine
different alignments can be selected as shown in the
screenshot of the settings window.
With Alignment enabled, the maximum number of
vertical / horizontal divisions is 32.
Please note that this setting does not support the
alignment of multiple groups of objects.
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13.49. VNC Viewer
Overview
VNC Viewer can run on HMI to control a PC or a device remotely. VNC server must be installed
on the remote device to be connected. On HMI the user can monitor and control the remote
device.
Configuration

Click on the VNC Viewer icon on the toolbar or select [Objects] » [VNC Viewer] to open the
settings dialog box. Configure the parameters and click OK; a VNC Viewer object will be
created.
General Tab

Setting

Description

IP

Enter the IP address of the remote device to be
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connected.
Port

Enter the port number of the remote device to be
connected.

Default Password

Enter the VNC password to log in the VNC server of
the remote device. If Default Password is enabled,
when connecting the remote device, VNC Viewer
will automatically use the password specified here
to log in, and the user doesn’t need to enter the
password.

Color level

Select from four color levels: Full (all available
colors), Medium (256 colors), Low (64 colors), Very
low (8 colors).
Auto select (not all servers support this function)
Allow VNC Viewer to automatically detect and select
the color level supported by the server used.
Enable run-time modification in [Control] function
Select color level or decide whether to enable [Auto
select] in HMI runtime using the control addresses
that can be specified in the Control tab in the VNC
Viewer settings dialog box.

Title bar

Enable
When [Enable] is selected, a field shows for entering
the caption in the title bar. The caption is limited to
ASCII characters, and the font cannot be customized.
The caption can be selected from Label Tag Library.
Only when the title bar is enabled can the VNC
Viewer window be moved or resized by dragging.

Option

Enable input from system keypad
With this option selected, a keypad icon shows in
the upper right corner of the VNC Viewer object,
and the system keypad can be opened by clicking
this icon.

Note




eMT/iE/XE/mTV: VNC Viewer is supported for OS version 20160418 or later.
cMT / cMT X Series: VNC Viewer is supported only on cMT series HMI screen accessed
locally, and for OS version 20180928 or later.
VNC Viewer cannot be simulated in on-line simulation mode.
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When [Default password] is selected, HMI’s Virtual Keyboard can only be called out
manually. If [Default password] is not selected, the Virtual Keyboard can pop up
automatically.

Control Tab

Setting

Description

IP

A set of word addresses can be specified to control
VNC Viewer as well to display the connection status.
Control address: Shows the connection status
0: Stopped
1: Running
2: Failed to connect
3: Authentication error
4: Server disconnection error
5: Security error
Control address + 1: Command
0: None
1: Start
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2: Stop
Control address+2~+5: IP
Control address+6: Port Number
Control address+7: Default Password
0: Disable
1: Enable
Control address+8: Password (16 words)
Control address+24: Title bar
0: Disable
1: Enable
Control address+25: Title bar name (16 words)
Control address +41: Color level
0: Very low
1: Low
2: Medium
3: Full
Control address +42: Auto select
0: Disable
1: Enable

Note




The allowable value range that can be entered in Control Address+6 is 0~99. The actual
Port Number will be the value entered in Control Address+6 plus 5900. For example, if the
user enters 1 in Control Address+6, the actual Port Number will be 5901. However, if the
user enters 100 in Control Address+6, the value will not be added by 5900, and the actual
Port Number will be 100.
In VNC Viewer, to use the HMI built-in Virtual Keyboard, please tap the Focus button on
the Virtual Keyboard first, and then tap VNC Viewer screen. This will change the input
target.

Click the icon to download the demo project. Please confirm your internet connection
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before downloading the demo project.
Click the icon to watch the demonstration film. Please confirm your internet connection
before playing the film.
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13.50. Contacts Editor
Overview
Contacts Editor enables users to dynamically add / modify / delete email contacts on HMI.
Configuration

Click the Contacts Editor icon on the toolbar to create a Contacts Editor object. Or, click
[Objects] » [Contacts Editor] in the menu.
General Tab
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Setting

Description

Control Address

A set of word addresses can be specified to change
contact list or to show results.
Control address: Gives commands.
Value Command
0

None

1

Add a contact to contacts list

2

Delete a contact from contacts list

3

Update mail address

4

Add a contact to group

5

Remove a contact from group

6

Remove all contacts from group

7

Display contacts in group

8

Display contacts with no group

9

Display all contacts

Control address + 1: Shows execution result.
Value Result
1

Success

2

Invalid command

3

Contact not found

4

Contact already exists

5

Too many contacts

6

Invalid name

7

Invalid mail address

8

Invalid group (equal to zero)

9

Invalid group (exceed boundary)

Control address + 2: Group(s), uses bits to
represent groups.
Value Commands
0

Group A

1

Group B

2

Group C

3~15

Group D ~ Group P

Control address + 3: Name (32 word(s)), contact
name
Control address + 35: e-Mail (32 word(s)), e-mail
address
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Note




General tab cannot be found when the model used is a cMT / cMT X model.
Contact names do not support Unicode.
The number of groups is specified in [System Parameter Settings] » [e-Mail] » [Recipients].
Please note that the number of groups cannot be dynamically changed on HMI.

Outline

Setting

Description

Font & Color

Select Contacts Editor object’s font and color.

Setting

Description

Title

The title shown in Contacts Editor.

Display chars

The displayable data length of each title in Contacts
Editor. Range: 1~60

Title
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13.51. Event Bar Chart
Overview
Event Bar Chart is a type of easy-to-use bar chart that can comprehensively illustrate project
schedule. Using Event Bar Chart to illustrate HMI events or alarms can help users to clearly
understand the time at which an event or alarm occurs, and its duration. Before drawing an
Event Bar Chart, please configure Event Log object first.
This feature is only supported on cMT / cMT X Series models (excluding cMT-Gateway).
Configuration
Event Log
Click [Data/History] » [Event Log] in the menu to configure several event logs. This section
describes the Event Bar Chart related settings that can be found in the Event Log settings dialog
box.

Setting

Description

Edit category name
mapping

Event Bar Chart will show the name of each category.
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General Tab

Setting

Description

Category

Event Bar Chart will illustrate the duration of all events in
one category, please select correct category in this field.

Message Tab

Setting

Description

Text

Enter the name of the event log.

Color

Select the color for the bar shown in Event Bar Chart
that illustrates this event log.
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Event Bar Chart

Click [Data/History] » [Event Bar Chart] in the menu to draw an Event Bar Chart.
General Tab

Setting

Description

Include
categories

Predefined
Predefine a range of event categories to be displayed in the Event Bar
Chart.
Dynamic category range
Use a set of consecutive addresses to select the display range of event
categories dynamically.

Option button
visibility

Show or hide the option button

of the object.

Predefined
Select [Enable] to show the option button.
Dynamic
Choose a bit address to control option button visibility.
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Appearance Tab

Setting

Description

Display timespan

Specify the time interval that is measured as a number of
hours. Events occur during this time interval will be
illustrated in Event Bar Chart. Tapping
in the upper
right corner of the HMI screen can also change this
setting.
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Style

By default 3 styles are provided for users to choose from.

Text size

Text sizes range from 50%~200%.

Title bar Format

Date + Time:
Date only:

Watch line

Time only:
A watch line shows at the point in the Event Bar Chart
that is touched. The time represented by the touched
point will show at the top of the watch line.

Number of Division

The number of divisions on X axis.

Time label

The format in which the time label is displayed.

HMI Settings
On cMT HMI or cMT Viewer, tap the

icon in the upper-right corner of the object to open

the following settings window.
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Setting

Description

Begin Date and Time

Specify the begin date and time at which Event Bar
Chart displays data. By default this setting is disabled,
and Event Bar Chart displays from the begin date and
time of the stored data.

End Date and Time

Specify the end date and time at which Event Bar Chart
displays data. By default this setting is disabled, and
Event Bar Chart ends at the end date and time of the
stored data.

Event Filter

Keyword
Events can be filtered by entering a keyword.
Match case
Use case-sensitive search when searching for events in
English.

Display Timespan

Dynamically change the time range (1~96 hours.)

(hr.)

shown in Event Bar Chart. Select all to display all
existing events.

Note


When HMI power is off, the HMI will not be able to obtain the alarm states; therefore, the
alarm states during the power off period will not be illustrated in Event Bar Chart, not
even after the power turns on.
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13.52. Action Trigger
Overview
The Action Trigger object can trigger a sequence of action groups when the specified condition
is met. Users can divide actions into action groups and the actions within the same group are
executed at the same time when the specified condition is met. When all the actions within
the same group are completed, the actions in the next group are then executed. This object is
only available on cMT / cMT X Series models.
Action Trigger has two types, each with different modes for triggering action execution:
Action Trigger (per-page): [Window open/close], [Backlight on/off], and [Value changed]
modes.
Action Trigger (Global): [Idle timeout], [Value changed], [Control token], [User secure access],
and [Condition object] modes.
Configuration

Click [Object] » [Action-related] » [Action Trigger (per-page)] or [Action Trigger (Global)] icon
on the toolbar to open an Action Trigger object property dialog box. Clicking [New] can add a
new Action Trigger.

EasyBuilder Pro V6.08.01

13-363

Objects

General Tab
Action Trigger (Per-page)

Action Trigger (Global)

Setting

Description

Trigger
(per-page)

Window open: Triggers actions when window opens. Settings in
Security tab will not be available when using this mode.
Window close: Triggers actions when window closes.
Backlight on: Triggers actions when backlight turns on.
Backlight off: Triggers actions when backlight turns off.
Value changed: When the state of the designated register meets the
preset condition, Action Trigger will start executing.

Mode: Idle
Timeout
(Global)

If the screen is left untouched for more than the specified time limit
configured in [Idle Timeout], Action Trigger will start executing.
Range: 1~43200 seconds

Mode: Value
Changed
(Global)

When the state of the designated register meets the preset
condition, Action Trigger will start executing.
Check condition recursively when actions ended
When all actions are completed, the trigger condition will be checked
again; and if the condition is met, the actions will be triggered again.
Dynamic condition value
This option is available when [Word] is selected as Type. Selecting
this option opens the [Read/Condition use different addresses]
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option. When [Read/Condition use different addresses] is not
selected, the condition value is read from the next contiguous
register of [Value address].
Control
Token
(Global)

Triggers actions when the Control Token is acquired or unacquired.

User Secure
Access

Triggers actions when access to the specified security class is
obtained or lost. When the security class is [Any], the actions can be

(Global)

triggered, regardless of class, when the access is obtained or lost.

Condition
Object
(Global)

Triggers actions when the conditions set in Condition object are met.
Check condition recursively when actions ended
When all actions are completed, the trigger condition will be checked
again; and if the condition is met, the actions will be triggered again.

Action Group

Actions are classified into groups. Actions in the same group will
simultaneously be triggered, and only after the actions in the
previous group have been all triggered, the actions in the next group
will then be triggered.

Delay

Delays the action for the specified time period (milliseconds).

Set Bit

Sets the designated bit address ON or OFF.
Set ON
Sets ON the designated bit.
Set OFF
Sets OFF the designated bit.
Toggle
Alternates the bit state.

Set Word

Changes the value in the designated word address.
Write constant value
Writes the constant value to the designated register.
Increment value (JOG+)
Increases value in register by a set amount in [Inc. value], up to the
[Upper limit].
Decrement Value (JOG-)
Decreases value in register by a set amount in [Dec. value], down to
the [Bottom limit].
Dynamic Limits (JOG+, JOG-)
Sets the [Upper limit](JOG+) and [Bottom limit](JOG-) by a
designated register.
Write constant string
EasyBuilder Pro V6.08.01

13-365

Objects

Writes the constant string to the designated register.
Object Control Command (cMT / cMT X only)
Listed for selection are commands (with their corresponding
command values) available for the control address of various
functions.
System Tag Command (cMT / cMT X only)
When a system tag is set as write address; for example, LW-9134:
Language Mode, the commands relating to the system tag can be
selected.
Change
window

Switches to the designated window. Change full-screen window can
only be the last action in the last group in an Action Trigger.
Change full-screen window: Changes to another base window.
Change common window: Changes common window.
Return to previous window: Changes from current screen to the
previous one displayed. For example, when window no. 10 is
changed to window no. 20, this function can be used to return to
window no. 10. This function is only available for base window.
Animation Setting:
The effects are: Fade, Fly, Float, Wipe, Split, Circle, Clock, Zoom, Turn,
Push. Different effects may be used for Start (window appears) and
End (window disappears).
[Duration] specifies how many milliseconds (ms) a transition effect
takes to complete.
[Direction] The direction of the transition.

Execute

Executes one of the Macros from the drop-down list that has already

Macro

been configured by users. Running a macro may take a while to
complete; therefore, when [Execute Macro] is put into an action
group, it is seen as completed when it is triggered. The system will
not wait for the macro to complete running before moving on to the
next action group.

Popup
Window

Pops-up a designated window.

Popup

Opens a calculator with an unchangeable appearance, allowing

Calculator
Window

operators to do simple calculation and enter the result to a
destination object by pressing the Enter key.

Keyboard
Input

Inputs characters/control signals, as often used with [Numeric] or
[ASCII] objects.
Enter: Same as the keyboard’s “Enter” function.
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Backspace: Same as the keyboard’s “Backspace” function.
Clear: Clear the value in the word register.
Esc: Same as the [Close window] function; it is used to close the
keyboard window.
Delete: Same as the keyboard’s “Delete” function, deletes the
number or character on the right side of the text cursor.
Left: Same as the keyboard’s “←” key moves the text cursor to the
left side of the previous number or character.
Right: Same as the keyboard’s “→” key moves the text cursor to the
left side of the next number or character.
Inc: Add 1 to the current value.
Dec: Minus 1 from the current value.
ASCII/UNICODE: Specify the character to be entered by this key.
Screen
Hardcopy
Acknowledge
all events

Saves current screen as a hard copy file into a SD card or USB disk.
Acknowledges all events at once.

(Alarms)
Import Data

Imports the e-mail contacts or user accounts, or logs in using USB
Security Key.
Data Position:
The external device to read data from. Options: USB disk or SD card.
Account import mode:
If [Overwrite] is selected, there will be only imported accounts after
import. If [Append] is selected, there will be imported accounts in
addition to existing accounts after import.
Delete file after importing user accounts:
The system will delete the account data saved in the external device
after importing; this can prevent the account data from leaking out.

Wait Until

Data Transfer
(Global)
File Transfer

The next group will be executed only when the condition set for a
designated bit or word address is met. However, if the condition is
not met even after the set wait time (timeout), it can either move on
to the next action group or end prematurely without continuing.
Sends the value in the designated address to another address.
Transfer files by FTP. HMI will connect to the FTP server in passive
mode.
General Tab:
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Download: Transfer file from FTP server to local HMI.
Upload: Transfer file from local HMI to FTP server.
Server address:
[Direct]: Designate server address related settings in EBPro.
[Dynamic]: Designate an address for changing the server address
related settings dynamically on HMI.
Suppose the dynamic address is set to LW-n, then:
LW-n: Host usage (0: IP, 1 Domain name)
LW-n+1: IP (4 words)
LW-n+5: Port
LW-n+6: Authentication (0: None, 1: Account)
LW-n+7: Username (16 words)
LW-n+23: Password (16 words)
LW-n+39: Domain name (64 words)
Delete the source file after successful transfer
Following successful transfer, the source file will be deleted. When
transferring in [Download (FTP -> HMI)] mode, please make sure that
the account has the write permission on the FTP server.
File Tab:
Set file position and full path of FTP server / Local HMI. When a
folder path is specified, all the files in that folder will be transferred,
not including files in subfolders. When a file with identical file name
already exists, it will be overwritten regardless.
Status Tab:
Designate an address for showing file transfer result and FTP server
response. Please use the following link for more information on FTP
server return codes.
https://en.wikipedia.org/wiki/List_of_FTP_server_return_codes
Control
Token

The action to acquire or unacquire a Control Token.
Control Token: Select a Control Token.
Action: Set this action to acquire or unacquire a Control Token.
Max. waiting time: Continues or stops running the next action group
if the Control Token is still not acquired even after the set [Max.
waiting time].

Note


At most 1000 Action Triggers can be created in a project.
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At most 20 groups can be created in an Action Trigger, and at most 20 actions can be
added into a group.
File Transfer Error Codes:
Error Code

Description

0

File transferred successfully.

1

The HMI directory for download does not exist.

3

USB disk or SD card is not found.

4

HMI or FTP directory is empty.

5

Uploaded file does not exist.

8

Operation rejected by FTP server.

9

USB disk or SD card is full.

10

Unknown error.
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13.53. Calendar
Overview
The Calendar object can show a calendar on cMT / cMT X Series HMI.
Configuration

Click [Object] » [Time-related] » [Calendar] icon on the toolbar to open a Calendar object
property dialog box. Set up the properties, press OK button, and a new Calendar object will be
created.
General Tab

Setting

Description

Appearance

Navigation bar Set the background color and text color of the
navigation bar.
Day of week Set the background color and text color of the days of
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week.
Day Set the background color, grid color, and text color of the days.
Today Set the background color and text color to show today.
Operation

Output the date information in a number or a string to the
designated address.

Click the icon to watch the demonstration film. Please confirm your internet connection
before playing the film.

EasyBuilder Pro V6.08.01

13-371

Objects

13.54. Touch Gesture
Overview
For some time, smartphones or tablets nowadays have been using gesture-based operation,
e.g., pinch with five fingers to close an app. Now, with HMI having Touch Gesture object that
supports up to 23 touch gestures, HMI can provide operating experience comparable to that of
a smartphone or tablet.
The Touch Gesture finger limit is 5.
Configuration

Click [Object] » [Action Related] »[Touch Gesture] icon on the toolbar to open the Touch
Gesture property dialog box. Select a window and then add its allowable touch gestures.
General Tab
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Setting

Description

Window List

Allow the gesture actions to be used in a specific window or all
windows. When Global is selected, one-finger gestures are not
supported.
Add/Delete
Add or delete a window that allows this gesture action.

Gesture

Shows gesture action list for the window.

Action List

Add/Delete
Add or delete a gesture action.

Actions

Set an action or group of actions triggered using this gesture. For
more information on the actions, see Chapter 13.36 or 13.52 in this
manual.

Note







Up to 16 gestures can be used for each window setting (global/individual).
When the same gesture is used in both the Global window and an individual window, the
gesture is effective only for the individual window.
When a user performs a gesture on the screen, objects are still triggered when they are
touched.
The touch gesture for an individual window is only effective when the window is a base
window. If the said window is a pop-up window, or overlaid windows, its touch gesture
will be ineffective and its gesture actions will not be executed.
Detection for the next gesture will only start when the actions for the current gesture
have been completed.
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13.55. PLC Web Browser
Overview
The PLC Web Browser object can be used for browsing PLC web pages. PLC Web Browser is
supported only on cMT3072X, cMT3072XH, cMT3092X, cMT3152X, and cMT3162X.
Configuration

Click [Object] » [Media] » [PLC Web Browser] icon on the toolbar to open a PLC Web Browser
object property dialog box. Set up the properties, press OK button, and a new PLC Web
Browser object will be created.
General Tab

Setting

Description

Default URL

Enter the URL into the provided field.
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Show
navigation
bar

With this option selected, users can directly change URL, refresh
page, or zoom in/out web page by clicking the icons in the navigation
bar displayed on HMI.
Icon

Command
Go back to the previous page
Go forward to the next page
Zoom out the page
Zoom in the page
Return to homepage
Refresh the page

Rounded
corners

With this option selected, the browser window will be displayed with
rounded corners.

Control
address

LW-n: Command ID
Value

Command

0

None

1

Go destination

2

Reload

3

Stop

4

Go back

5

Go forward

6

Clear cache

7

Clear cookie

LW-n+1 Status
Value

Command

0

Load started

1

Load stopped

2

Load succeeded

3

Load failed

LW-n+2 Error Code
Value

Command

0

No error

1

Internal error

2

Connection error

3

Certificate error

4

HTTP error

5

FTP error

6

DNS error
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Destination
page URL
address

The designated register is for entering a URL with length limit 255
words. After entering the URL, please enter value 1 in the Command
ID address to go to the destination page.

Current page
URL address

Shows the URL of current page, the length limit is 255 words.

Notes on PLC Web Browser
1
2

3

For more details about supported models and OS versions, please see Appendix A in this
user manual.
PLC Web Brower object is designed specifically for connection to PLC’s built-in web server,
allowing users to access PLC web page to configure PLC and view PLC data. Using PLC Web
Browser to connect to other types of websites may lead to unexpected results or errors.
Displaying relatively complex web page using PLC Web Browser will occupy more memory
and consume a large amount of CPU, which can significantly slow down HMI’s operating
speed. Users are advised to use change page function or a Direct/Indirect window to
display PLC Web Browser object only when it is needed, in order to prevent reduction of

4
5
6

7

system performance.
As HMI memory is limited, when the PLC Web Browser occupies too much memory, the
system will automatically stop PLC Web Browser to ensure proper operation of HMI.
In consideration of performance, PLC Web Browser can only run on an HMI whose
CODESYS is not activated.
Due to rapid change in web technologies, it is not guaranteed that all PLC web servers are
supported by PLC Web Browser in EasyBuilder Pro, and certain PLC web pages may not be
correctly displayed using PLC Web Browser.
When multiple PLC Web Browser objects are placed in a single window, only one of them

will run while the rest remain ineffective.
8 PLC Web Browser object displays web page on top of everything else even if there are
other objects placed above it.
9 When the PLC Web Browser is clicked or tapped in cMT Viewer running on a PC, smart
phone or tablet device, the default browser for the device will be used to open the web
page. Note that, in this case, to access the PLC within the same network as HMI, the
device running cMT Viewer should also be in the same network as the PLC.
10 Browsing web pages using PLC Web Browser on cMT-iV5/cMT-iV6 is not possible.
11 Features not supported by PLC Web Browser:
 Save file as…
 Text selection
 Right-click menu
 Drag & Drop
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Windows prompt for entering account name and password (e.g., FTP login)
Playing videos, e.g. YouTube…etc.
Uploading / Download files.
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13.56. Condition
Overview
The Condition object can be used to replace the if-else statement in macro. When the specified
conditions in the Condition object are met, the designated output bit address will be set ON.
The output bit address can be used in objects’ security settings, Event Log, Backup, and Data
Transfer…etc. The Condition object can be selected in Action Trigger (Global) object’s mode
setting. Note that this object is available only on cMT / cMT X models.

Configuration

Click [Object] » [Condition] icon on the toolbar to open a Condition object property dialog box.
Click [New] to add a new condition, and then click [OK] to create a Condition object.
General Tab
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Setting

Description

Name

Enter the name of this object.

Conditionals

Operator: Select AND / OR operator.
AND: The Condition object is effective when all the specified
conditions are met.
OR: The Condition object is effective when one of the specified
conditions is met.

Type

Value Address: Select an address type from Bit / Word.

Condition Object: Select another Condition object.

Output

With this option selected, when the conditions are met, the specified
bit address will be set ON. When the conditions are not met, the
specified bit address will be set OFF.

Note



At most 128 Condition objects can be created in a project.
At most 8 conditions can be created in a Condition object.
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Example 1
Here is an example of using Condition object to replace the if-else statement in macro.
The macro below contains three conditions.

1.

Create a Condition object, add condition_A and condition_B, and then select AND
operator as shown below.
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2.

Create another Condition object, add Condition Object 1 created in the previous step, add
condition_C, and then select OR operator as shown below.

3.

Now the Condition objects can do the same thing as the macro, which triggers actions
according to the conditions.
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13.57. FTP Server
Overview
In FTP Server settings, FTP connection parameters can be configured. With FTP function
enabled, backup files (screen hardcopy or historical data) can be transferred to FTP server on
PC from HMI, in order to achieve the same effect as using EasyPrinter. This feature is only
supported on cMT / cMT X Series models.
Configuration

Click the FTP Server icon in Data/History tab to open the property dialog box. Set up the
properties and press OK button to add a new FTP server.
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General Tab

Setting

Description

Server address

Direct
Use the server address related settings (e.g. Type, IP,
Port…etc.) in EasyBuilder Pro.
Dynamic
Specify an address for setting FTP connection parameters
dynamically on HMI.
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Host

Plain FTP
No encryption.
Implicit FTP over TLS
The entire connection is encrypted. Default TCP port is 990.
Explicit FTP over TLS
Encryption begins following authentication request (AUTH
TLS). Default TCP port is 21.
FTP server’s IP address or domain name.

Port

FTP server’s port number.

Username

FTP server’s username.

Password

FTP server’s password.

Type

Note


If “This server is used and cannot be deleted.” message shows while deleting an FTP
server, please disable FTP function in Home » System Parameters » FTP tab.
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13.58. Date/Time
Overview
The Date/Time object displays the current date and time in the specified format and font.
Configuration

Click the Date/Time icon on the toolbar or click [Object] » [Time-related] » [Date/Time] in the
menu to create a Date/Time object.
General Tab

Setting

Description

Date

Set the date format.

Day of week

Set the label of the days of the week.
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Time

Set the time format.

Font

Set the font, color, size and alignment of the text displayed.
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