cMT X Series Easyweb 2.0
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L_l\u\WE!NTEK cMT X Series Easyweb 2.0

Chapter 1 System Settings

1.1 Overview

Easyweb 2.0 is a web interface that allows users to configure parameters of cMT X Series HMI.
Additionally, with its Webview feature, users can monitor HMls through a web browser. This user

manual explains the cMT X Series HMI features that can be configured using Easyweb 2.0.

1.2 Ways to Log In Easyweb 2.0

Connect an HMI via an Ethernet cable, and log in system settings in one of the following ways.

Via internet browser

Open internet browser (Windows Edge, Chrome, or Firefox), and enter HMI’s IP address (e.g.:
192.168.2.121). The web page below opens. If Webview interface is shown after entering the IP
address, please enter https://HMI_IP/admin to open Easyweb 2.0 system login page.

W Easyweb

Welcome back

Sian ) con
Sign in to continue

£ HM! Name

Admin Jpdate History

NG cMT-1E7C_FAE_cMT3072XH .

Password

J et

Set on cMT Viewer devices

Launch cMT Viewer App, tap Search, select the HMI and tap Qe icon to configure.
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https://hmi_ip/admin%20to%20open%20EasyWeb%202.0

o[ f
I 17-03-2910:4806 -

Connect °
Search History

Q Name/ 1P c

-y CMT-4C66

“ 192,168.2.121 [+

-, Default HMI

B

"7 192.168.2.124 ° |
. CMT-3E87

2

“ 192.168.2.127 °

o 1%-3072

¥ 192.168.2.136 e

o, CMT-4C52

5y

v 192.168.2.141 e l
-, CMT-2C40

¥ 192.168.2.147 ©

.~ Default HMI

“* 192.168.2.151 6 l
7, CMT-04B1

"7 192.168.2.195 e

o CMT-AC51%Q 2

' 192.168.1.212 -

1.3 Easyweb 2.0 Login Identities

Three identity levels exist in Easyweb 2.0: [Admin], [Update], and [History]. [Admin] controls all the
settings while [Update] controls limited items. For safety, specify a password before configuration.
A password is needed for opening [History] settings, and the historical data can be backed up after
logging in with password.

The default password is 111111. After successful login, the password for each identity level can be

changed in [System Password] page.

W Easyweb

Welcome back
Sign in to continue

a ®

Admin Update History

Password
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1.4 Easyweb 2.0 Interface
Dashboard

System status and HMI status are displayed in Dashboard after login.

192.168.2.97

\\o cMT3072XH HMI Name: Date/Time:
EasyWeb 2.0
© sveen Dashboard
T3 Network
== Project
2023/04/27 15:28:31 3:29
V2.1.53 20230322

System » Info

In this page the user can edit HMI Name / Date / Time.

192.168.2.97

\\o cMT3072XH HMI Name: Date/Time:
EasyWeb 2.0
© sveen Dashboard
T3 Network
== Project
2023/04/27 15:28:31 3:29
V2.1.53 20230322

System » Diagnostics

cMT-1E7C_FAE_cMT...

2.16.5

cMT-1E7C_FAE_cMT...

2.16.5

In this page the user can collect information about any errors that occur during HMI operation.
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192.168.2.97

HMI Name:

“,? cMT3072XH ‘) Date/Time:

) EasyWeb 2.0

Diagnostics

HMI Info Collector Version: 1.0.20
® Diagnostics

T Network HMI Info Collector: ¥ Run
= Project
&= Data

® Features

G W

© Administration

B hmi-info-collect..enc A

Network » Ethernet

In this page the user can set the IP address of each Ethernet port.

\\0 HMI Name: Date/Time: - admin
)
Ethernet
i ]
=
LAN 1 (WAN)
-

Mac Address: 00:0¢:26:21:1e:7¢

Configure IP: Automatic &
Address: 192 . 168 . 2 . 97
G
Netmask: 255 . 255 . 252 . O
Gateway: 192 168 . 254
DNS: 168 . 9% . 1

Bridge Mode
Dual Ethernet port models can be configured in Bridge Mode to allow LAN1 and LAN2 to operate in

the same network segment, providing switch-like functionality.
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Date/Time: ® - admin v

HMI Name:
\“’ cMT3072XH
EasyWeb 2.0 3

@ sreem Ethernet

T Network

Bridge Mode

® Ethemet
Enable Bridge Mode:

Enabling Bridge Mode triggers a confirmation window, which prompts users to verify the proper

connection of the two Ethernet ports. Failure to do so could lead to a network loop and a broadcast

storm. Once the connection is confirmed, click OK to proceed with the operation.

Attention! X

Bridge mode makes HMI behave like a two-port Ethernet
switch. And networks on both Ethernet ports are
connected in the same broadcast domain.

NOTICE: if both ports connects to the same network,
unplug one. Otherwise, this creates a network loop and
causes a broadcast storm breaking the network.

OK (5) Cancel

Project » Project Management

In this page the user can restart / update / back up the project file.
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@ cMT-Project Management X =+

< C A == | 192.168.2.121/admin/project/management % ® O | Q= @ :
® Dashboard / Project Project Management = admin
\ cMT3152X
Easyweb 2.0

o Info Project Management

@ Network Restart Project: Restart C

= Project Update Project:

® Project Management Backup Project: Backup &

USB/SD Update:

Project » Email

In this page the user can edit email contacts; e.g., the groups a contact is in, and email addresses.

o= %
@ T - Email x 4+

<« C A F=2 | 192.168.2.121/admin/project/email % ® O H g =@ :
Dashboard / Project Emai o admin

\ © cMT3152X
0

Easy

QO o SMTP  Contaots  Upioad

@ Network
*Host: stmp.gmail.com

i Project

* Username: test@gmail.com

“Password: = eeseeeees
* Gonfirm Password:
Authentication: ()
Encryption: Nore @ TLS SsL

(W) Features

Sender Information

“Name: Local HwmI Use HMI Name

Project » Enhanced Security
In this page the user can set operable classes and password for each account.
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o|=] &
@ cMT - Enhanced Security x  +
< C A F== | 192.168.2.121/admin/project/security # % O | 8| = @ H
Dashboard / Project Enhanced Security A admin
\ © cMT3152X
Easyweb 2.0
o Info Accounts Import User Accounts
= Project @ Please click [Save] bution after editing data
~ Passwor
D Hide Account a A B [ D E F G H 1
1 admin 11111 ~ ~ ~ ~ o o o o ~
Enhanced Security 2 useri 111 o
3 user2 222 ~ ~
4 user3 333 J e v
5 userd 444 ~ v \/ \/
6 userb 555 J ~ e e v
7 usert 666 ~ ~ 4 4 N4 v
Project » Recipe
In this page the user can update, back up, or clear recipe data on HMI.
o|=] %
@ cMT - Recipe x 4+
<« C A F=2 | 192.168.2.121/admin/project/recipe # ® O | s e @ H
Dashboard / Project Recipe = admin

\ © cMT3152X
0

Easy

QO o Action

em
T Network Update Backup Clear
Recipe Database Backu
& Project s pd p

nw

-

Backup

(W) Features

Data » Data Log & Trend Display
This page displays data log and the corresponding trend. The data can be exported or backed up.
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Please note that decimal places are not displayed, exported or backed up in Easyweb 2.0; however,
this can be achieved by creating a History Data Display object and a Backup object in the HMI

project and connecting the HMI using cMT Viewer.

o|=] %
@ cMT- Datalag & Trend x 4+
< C A F=2 | 192.168.2.121/admin/data/datalog % ® O H g =@ :
Dashboard / Data / Data log & Trend = admin
\ © cMT3152X
Easy 0
o Info Datalog Trend Display
@ Network
Object:  logooo
Project
0 Refresh @ Option
# = Time + Channel 1 Channel 2 Channel 3
Ll By 235778 (@ 2020/04/0113:27:39 0422618 0574748 1.19927
235777 (© 2020/04/01 13:27:38 -0.173648 -0.777817 1.18177
235776 © 2020/04/01 13:27:37 0.130526 -0.959746 1.09625
235775 © 2020/04/01 13:27:36 0.382683 -1.0587 0.97082
235774 ® 2020/04/01 13:27:35 0.608761 -1.09915 0.802957
235773 ® 2020/04/01 13:27:34 0.793353 -1.07886 0.6
235772 (& 2020/04/01 13:27:33 0.939693 -0.980107 0.330765
* Export to Spreadshest * Backup database 1
o|=] %
@ cMT- Datalag & Trend x 4+
< C A F=2 | 192.168.2.121/admin/data/datalog % ® O H g =@ :
Dashboard / Data / Data log & Trend = admin
\ © cMT3152X
Easy 0
o Info DataLog Trend Display
@ Network
Object:  logooo
Project
Auto Refresh 2 Refresh @ Option
45
Data Log & Trend Display 10
15
o
-15
-30
-45
1:23PM 124 PM 1:25 PM 1:26 PM 1:27 PM 1:28 PM 1:29PM 1:30 PM 131 PM
—-0.382683 —— 0914817 ——-12
X. Division 8 Y. Division 7

The display feature can work properly only when in EasyBuilder Pro, [All records in one file] is
selected in Data Sampling’s History File setting. The display feature is currently not supported for
[Customized file handling] mode.
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History file
Enable

@) All records in one file

() Customized file handling

File name :  |ogooo

Data » Event Log

This page displays event logs, and the data can be exported or backed up.

o|=] &
@ MT-Eventlog x  +
& G A F=2 | 192168.2.121/admin/data/eventlog # 4 0[ B =@ :
Dashboard / Data / Eventlog - admin
\ © cMT3152X
Easyweb 2.0
o Info
Time column
2 Network 2020-03-04 ) 2020-04-01
Category range (0 - 255)
- .
Project
0 255 .
Keywords Select Language
Add terms Language1
EventLog
# Calegory Event Message Event trigger time Retum ip normal time Occurence count
1 1 TankError!! (© 2020/04/01 13:31:25 ® 3 =
2 1 Machine Error !t © 2020/04/01 13:31:25 O 2020/04/01 13:31:31 44
3 255 StartMemory Test  © 2020/04/01 133117 @ 1
Flow Speed Ermor
4 1 . © 2020/04/0118:31112 @ 2020/04/01 13:31:20 17
5 1 Machine Error !t © 2020/04/01 13:31:110 @ 2020/04/01 13:31:18 43
[ 1 TankEmor ! © 2020/04/01 133106 © 20200401 13:31:15 30

Data » Operation Log

In this page the user can back up operation logs.
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o= %
@ cMT - Operation Log X  +

< C A F=2 | 192.168.2.121/admin/data/operationLog “ ® O H o= @ :
Dashboard / Daia Operation Log o admin
\ € cMT3152X

Easyweb 2.0

+ Backup database

o Info
EI Network

= Project

@ OperationLog

@ Features
@ Account

Features » Webview Setting
In this page the user can enable Webview and set password. Please see Chapter 2 in this user
manual for more details.

7 v
192.168.2.13 0 @ =s=a=

\ ® cMT3072XH HMI Name: D¢ Date/Time: ° admin

\ Easy 20

WebView Setting WebView w

] Network
SR Enable @
== Project
— Force HTTPS ()
@ Features Use same HTTP port as EasyWeb

®  WebView Setting

Use WebView as homepage

User List 0 A Control Only View Only

Automatic Login © Disabled Control User View User

(?ontrol User Change password

View User Change password &

Features » CODESYS

In this page the user can activate CODESYS® and manage settings for firmware updates.
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- o

19, 63 % & O @ mncogito

® cMT3072XH 3 HMI Name: Date/Time: X - admin v
\‘ EasyWeb 2.0 3
© sveer CODESYS
T3 Network
Status

Status: Not Activated

License: Activate Restore

® CODESYS

Features » FTP

In this page the user can modify FTP server related settings.

x  + v

192.1682.13 % 0 @ =ras
\ © cMT3072XH HMI Name: Date/Time: -  admin
EasyWeb 2.0
o System FTP
FTP Server Enable [ @)

FTP client can modify USB/SD data

FTP port

Features » EasyAccess 2.0

In this page the user can activate EasyAccess 2.0 and configure the proxy server.

UMO020001E_20231101 Copyright© 2023 WEINTEK 1IOT LTD. All rights reserved.
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+ u]

192.168.3.63 . . D @ e
© GMT3072XH i Neme: CatalTime: 2 aimin -
\\ EasyWeb 2.0 A)
@ sysen EasyAccess 2.0
¥ Network
Connection
& Project 3

&= Data

Status: 2 (Connected)
Fealures

&% Weincloud Hardware key:

® EasyAccess 2.0 Error code: 0

SessionID: 0
Password: 0
Version: 2.16.5

Domain Name:

Weincloud » Dashboard

In this page the current subscription status of Dashboard can be viewed.

® - HMI Name: Date/Time: - admin
\\ cMT3072XH
EasyWeb 2.0 ki
- Dashboard
System
T3 Network
Region: Global
Domain: weintek_fae

Status:

Expiry Date: 1970-01-01

Action: < Manage on Weincloud

Dashboard

QR Code:

Administration » System Password

There are four different levels of password protection: System Setting, Update Project, History, and
User, and in this page the user can change the passwords. The default passwords are 111111.
[System Setting]: This is the highest level. It has an access to change all system settings, download,

upload project, back up historical data, or change passwords for other levels.

UMO020001E_20231101 Copyright© 2023 WEINTEK 1IOT LTD. All rights reserved.
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[Upload Project]: This level can download, upload project, and back up historical data.

[History]: This level controls FTP access and it can back up historical data.

[User]: This level can operate cMT X projects via cMT Viewer. Other three levels above can all do
this.

S M7 x  +
&« C { A F=2 | bps//192.168.2.119/admin/account/password 2 B & » O @ :
o P —

\‘O cMT3152X b
EasyWeb 2.0

System Password

g Network

| Please select identity to edit password

Project

System Setting
Current password:

New password:

© Administration

®  System Password

Confirm new password:

Submit Reset

System Setting
Update Project
History

User

UMO020001E_20231101 Copyright© 2023 WEINTEK 1IOT LTD. All rights reserved.
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Administration » Security

x  + v

192.168.2.13 ‘ a @ e
® cMT3072XH - HMI Name: Date/Time: 2 2 admin
\‘ EasyWeb 2.0 3
e Security
@ iy Force HTTPS .

Auto block if failed login attempts reaches the limit

Allow site embedding a
Allow CORS requests [ @)
Password Strength Rules Reset m

Enable password strength rules

Minimal password length

Include numbers

[Web Security]

Encrypt communication with EasyBuilder Pro, block the account when the number of failed login

attempts reaches the limit, or allow this web page to be embedded.

Force HTTPS a

Auto block if failed login attempts reaches the limit

Allow site embedding

8

Allow CORS requests

8

[Password Strength Rules]

Set password strength rules that EasyWeb uses to determine whether a password is valid.

UMO020001E_20231101 Copyright© 2023 WEINTEK 1IOT LTD. All rights reserved.
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Password Strength Rules Reset
Enable password strength rules

Minimal password length

Include numbers

Include mixed cases

Include special characters

[Password Expiration]

Set the password expiration policy.

Password Expiration Reset

Enable password expiration

Validity period

days
Enforce password update
Administration » OS Update
The OS can be updated by using EasyWeb 2.0.
\\0 SZEEZ%XH HMI Name: DatefTime: Q L admn v

o System OS U pdate

T3 Network

OS Update: Update =

® OS Update

During the update process, please do not turn off the HMI.

UMO020001E_20231101 Copyright© 2023 WEINTEK 1IOT LTD. All rights reserved. 15



3¢ Updating

© © ®

Prepare OS Update Upload OS Image Update OS

© Please wait until update has completed

Once the update is complete, the system will display the following window.

© Update Completed X

© © ©

Prepare OS Update Upload OS Image Update OS

@ 0S Update has completed!

The window below may appear for the following reasons:
1. Incompatible OS version.

2. |IP address changed after OS update.
3. The OS update process took too long.

Check the device X

Unable to verify the OS update result. Please check the device and verify the OS
update result.

Common reasons:

OS is updated to an incompatible older version
IP address is changed after the OS update

OS update takes longer than expected (3 min.)

If the device is unresponsive, please contact our distributors or via our website.

UMO020001E_20231101 Copyright© 2023 WEINTEK 1IOT LTD. All rights reserved. 16



Chapter 2 How to Use Webview

2.1 Overview

cMT X Series HMI can be monitored and controlled using an internet browser (Windows Edge,
Chrome, or Firefox). Up to 4 users can log in simultaneously.

2.2 Enabling Webview

Log in Easyweb 2.0, open Webview Setting page and toggle on [Enable]. In this page, whether a
password is required for logging in Webview can be set.

Force HTTPS: Enabling this will make Webview use HTTPS.

Use same HTTP port as EasyWeb: Enabling this will make Webview use port 80 to connect to the

VNC server when accessed via HTTP.

AN +

192.168.2.13 % O @ =mstum i

- HMI Name: Date/Time: Q > admin
\‘o cMT3072XH =
EasyWeb 2.0 3

@ s WebView Setting Web\View w
T Network

Enable c
= Project

Force HTTPS ()
@ Features Use same HTTP port as EasyWeb
® WebView Setting

Use WebView as homepage

User List 0 A Control Only View Only

Automatic Login © Disabled Control User View User

Control User Change password &

View User Change password (&

2.3 Log In Webview using an Internet Browser

Step1l. Open internet browser and enter HMI's Webview address (e.g.: 192.168.2.121
/app/dashboard). In Webview settings, if “Set as homepage” option is selected, then
simply enter the IP address (e.g.192.168.2.121). Webview interface opens after entering
the password.

UMO020001E_20231101 Copyright© 2023 WEINTEK 1IOT LTD. All rights reserved.
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S vt x  +
& C A F=2 | 192168.2.121/app/login?auto=stop - % ®% O @ B =@ :

Control Mode

Step 2. The HMI screen is displayed in the browser window. Certain HMI screen resolutions may
exceed the browser window size. When this happens, to change the view area, drag the
white frame that represents browser window in the lower-right corner and move within
the gray area that represents HMI screen.

[=[@] % ]
S oMT x 4+
C A F=2 | 192.168.2.121/app/dashboard - % 4 OH B =@ :

VNC Viewer run on HMI allows remote monitoring devices with VNC Server installed for
flexible operation.

Step 3. The toolbar that opens by clicking the three-line icon in the upper-left corner of the
window is shown below. From left to right, the toolbar is separated into three groups of
items.

UMO020001E_20231101 Copyright© 2023 WEINTEK 1IOT LTD. All rights reserved.
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In the first group, the HMI screen can be resized to fit in the browser window, or
displayed with HMI’s actual screen resolution.

In the second group, the position of the icon that opens the toolbar and the dragging
panel that moves the view area can be changed.

In the third group are the system settings icon and the logout icon.

8 B

0 Note

B When “Set as homepage” is selected in Webview, the Webview interface can be opened by
directly entering HMI IP address. When login password is forgotten, please enter

https://HMI IP/admin to return to the default system settings page. This prevents the

situation where Webview functions cannot be used once password is forgotten.

2.4 When Webview Doesn’t Open

When a login attempt fails and the page below shows, try the following ways to troubleshot.

1. Check whether Webview is enabled for the HMI.

2. Check whether the browser supports Webview, and please use recommended browsers such as
Windows Edge, Chrome, or Firefox.

3. Maximum number of users may be exceeded (4 users at a time).

SEIES
S T X 4+

< G ® F=2 | 192.168.2.121/app/dashboard # % O | B =@ :

CONNECTING

T

If it takes a long time to connect.

Possible causes :

1. Webview feature is disabled on this HMI.

2. This browser does not support Webview.

3. Maxinum connections for Webview has been reached.

Windows is a trademark or a registered trademark of Microsoft Corporation in the United States and/or other countries.

CODESYS® is a trademark of CODESYS GmbH.

Other company names, product names, or trademarks in this document are the trademarks or registered trademarks of their respective companies.
This document is subject to change without prior notice.
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