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EasyRemotelO

1. Overview

L_I WE!NTEK

EasyRemotelO is a tool designed for configuring Weintek iR-ETN/iR-ETN40R devices.

Through the EasyRemotelO interface, users have the capability to configure

iR-ETN/iR-ETN40R’s IP address and various parameters, and monitor or modify

device values. Additionally, the export feature of EasyRemotelO facilitate users,

especially those using EasyBuilder Pro, CODESYS, or EtherNet/IP devices, in

generating essential files for establishing a connection with iR-ETN/iR-ETN40R.

2. Quick Start

1.

Launch EasyRemotelQ, click on [Automatic Scan].

Project Window

&7 EasyRemotelQ
fle Edit View Online Tools Help

BEES8NEEHEBB
& | Automatic Scan || 45t biop | Pt |

== Mo =

Channel Name Type

Online Falue

Froject Falue

Log Message

Date Time

2018-02-07 16:10:30.753 EasyRemotelO is started. ProductVersion:1.0.0.0

Message

2.

Select [Overwrite the project], and click [Scan]. The default IP of
iR-ETN/iR-ETN4O0R is 192.168.0.212. Please make sure the PC is in the same

domain: 192.168.0.*.*.
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3.

4.
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Automatic Scan

Mame

IP Address

Mac Address

Sub Mask

X

@ Owerwrite the project

(7 Add to project

4

1

o) o)

The iR-ETN/iR-ETN40R can be found in Automatic Scan window. Select the
iR-ETN/iR-ETN40R you want to configure and click OK.

Automatic Scan

Sub Mask

X

Mame IP Address MWac Address
> [] iR-ETN 1921682183  00-0C-26-01-02-04 255.255.252.0 | @ Overwrite the project
. [[] TONY2 1021681136  00-0C-26-12-34-5B 2552552520 | & add 1o project
> [[] TONYL 1921681138  00-0C-26-12-34-5A 255.255.252.0
Sran
4 UL 3
[ ok || Come |

The iR-ETN/iR-ETN40R and the module’s information will be shown as below.
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& EasyRemotelO (E=8 Fo8 =
Eile Edit View Online Tools Help

BB RB IS E8RNEEHBE
Project Window 8 x

10/ Modules | Addiessbap | Paramster
4 [ iR-ETN (192.168.2183)
@@ #1 iR-DM16-P Channel Name Type Online Value Project Valve
4 iR-ETN (192.168.2.183)
#1:iR-DM16-P DI/ DO 0x00
Log Message J x
Date Time Message
2018-02-07 16:21:28.500 Auto scan is successfully completed
2018-02-07 16:10:30.753 EasyRemotelO is started. PraductVersion:1.0.0.0

5. Select [Change IP] under [Online] to change the IP address of iR-ETN/iR-ETN40R
and then click OK.
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d7 EasyRemotel0 [E=8|EcE x|
File Edit View[m]'rao\s Help
Eg) [@ Automatic Scan shiftes K] @ @
Project Window [Z] Compare with Offline Shift+C
Address Map Parameter
4 @ RETN @S B} Download
iR = Onling Velve Project Value
TR el T S —
[}:ﬂ Copy to Project name
Special Commands ct code
Change IP ame IR-ETM
are revision
¥ SstartMonitoring Shift+h | o revicion
Eﬂ Stop Monitoring Shift+0 consumption
TOTrEht power consumption
Power supply
Life guard time 0
iBus continue run oM
MNumber of TCP connected

Mumber of modules

Point Of Digital input
Paint Of Digital output
Mumber Of Analog input
Mumber Of Analog output

Log Mesmage 5 X

Date Time Message

2018-02-07 16:21:28.500 Auto scan is successfully completed

2018-02-07 16:10:30.753 EasyRemotelQ is started. ProductVersion:1.0.0.0

ChangeIP address IEI
Mac Address : 00-0C-26-01-02-04

IPddress: 107 | 168 2 183
SubMask: 255 255 2% 0

[ ox || canel

6. Inthe Project Window, select an iR-ETN/iR-ETN40R and then go to [Parameter]
tab in the right column. Here you can change the related parameters of
iR-ETN/iR-ETN4OR. The actual value of iR-ETN/iR-ETN4O0R is in the [Online Value]

column. The new value should be entered in the [Project Value] column.
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&7 EasyRemotelD o e =]

file Edit View Online Tools Help
PR 2SSy BUEREEH BE

Progect Window 5 X

| I0/Modules | AddmessMap | Pasameter

4 [l iR-ETN (192.168.2.183)
[ #1:iR-DM16-P Channel Name Onling Vealue Project Value

4 iR-ETN (192.168.2.183)
Vendor name
Product code
Host name iR-ETN
Firmware revision
Hardware revision
Power consumption

Current power consumption

Pawer supply

Life guard time o
iBus continue run ON
MNumber of TCP connected

Number of madules

Paint Of Digital input
Point Of Digital output
Mumber Of Analog input
Mumber Of Analog output

Log Mesmage 5 x

Date Time Message

2018-02-07 16:47:13.631 Auto scan is successfully completed
2018-02-07 16:21:28.500 Auto scan is successfully completed

2018-02-07 16:10:30.753 EasyRemotelQ is started. ProductVersion:1.0.0.0

N

Click [Upload] to read the data from iR-ETN/iR-ETN40R and show in
EasyRemotelO.
Click [Download] to write the data in EasyRemotelO to iR-ETN/iR-ETN40R.
File Edit WView Online Toolz Help
BB s B BEH BE

Project Window q X

10/M UP19%9 adress bap | Parsmeter

Eile Edit View Online Toaols Help

PR Sse B0 BRENBE

Froject Wind g X '
fopee o 0 Mod .! ap Parameter
Select the module connected to iR-ETN/iR-ETN4OR in Project Window. In the

%

I0/Modules tab you can read/write inputs and outputs value. Click [Download]
to write the data from EasyRemotelO to iR-ETN/iR-ETN4OR.
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&7 EasyRemotelD

file Edit View Online Tools Help
BB == 0 Bt B 0
Progect Window 5 X
10/ Modules | AddmssMap | Pavameter |
4 [l iR-ETN (192.168.2.183) - -
i #LiR-DM16-P Chanmel Name Tupe Qnline Falue Project Value
4 #1:iR-DM16-P
Digital Input #0 DI
Digital Input #1 2}
Digital Input #2 DI
Digital Input #3 01
Digital Input #4 oI
Digital Input #5 DI
Digital Input #6 2}
Digital Input #7 DI
Digital Output #0 Do 0
Digital Qutput #1 Do 0
Digital Output #2 DO 0
Digital Output #3 Do ]
Digital Output #4 DO 0
Digital Qutput #5 Do 0
Digital Qutput #6 Do 0
Digital Output #7 DO 0
Log Mesmage 5 x
Date Time Message
2018-02-07 16:47:13.631 Auto scan is successfully completed
2018-02-07 16:21:28.500 Auto scan is successfully completed
2018-02-07 16:10:30.753 EasyRemotelQ is started. ProductVersion:1.0.0.0

9.

The parameters of the modules can be changed in Parameter tab.

&7 EasyRemotelD
Edit

File

Progect Window

View Online

ficols
P Z S

Help

00 B B

| I0/Modules | AddmessMap | Pasameter

4 [l iR-ETN (192.168.2.183)
i #1:iR-DM16-P Chawne] Naime Onnline Value Project Value ol
4 #1:iR-DM16-P
Digital input filter time #0 o
Digital input filter time #1 o
Digital input filter time #2 o
Digital input filter time #3 o
Digital input filter time #4 o
Digital input filter time #5 0 3
Digital input filter time #6 o
Digital input filter time #7 o
Digital output error mode #0 Error value
Digital output error mode #1 Error value
Digital output errar mode #2 Error value
Digital cutput error mode #3 Error value B
Digital output errar mode #4 Error value
Digital output error mode #5 Error value
Digital output error mode #6 Error value
Digital autput error mode #7 Errarvalue
Digital cutput eror value #0 Low
Dinital outout ereor value #1 Low A
Log Mesmage 5 x
Date Time Message
2018-02-07 16:47:13.631 Auto scan is successfully completed
2018-02-07 16:21:28.500 Auto scan is successfully completed
2018-02-07 16:10:30.753 EasyRemotelQ is started. ProductVersion:1.0.0.0




EasyRemotelO L_| WE'NTEK

3. Settings
Edit
Add

Network Coupler: Add network coupler manually.

Module: Add module manually.

Online

Automatic Scan

Scan all the iR-ETN/iR-ETN4OR in the same domain.

Compare with Offline

Check whether the devices in EasyRemotelO exist in the same domain.

Compare with Offline [ = |
Item Offline Value Cnline Value
#2: Mon-exist online iR-DI16-K X
EasyRemotelO @ Start Compare
Comparision completed. Configuration is different. Target: iR-COP
! N (192.168.1.225)
[ ok || cansl
Download

Write the value from EasyRemotelQ’s Project Value column to the iR-ETN/iR-ETN4O0R.
Upload

Read the value from iR-ETN/iR-ETN40OR and show it in EasyRemotelO’s Online Value
column.

Copy to project

Read the value from iR-ETN/iR-ETN40R and show it in EasyRemotelO’s Online Value

and Project Value columns.
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[0/ Modules Address Map | Parameter
Chnne] Neame Type Online Falue Project Falue
4 #1:iR-DM16-P

Digital Input #0 oI 0
Digital Input #1 DI 0
Digital Input #2 oI 0
Digital Input #3 oI 0
Digital Input #4 oI 0
Digital Input #5 oI 0
Digital Input #6 DI 0
Digital Input #7 oI 0
Digital Qutput #0 DO 0 0
Digital Qutput #1 DO 0 0
Digital Output #2 DO 0 0
Digital Output #3 DO 0 0
Digital Qutput #4 DO 1 1
Digital Qutput #3 DO 0 0
Digital Output #6 DO 0 0
Digital Qutput #7 DO 0 0

Special Commands

Restart Device: Restart iBus and module.

Restart iBus: Restart iBus only.

Reset to default (except IP setting): Reset all the parameters, except IP settings, to

default.

Special Commands

Restart Device
Restart iBus
Reset to default{except IP Setting)

=3

Hend

Change IP

Change the IP address of iR-ETN/iR-ETN4OR.

Change IP address \E\
Mac Address : 00-0C-26-04-05-06
IP hddress: 192 168 1 225
SubMask: 255 255 252 O

OK i | Cancel
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Start Monitoring

Start monitoring iR-ETN/iR-ETN4OR. (Read only)
Stop Monitoring

Stop monitoring iR-ETN/iR-ETN4O0R.

Tools
Modbus
Allows users to run an online MODBUS TCP/IP client on the PC.

Modbus Communication

Communication Setup

IF Address : 192 , 168 . 1 . 40 SlaveID: |0

Protocol :  |Modbus TCP

Pre_defined : [[1.F'.ead] Digital input V] [ ]
Function : [Read Discrete Inputs v]
Address: 0 Quantity 1 1

Response

Hex Dec ASCII BIM
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4. Analog Module
Displaying Channel Value

I__“v WE!NTEK

All channel values are displayed when clicking the [Start Monitoring] button in the

I0/Modules tab.

Address Map Parameter

Channel Name Type Cinling Value Froject Value
W #3:iR-AId-VI
Analog Input #0 Al 0
Analog Input #1 Al 0
Analog Input #2 Al 0
Analog Input #3 Al 0
Writing Channel Value

All channel values are displayed when clicking the [Start Monitoring] button in the

I0/Modules tab.

Specify [Project Value] and then click [Download], the specified value will be written

into [Online Value].

0/ Modvles  Address Map Parameter

Channel Name Type Cinline Valve Froject Value
o F2R-AC-VI

Analog Output #1 AO 0 0
Analog Qutput #2 Al 0 0
Analog Output #3 AC 0 0

Configuring Parameters

Click [Upload All] to read all parameters which are displayed in the Parameter tab.

10 /Modulss  AddressMap

Chanmel Name Oling Vale Project Falue ~
v #3R-AI4-VI
Product Code (425
Firmware Revision 1.0.00
Hardware Revision 1.0.00
Power Consumption 035W
Point of Digital Input 0
Point of Digital Qutput 0
MNumber of Analog Input 4
MNumber of Analog Output 0
Input Mode 20 Close Close 4
Input Mode #1 Close Close &2
Input Mode 2 Close Close v
Input Mode #3 Close Close v
Input Scale Range Upper Limit #0 32000 32000
Input Scale Range Upper Limit #1 32000 32000

Change channel parameter under [Project Value].

10
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10 ! Modules Address Map Parameter

Channel Name Onling Value Project Value L
¥ #3iR-AIM-VI
Product Code w0425
Firmware Revision 1.0.0.0
Hardware Revision 1.0.0.0
Power Consumption 0.35W
Point of Digital Input 0
Point of Digital Qutput 0
Mumber of Analog Input 4
Mumber of Analog Qutput 0
ooz e g 3|
Input Mode 1 Close Close =~
Input Mode #2 Close Close =~
Input Mode #3 Close Close
Input Scale Range Upper Limit #0 32000 32000
Input Scale Range Upper Limit #1 32000 32000

Click [Download] to write from [Project Value] into [Online Value].

10 /Modules  Address Map Parameter

Channel Name Online Value Project Value ()
v #3iR-AI4-VI

Product Code (0425

Firmware Revision 1.0.0.0

Hardware Revision 1.0.0.0

Power Consumption 0.35W

Point of Digital Input 0

Point of Digital Qutput 0

MNumber of Analog Input 4

MNumber of Analog Output 0

Input Mode #1 ose Close ~
Input Mode #2 Close Close ~
Input Mode #3 Close Close ~
Input Scale Range Upper Limit #0 32000 32000

Input Scale Range Upper Limit #1 32000 32000

sk For more information about channel parameters, see chapter 6 in
UMO018013E_iR-Axxx-VI_UserManual_20190401_eng.

sk Settings in the Parameter tab are written into the analog module’s registers.

A faster way to start analog module is to configure the parameters using
EasyRemotelO and then import the settings on the coupler.

11
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Initializing Module

[Online] » [Special Commands]

I__| WE!NTEK

Select the analog modules to be initialized, and then click [Send] to restore factory

default.

Special Commands

Restart Device

Restart iBus

Reset to default(except IP Setting)

Rezet to manufacture value (#2: iR-A004-Y1)
Reszet to manufacture value (3: iR-AI04-V])
Reset to manufacture value (£4: IR-4I104-TR)
Reset to manufacture value (7 IR-A104-4T)
Reset to manufacture value (& iR-4AC04-V)
Reset to manufacture value (#17; iR-ACM-Y)
Reset to manufacture value (#13: iR-ACQM-Y)

e,

Cancel

12
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5. Export

Export Tag

When Weintek Remote IO (MODBUS TCP/IP) driver is selected in EasyBuilder Pro,
selecting [Export Tag] in EasyRemotelO can help users quickly build
iR-ETN/iR-ETN4OR related parameters.

1. Launch EasyRemotelO and select [File] » [Export Tag].

[H] EasyRemotelO - O X
File Edit View Online Tools Help
Open Ctrl+0 B2 e MR We iR ©% °F
3 New Ctrl+N
- I0/Moduks  AddmssMop  Perometer  Power Informiation
H seve Ctil+S
B Savehs Chamel Houe Modbus Mapping Onling Talue Project Velne ™
Bport Tog v E1: iR-AMOG-VI
e Product Code 0x7530 0x0635
Firmware Revision 07531 1.000
EEEiEnalEDES Hardware Revision 7532 1000
Power Consumption 07533 035W
Point of Digital Input 07556 ]
Point of Digital Output 07557 [}
Number of Analog Input 0x7558 4
Number of Analog Output 07559 2
Analog Output Error Mode 20 0x1815[0] Error value Error value
Analog Output Error Mode 21 0x1815[1] Error value Error value
Analog Output Error Value 20 0x1819 0 0
Analog Output Error Value #1 01812 0 0
Output Mode 0 Oxde20 =10V 107
Output Mode %1 Oxde2] Close Close
Output Scale Range Upper Limit 20 Oxded 32000 32000
Output Scale Range Upper Limit #1 Oxde25 32000 32000
Output Scale Range Lower Limit 50 Oxde28 -32000 -32000
Output Scale Range Lower Limit #1 Oxdedg -32000 -32000 v
< >

2. Launch EasyBuilder Pro and select [System Parameters] » [New Device] »
[Weintek Remote 10 (MODBUS TCP/IP)].

Device Properties

| Weintek Labs., Inc. - Search

Weintek Built4n CODESYS
Weintek Remote 10 (CANopen

Weintek Remote 10 (MODBUS TCP

3. After importing tags, information about iR-ETN/iR-ETN40R can be found when
creating an object.

—
X
Device : | yeintek Remote I0 (MODBUS TCP{IP) w
Address type : |iR-ETI. Vendar Name
Address: 4
Q|
Address format : .
Name Data type Description &
[ iR-ETN.Vendor Name Undesignated
) iR-ETN.Product Code Undesignated
B iR-ETN.Host Name Undesignated
*To make calculation { | o ip_gn Firmware Revision Undesignated
conversion definition
TagLibrary... | | B iR-ETN.Hardware Revision Undesignated
T | | B iR-ETN.Power Consumption Undesignated
?-E‘I’N.Cur.rent Power Undesignated
onsumption
0 iR-ETN.Power Supply Undesignated
I D CTRIL e Coned T Ll clmmicvim b b
Tag: |iR-EI'N.Vendor MName Ok

13
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Export PLCopenXML

L_| WE!NTEK

Exporting PLCopenXML file can help users quickly build communication parameters
when establishing connection between a CODESYS device and an iR-ETN/iR-ETN40R.
1. Launch EasyRemotelO and select [File] » [Export PLCopenXML].

H

File Edit View

EasyRemotel0

Open -0
New Cl+N
Save Ctrl+S
Save As

Export Tag

Export PLCopenXML

Export EtherNet/IP EDS

Online  Tools  Help

X

I0/Modules  AddvessMap  Porameter  Power Information

Chonnel Name Modbus Mapping Online Valus Project Value

v #1:iR-AMOE-VI
Product Code 0x7530 0x0635
Firmware Revision 07531 1.0.00
Hardware Revision 07532 1.0.00
Power Consumption 0x7533 0.35W
Point of Digital Input 0x7556 0
Point of Digital Output 0x7557 0
Number of Analog Input 0x7558 4
Number of Analog Output 0x7559 2
Analog Output Error Mode #0 0x1815(0] Error value Error value
Analog Output Error Mode #1 0x1815[1] Error value Error value
Analog Output Error Value #0 0x1819 0 0
Analog Output Error Value £1 0x181a 0 0
Output Mode #0 Oxde20 =10V 107
Output Mode #1 Oxde2l Close Closs
Output Scale Range Upper Limit 20 Oxde2d 32000 32000
Output Scale Range Upper Limit #1 Oxde2s 32000 32000
Output Scale Range Lower Limit #0 Oxde28 -32000 -32000
Output Scale Range Lower Limit #1 Oxde29 -32000 -32000 v

<

>

Select the device and set the file version to be exported. The file version should

be the same as that of the Modbus_TCP_Slave in CODESYS IDE. The version used

in the example below is 3.5.16.0.

Channel Select

<

iR-ETN (192.168.3.212)
[ iR-ETN (192.168.1.135)
(] iR-ETN (192.168.1.136)

Select All Unselect Al Export file version : |33, 16.0

CK

Cancel

14
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[ Add Device =

Mame |Mndbus_TCP_SIaue

Action
(@) Append device () Insert device Flug device () Update device
|String for a full text search | Wendor | «all vendors> v
Mame Vendor Wersion Description
= ﬂi Fieldbuses
=/ Wil Modbus
= WEE Modbus TCP Slave
ﬂj |Mudbus TCP Slave 35 - Smart Software Solutions GmbH 3.5.16.0 A generic Modbus ¢
m Modbus TCP Slave 35 - smart Software Solutions GmbH 4,1.0.0 A generic Modbus ¢
< >
Group by category Display all versions (for experts only) [_] Display outdated versions

3. Launch CODESYS, add [Ethernet] » [Modbus_TCP_Master] device.

Devices > 0 X
=[5 PLCopen¥ML -
= ﬁ Device (Weintek Built-n CODESYS)
=&l PLC Logic

= a Application

m Library Manager
WF] PLC_PRG (PRG)

= @ Task Configuration
=-g& MainTask

& PLC_PRG
= m Ethernet (Ethernet)
ﬁ |Mndbus_TCP_Master (Modbus TCP Master) |

4. Select [Project] » [Import PLCopenXML] to import PLCopenXML.

15
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Devices SUEIX] | R_ETH_192 168 3 212 X
= ALCopenrt -
= Device (Wentek Buitin CODESYS) General Name Access Type Tigger READ Offset  Length  EorHandiing WRITEOffset  Length
=8l pLcLogic 0 1:IR-AM0S-VI Anlog Input Read Input Registers (Function Code 04) Cyic, t£100ms 1620000 4 Keeplast Value
=) Application Medbus Slave Channel 1 1:ReAMOSVLAndlog Output  Read/Wirte Mltiple Registers (Functon Code 23)  Cydic, t5100ms 1650100 2 KeeplastVaue 1630100 2
i) Lirary Manager —— 2 2 R-DMI6N.Digtal Input Read Discrete Inputs (Function Code 02) Cydc, t#100ms 1620000 s Keeplast Value
9 pic R pRY) 3 2 R-DMIGN.Digital Output(R)  Read Coils (Function Code 01) Cydc, t£100ms 1670000 s Keeplast Value
=B Task configuration ModbusTCPS/ave Parameters 4 2 R-DMI6-N.Digital Qutput(W)  Write Maltple Coils (Function Code 15) Cydic, t%100ms 1620000 8
=& MainTask
8 picPre ModbusTCPSlave /0 Mapping
=@ Ethernet Ethemet)
= (@ Modbus_TCP_Master (Modbus TCP Master) Status

Informatin

5. After importing the file, the selected iR-ETN/iR-ETN40R can be found in the
CODESYS project with the read/write channels and parameters set.
= ﬂj Device (Weintek Built-in CODESYS)
=21 pLE Logic
=1L} Application
m] Library Manager
PLC_PRG (PRG)
= @ Task Configuration
= @ MairTask
H pLC_PRG
= ﬂj Ethernet (Ethernet)
= ﬂj Modbus_TCP_Master (Modbus TCP Master)
[ m_ETN_192_168_1_37_{Modbus TCP Slave)

Export EtherNet/IP EDS

Exporting EtherNet/IP EDS file can generate Electronic Data Sheets of
iR-ETN/iR-ETN4OR.

1. Launch EasyRemotelO and select [File] » [Export EtherNet/IP EDS].

EasyRemotelQ - O x
File Edit View Online Tools Help
Open Curl+0 Bl e @B e R > g
3 New Ctrl«N 8 x
10 ¢ Modules Address Map Powameter Power Information
B save Ctrl+S
B soveds Chansel Neane Modbus Mapping  Online Yalue Project Value  ~
Export oy v #1:iR-AMOB-VI
S —— Product Code 0x7530 0x0635
Firmware Revision 07531 1000
EpeEli LD ES Hardware Revision 0x7532 1000
Power Consumption 0x7533 035W
Point of Digital Input 0x7556 0
Point of Digital Output 0x7557 0
Number of Analag Input 0x7558 4
Number of Analog Output 0x7559 2
Analog Output Error Mode #0 0x1815[0] Error value Error value
Analog Output Errer Mode #1 0x1815[1] Error value Error value
Analog Output Error Value #0 0x1819 0 0
Analog Output Error Value #1 x181a 0 0
Output Mode #0 Oxde20 =10V Hoy
Output Mode #1 Oxde2l Close Close
Output Scale Range Upper Limit 20 Oxde24 32000 32000
Output Scale Range Upper Limit 1 Oxde25 32000 32000
Output Scale Range Lower Limit #0 Ox4e28 -32000 -32000
Output Scale Range Lower Limit #1 Ox4e29 -32000 -32000 v
< >

2.  Import EtherNet/IP EDS in the user interface of EtherNet/IP device. Please see

iR-ETN EtherNet/IP Connection Guide for more information.

16


https://dl.weintek.com/public/iR/eng/UserManual/UM020006E_iR-ETN_EtherNetIP_Connection_Guide_eng.pdf
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